I am considering using derby for a small application. I have installed it with YAST but it is the old 10.3.1.4 version. Does anybody know if fixes are being back ported to this version? It would appear that 10.3.1 & 10.3.2 have been withdrawn by the derby project due to a serious data corruption bug. Is the opensuse 10.3.1.4 the broken code?

I can download 10.5 or the new 10.6 but these get installed outside YAST and complicate upgrades