Results 1 to 4 of 4

Thread: Broken Paraview in 11.3 - nvidia issue

  1. #1

    Default Broken Paraview in 11.3 - nvidia issue

    Dear All,

    Paraview is a visualisation software which is important for my work. It did work under 11.2 with the prop. Nividia drivers. The problem with 11.3 is that the installation of the prop. nividia driver via yast does not work:
    (1) I added the Nvidia repo
    (2) installed nvidia-gfxG02-kmp-desktop and x11-video-nvidiaG02

    During suseconfig, yast briefly shows a warning/error message (?) that
    xorg.conf ist not present (of course not, it is a dir since 11.3).

    After that glxinfo then gives me error messages like that:
    "GLX" missing on display ":0.0"

    For your info, without the prop. nvidia driver, Paraview's "save screen shot" crashes with a segmetation fault. This happened before in 11.2 but was solved by installing the prop. nvidia driver.

    My system (without the prop Nvidia drivers) is currently:
    Linux 2.6.34.7-0.5-desktop x86_64
    System: openSUSE 11.3 (x86_64)
    KDE: 4.4.4 (KDE 4.4.4) "release 3"
    Display Info
    Vendor: nVidia Corporation
    Model: GeForce 8300 GS
    2D driver: fbdev
    3D driver: swrast (No 3D Acceleration) (7.8.2))

    If I cannot solve this problem, I very reluctantly have to switch the OS...
    Any help is very much appreciated.

    Best regards,

    K

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Broken Paraview in 11.3 - nvidia issue

    I highly recommend that you consider loading the nVidia binary proprietary video driver, done the hard way. You will NOT use the nvidia repository or the two installed files that you listed and I would undo anything you had tried before. Here are the things I recommend to any nVidia graphics card user:

    You should look at this document before proceeding on...

    SDB:Configuring graphics cards - openSUSE

    Then, take a look at the procedure I use to install the nVidia driver as I install openSUSE 11.3:

    1. During the install, when you have the option to change your booting setup, I add nomodeset to the kernel load command for the normal load/start of openSUSE. This kernel startup option is already present for the Failsafe selection for openSUSE.
    2. During the first start of openSUSE, I download the latest nVidia Video driver to the downloads folder.
    3. I change/save the System/Kernel option NO_KMS_IN_INITRD from "No" to "Yes" in the /etc/sysconfig Editor in Yast.
    4. I do an update of openSUSE on the first run of openSUSE and then a restart/reboot.
    5. In grub OS selection I add the command line option "3" to the openSUSE start line so that I just go to the run level three terminal prompt.
    6. I login in as root and change to the /home/user/Downloads folder.
    7. I run/install the NVIDIA video driver using "sh ./NVIDIA-Linux-x86_64-260.19.21.run" and answer all questions as appropriate for my system.
    8. Type in reboot at terminal prompt to restart the system with new video driver.

    Read through it all, consider what it means and the procedure you might use in your present situation. I use openSUSE 11.3, kde 4.4.4 and the most recent nVidia video driver and everything works like a champ. I can also say that you can use the same driver in openSUSE 11.2 and you can even load the KDE version there as well. openSUSE 11.2 is still supported, though said support is limited. Anyway, let us know what your next question might be.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: Broken Paraview in 11.3 - nvidia issue

    Hi James,

    Thank you for the quick reply.

    The downside of compiling it (the "hard way") is that
    you end up without an X server after an online update (I have found this annoying in the past when the
    Suse was still at 10.x).
    the suspense modes might not work (this has been an issue in the past)
    you might need something like nividia-xconfig to configure your X (since sax2 has gone) which I don't have
    at the moment

    So, I would consider it a workaround;
    The crucial question is whether I should mess up my easy-to-update system or to dual-boot to something else
    where Paraview works out of the box (Windows in the worst case).

    I had hoped for a direct Yast type solution as it was available before 11.3.

    Thanks a lot again.

    Best regards,

    K

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Broken Paraview in 11.3 - nvidia issue

    Hi James,

    Thank you for the quick reply.

    The downside of compiling it (the "hard way") is that
    you end up without an X server after an online update (I have found this annoying in the past when the
    Suse was still at 10.x).
    the suspense modes might not work (this has been an issue in the past)
    you might need something like nividia-xconfig to configure your X (since sax2 has gone) which I don't have
    at the moment

    So, I would consider it a workaround;
    The crucial question is whether I should mess up my easy-to-update system or to dual-boot to something else
    where Paraview works out of the box (Windows in the worst case).

    I had hoped for a direct Yast type solution as it was available before 11.3.

    Thanks a lot again.

    Best regards,

    K
    You are very right that kernel updates can upset the video driver install. I have taken two approaches to the problem. I keep more than one kernel loaded and thus kernel updates do install a new kernel, but I can opt to load the old one until I have time to reload the video driver. Second, I use the opportunity to look for and find the latest nVidia video driver and load it if it is newer at the same time. To maintain more than one kerenl, you make an edit to the following file. It does contain many options and I am only showing the one you modify:

    edit the file /etc/zypp/zypp.conf as root to say:

    Code:
        ##
        ## Packages which can be installed in different versions at the same time.
        ##
        ## Packages are selected either by name, or by provides. In the later case
        ## the string must start with "provides:" immediately followed by the capability.
        ##
        ## Example:
        ##    kernel                - just packages whith name 'kernel'
        ##    provides:multiversion(kernel)   - all packages providing 'multiversion(kernel)'
        ##                      (kenel and kmp packages should do this)
        ## Valid values:
        ##    Comma separated list of packages.
        ##
        ## Default value:
        ##    empty & you only need one command, select the one for your openSUSE version.
        ##
        # multiversion = provides:multiversion(kernel)
    
        # ( Use this for openSUSE 11.2 & it works with 11.3)
        multiversion = kernel-desktop 
    
        # (Use this for openSUSE 11.3)
        multiversion = provides:multiversion(kernel)
    In KDE the menu Run Command you use to edit the file would be:

    Code:
    kdesu kwrite /etc/zypp/zypp.conf
    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •