Results 1 to 7 of 7

Thread: Xvnc doesn't work (kde4.4.4)

  1. #1
    Join Date
    Nov 2010
    Location
    Hungary
    Posts
    23

    Default Xvnc doesn't work (kde4.4.4)

    Dear All,

    I would like to do remote access to my OpenSuSE 11.3 with vnc but it doesn't work.
    OpenSuSE 11.3 x32
    updated time: 18.11.2010
    Kde version: 4.4.4
    Kernel: 2.6.34.7-0.5-xen
    Xvnc: xorg-x11-Xvnc-7.5_1.8.0-10.3.1

    log:
    18/11/2010 10:01:34 key events received 1, pointer events 159
    18/11/2010 10:01:34 framebuffer updates 18, rectangles 471, bytes 529608
    18/11/2010 10:01:34 LastRect markers 3, bytes 36
    18/11/2010 10:01:34 cursor shape updates 8, bytes 396
    18/11/2010 10:01:34 cursor position updates 1, bytes 12
    18/11/2010 10:01:34 tight rectangles 459, bytes 529164
    18/11/2010 10:01:34 raw bytes equivalent 6484752, compression ratio 12.254711
    18/11/2010 10:01:34 GenerateVncDisconnectedEvent
    Error: Can't open display: :1
    Could not connect to D-Bus server: org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /tmp/dbus-1k20Tjlord: Kapcsolat elutastva
    startkde: Shutting down...
    kdeinit4_wrapper: Warning: connect(/home/<user>/.kde4/socket-201xen/kdeinit4__1) failed: : No such file or directory
    Error: Can not contact kdeinit4!
    startkde: Running shutdown scripts...
    kded4: Fatal IO error: client killed
    xprop: unable to open display ':1'
    xprop: unable to open display ':1'
    startkde: Done.
    kdeinit4: sending SIGTERM to children.
    kdeinit4: Exit.

    Has somebody idea, what is the problem ?


    Thanks for help.

    Attila

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Xvnc doesn't work (kde4.4.4)

    There are two main ways for setting the VNC server in openSUSE. One is to start it using command "dbus-launch vncserver". The other is in yast --> xinetd GUI. Which are you using? If you are using the command line method of starting the VNC server, this tutorial covers a bunch of configuration bits and pieces: TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Nov 2010
    Location
    Hungary
    Posts
    23

    Default re: Xvnc doesn't work (kde4.4.4)

    Thanks, but the solution way is tigervnc. tightvnc not so good.

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Xvnc doesn't work (kde4.4.4)

    Quote Originally Posted by amaxiprivate View Post
    Thanks, but the solution way is tigervnc. tightvnc not so good.
    Tigervnc is not in our repos as an RPM so it would be very difficult for new users to install. Moreover, TightVNC has been integrated with openSUSE (obviously with mixed success) and Tigervnc would not be able to function as well because it has not been integrated (de-bugged).
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,491
    Blog Entries
    37

    Default Re: Xvnc doesn't work (kde4.4.4)

    My mother's PC in Canada is running a 64-bit openSUSE-11.3 (KDE4). My current main desktop PC here in Europe is running a 64-bit openSUSE-11.3 (KDE4).

    Less than 3 hours ago I was accessing her PC's desktop with vnc, from a continent away, fixing a minor Skype problem on her PC, and training her on some desktop things. I've been doing this successfully since November last year (when I installed 11.3 on her PC), and doing this for years when her PC had openSUSE-11.1. I've always used the same command line technique (for launching vnc where I pipe the connection through ssh).

    But I don't use tigervnc. I use x11vnc and vncviewer. The method I use works well for KDE. It does not work with Gnome.

  6. #6
    Join Date
    Mar 2009
    Location
    Sydney AU
    Posts
    147

    Default Re: Xvnc doesn't work (kde4.4.4)

    This simple KDE way has also worked well for me.

    I have been connecting to server openSUSE-11.3_32 (KDE4-LXDE) from client openSUSE-11.3_64 (KDE4), both on home LAN in my case.

    But since installing openSUSE-11.4_64 (KDE4) on the client box (with same network and firewall settings) the vcnviewer hangs (with no output) and times out without generating a vnc X-window display. The KRDC GUI also hangs.

    I have re-read the x11vnc man page; swerdna's How To and the developer's guide all to no avail.

    Most likely user error but perhaps something relevant is changed in openSUSE-11.4?

  7. #7
    Join Date
    Mar 2009
    Location
    Sydney AU
    Posts
    147

    Default Re: Xvnc doesn't work (kde4.4.4)

    Still puzzled about this. However this post helped.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •