Results 1 to 9 of 9

Thread: ./Xdefaults

  1. #1

    Default ./Xdefaults

    Does SuSE 11.3 hava a problem reading Xdefaults? I can't get any term (aterm/xterm/etc) to read from the file. I would post my Xdefaults but it's so missed up at this point...

    If this is an issue with suse please comment. If not, ignore me and I'll figure it out.


    TTFN
    John

  2. #2
    Join Date
    Jun 2009
    Location
    Pennsylvania, USA
    Posts
    233

    Default Re: ./Xdefaults

    ogbi-web kenobi wrote:

    >
    > Does SuSE 11.3 hava a problem reading Xdefaults? I can't get any term
    > (aterm/xterm/etc) to read from the file. I would post my Xdefaults but
    > it's so missed up at this point...
    >
    > If this is an issue with suse please comment. If not, ignore me and
    > I'll figure it out.
    >
    >


    AFAIK none of the ?term programs read ~/.Xdefaults or ~/.Xresources
    directly, but use the resources that were set up by xrdb at login/startx
    time.

    What have you tried to get xterm to do your bidding?



  3. #3

    Default Re: ./Xdefaults

    I'm trying to do what I "thought" .Xdefaults/.Xresources were for; customize font color, background, etc. All I get with xterm is the default white on black. Aterm, I was simply seeing if it would work. I don't know where it is getting a green background from.

    As far as use, aterm|xterm, I could care less which I use, the thing I normally have and am use to is a borderless/transparent term on my desktop (for quick use). For some reason SuSE 11.3 wont cooperate!

    This isn't a big deal, but after tinkering with this issue on and off for a few weeks, I thought... maybe it's not me and started blaming it on the computer ;-)


    Here's my .Xdefaults: It's a mess.
    ! If changing things in this file doesnt result in changes in your term
    ! you should run 'xrdb -load ~/.Xdefaults'

    !-------------------------------------------------------------
    xterm*eightBitInput: false
    xterm*scrollTtyOutput: false
    xterm*scrollKey: true
    xterm*saveLines: 2048

    xterm*Scrollbar*thickness: 5
    xterm*Scrollbar*background: #000000
    xterm*Scrollbar*foreground: #4e71ad

    xterm*background: black
    xterm*foreground: black
    !xterm*reverseVideo: true
    xterm*reverseVideo: false

    !-------------------------------------------------------------
    *VT100.eightBitInput: false
    *VT100.scrollTtyOutput: false
    *VT100.scrollKey: true
    *VT100.saveLines: 1000

    *VT100.Scrollbar.thickness: 5
    *VT100.Scrollbar.background: #c6c6c6
    *VT100.Scrollbar.foreground: #4e71ad


    !black
    *color0: #000000
    !red
    *color1: #880000
    !green
    *color2: #008800
    !yellow
    *color3: #888800
    !blue
    *color4: #0808ff
    !purple
    *color5: #880088
    !cyan
    *color6: #008888
    !white
    *color7: #aaaaaa

    !bright-black
    *color8: #666666
    !bright-red
    *color9: #ff0000
    !bright-green
    *color10: #00ff00
    !bright-yellow
    *color11: #ffff00
    !bright-blue
    *color12: #5555ff
    !bright-purple
    *color13: #ff00ff
    !bright-cyan
    *color14: #00ffff
    !bright-white
    *color15: #ffffff



    ! Color section

    !xterm*background: #000000
    !xterm*foreground: #cfcfcf
    !xterm*cursorColor: #cdc092

    ! Nice for manpages
    !xterm*underLine: on
    !xterm*colorMode: on
    xterm*colorBD: lightyellow
    !xterm*colorBDMode: off
    xterm*colorUL: blue
    !xterm*colorULMode: on

    xterm*dynamicColors: on
    xterm*highlightSelection: true

    !xterm*eightBitInput: false
    xterm*metaSendsEscape: true
    !xterm*oldXtermFKeys: true
    xterm*charClass: 33:48,35-38:48,39:43,42-47:48,58-59:48,61:48,63-64:48,126:48
    !xterm*charClass: 46-47:48,58:48,64:48,63:48,95:48,126:48,61:48,37:48,35:48,43:48,36:48

    ! Other settings

    xterm*VT100.Translations: #override \
    <Key>BackSpace: string(0x7F)
    !\n\
    ! <Key>Delete: string("\033[3~")\n\
    ! <Key>Home: string("\033OH")\n\
    ! <Key>End: string("\033[4~")
    ! <Key>Home: string("\033[1~")\n\
    xterm*ttyModes: erase ^?

    ! Suggested by denek
    ! *VT100*backarrowKey: false

    !xterm*backarrowKeyIsErase: true
    !xterm*backarrowKey: true
    !xterm*borderWidth: 0 doesnt do anything
    xterm*internalBorder: 0
    !xterm*modifier: alt
    !xterm*saveLines: 2048
    xterm*scrollBar: false
    !xterm*titeInhibit: true

    xterm*renderFont: false
    !xterm*faceName: terminus
    !xterm*faceName: fixed
    !xterm*faceSize: 8
    xterm*font: -xos4-terminus-medium-r-normal-*-12-*-*-*-*-*-*-*
    !xterm*font: -xos4-terminus-medium-r-normal-*-24-*-*-*-*-*-*-*
    !xterm*font1: -xos4-terminus-medium-r-normal-*-24-*-*-*-*-*-*-*
    xterm*font2: -misc-fixed-medium-r-normal-sans-9-90-75-75-m-50-iso8859-1
    !xterm*font3: -xos4-terminus-medium-r-normal-*-24-*-*-*-*-*-*-*
    !xterm*font4: -xos4-terminus-medium-r-normal-*-24-*-*-*-*-*-*-*
    !xterm*font5: -xos4-terminus-medium-r-normal-*-24-*-*-*-*-*-*-*
    !xterm*font6: -xos4-terminus-medium-r-normal-*-24-*-*-*-*-*-*-*
    !xterm*font7: -xos4-terminus-medium-r-normal-*-24-*-*-*-*-*-*-*
    !xterm*font8: -xos4-terminus-medium-r-normal-*-24-*-*-*-*-*-*-*
    xterm*termName: xterm

    !xterm*renderFont: true
    !xterm*faceName: fixed
    !xterm*faceSize: 8
    !xterm*termName: Monotone

    !xterm*faceName: Vera sans mono
    !xterm*faceSize: 15
    !xterm*termName: xterm-xfree86

    !
    ! These are aterm specific
    !

    ! <lizr> aterm*font: -xos4-terminus-medium-r-normal--16-160-72-72-c-80-iso8859-1
    ! <lizr> aterm*transparent: true
    ! <lizr> aterm*shading: 50
    ! <lizr> aterm*fading: 25
    ! <lizr> aterm*cursorColor: white
    ! <lizr> aterm*scrollBar: off
    ! <lizr> aterm*foreground: darkgray
    ! <lizr> aterm*background: black


    !Aterm*pointerColor: black
    !Aterm*transparent: false
    !Aterm*shading: 70
    !Aterm*fading: 80

    !Aterm*textType: or
    !Aterm*tintingType: invert
    !Aterm*tinting: magenta
    !Aterm*tinting: grey40

    Aterm*cutchars: !""$%''()*+,;<>[\]^`{|}
    Aterm*font: fixed\ 8
    !Aterm*font: -xos4-terminus-medium-r-normal--16-160-72-72-c-80-iso8859-1
    !Aterm*font: ter-124b
    Aterm*loginShell:true
    Aterm*transparent:true
    Aterm*shading:40
    Aterm*background:Black
    Aterm*backgroundPixmap : ~/Pictures/goth.jpg
    Aterm*foreground:White
    Aterm*scrollBar:true
    Aterm*scrollBar_right:true
    Aterm*transpscrollbar:true
    Aterm*saveLines:32767
    !Aterm*font:*-*-fixed-medium-r-normal--*-110-*-*-*-*-iso8859-1
    Aterm*boldFont:*-*-fixed-bold-r-normal--*-*-110-*-*-*-*-iso8859-1


    rxvt*font: ter-124b
    rxvt.termName: rxvt

    ! These are for a tranparent mouse in XFree86 4.3 and later
    Xcursor.size: 16
    Xcursor.theme: whiteglass

    ! XDvi
    XDvi*mfMode: ljfour
    XDvi*pixelsPerInch: 1200
    XDvi*shrinkFactor: 8
    !XDvi*paper: a5
    XDvi*wwwBrowser: x-www-browser
    XDvi*thorough: true
    XDvi*foreground: #202020
    XDvi*background: #eeeeee
    XDvi*underLink: true
    XDvi*font: ter-120b


    TTFN
    John

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,499
    Blog Entries
    2

    Default Re: ./Xdefaults

    With KDE installed,

    I made all those "appearance" customizations from within the Konsole GUI, clicking on "Edit Profile"

    Yes, I found the default black lettering on white background strange...

    Looks like those edits only apply to BASH, not xterm if it makes a diff to you...

    HTH,
    Tony

  5. #5

    Default Re: ./Xdefaults

    Quote Originally Posted by ogbi-web_kenobi View Post
    Does SuSE 11.3 hava a problem reading Xdefaults? I can't get any term (aterm/xterm/etc) to read from the file. I would post my Xdefaults but it's so missed up at this point...
    If this is an issue with suse please comment. If not, ignore me and I'll figure it out.
    Not openSUSE has the problem but KDE. Create the file xresources.rc.sh (the name is up to you) in ~/.kde4/Autostart (create this directory if needed) with the following or a similar content (depending on the file you're using in your system):

    Code:
    #!/bin/bash
    xrdb /etc/X11/xinit/.Xresources
    It works most of the time but not always. However Xresources settings don't survive a new session. You'll have to close aterm an open it again.

    * I forgot to say that you have to make this file executable.

  6. #6

    Default Re: ./Xdefaults

    Quote Originally Posted by tsu2 View Post
    With KDE installed,
    I made all those "appearance" customizations from within the Konsole GUI, clicking on "Edit Profile"
    Such settings apply to kde konsole, not to other (older) terminals like aterm, xterm, rxvt, wterm, etc, all using Xresources.

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: ./Xdefaults

    ogbi-web kenobi wrote:
    > I'm trying to do what I "thought" .Xdefaults/.Xresources were for;
    > customize font color, background, etc.


    there are about a thousand instances of "color" in man xterm, follow
    them to find jillion of ways to specify your color choices as command
    line options:

    xterm [options]

    or, you could make an alias..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  8. #8

    Default Re: ./Xdefaults

    Quote Originally Posted by ogbi-web_kenobi View Post
    Here's my .Xdefaults: It's a mess.
    ! If changing things in this file doesnt result in changes in your term
    ! you should run 'xrdb -load ~/.Xdefaults'
    Did you try that? Then exit and restart aterm.

  9. #9

    Default Re: ./Xdefaults

    Don't mean to dig up an old post, but I just wanted to update how this turned out and the lessons I've learned.

    Let's start with the simple: Xterm. The reason I couldn't get Xterm to read(and yes it does indeed read) from .Xdefaults is Xterm was taking on KDE colors because I had "Use KDE fonts and colors" checked in the Fonts configuration of "Configure Desktop". Once I unchecked that everything was fine. Simple!

    Aterm was a different story. It boils down to this. If you want pixmap support or anything a configuration option you have to install the AfterStep libs. Which means installing the AfterStep WM. Something I decided wasn't worth the eye candy. Yakuake is better, simplier, and is an F12 away.

    Sumed up Xterm configured. Aterm, not worth installing another WM I wouldn't ever use.

    Lessons learned: Sometimes you have to weigh the worth of the eye candy by the amount of trouble and performance it's going to cost. "Free as in Freedom of Speach". But it all comes with a cost.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •