Results 1 to 8 of 8

Thread: Shutdown fails to turn off the PC

  1. #1
    Join Date
    Nov 2010
    Location
    Florence, Tuscany
    Posts
    2

    Default Shutdown fails to turn off the PC

    Hallo,
    this problem is a well known one as far as I have read, but the solution is yet to come.
    I formatted and installed OpenSuse 11.3 KDE as the only OS on a PC with 768 RAM, two Hard Disks (6+8 GB), mobo Abit BE6, processor Celeron Coppermine 1100Mhz (with slotket adapter), video card Matrox G400+, Sound Blaster Live! Value.
    HD 1 is set root and ext4 + 1 GB swap, HD2 is /home ext3.

    The live OpenSuse CD worked fine, shutdown turns off the power, while the installed one won't. I formatted twice, and the problem persist. Reboot works fine.
    At shutdown, the hard disks are turned off while the screen and power are still on, so I have to press the power button to turn off completely.
    Yesterday I wasted all the day with this problem without solving it, I've read many threads but no solution worked. That PC obviously worked fine with both Windows 98 and XP.
    Those problems are in the "out of the box" installation, without any setting altered.
    I've tried disabling ACPI, PM control by APM, and power management features in the bios (latest 2001's Award bios for this old mobo).
    I've set alternatively pci=noacpi, nosmp, apm=power-off, acpi=force in GRUB options. I've updated the distro. I've set value poweroff for HALT in etc/sysconfig. Nothing changed.
    I've also tried macumba and ancient celtic cerimonies, yet they didn't work.

    Is it possible to solve this problem or it's a known unsolved bug?

    Loading OS screen:


    Those are the final screens after shutdown where it stops.


    The final screen:

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Shutdown fails to turn off the PC

    On 2010-11-17 13:06, Onod wrote:
    >
    > Hallo,
    > this problem is a well known one as far as I have read, but the
    > solution is yet to come.


    /etc/sysconfig/shutdown

    HALT="auto"

    Try changing that. Notice that disabling acpi will cause those symptoms, no
    poweroff. I have seen a more detailed poweroff adjustment in the
    hibernation control (bios vs platform), but I don't see it here.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Shutdown fails to turn off the PC

    Onod wrote:

    > Is it possible to solve this problem or it's a known unsolved bug?


    let me ask: was the machine like this from the very first time you
    tried to shutdown?

    or, did it work ok for a while, and then suddenly stopped closing the
    power?

    it seems you have tried most of the things that usually might have an
    impact....

    but to answer your (quoted) question above: you can probably find that
    answer by searching the bugzilla database, begin here:
    http://en.opensuse.org/Submitting_Bu...ching_for_bugs

    and, a good workaround might be in there....if so, please post it here
    for the next Abit BE6 trail tracker..

    but, i can give you a last resort work around:

    when you see the screen stopped at "System halted." press the power
    button to complete the shutdown...[remember, a full automatic shutdown
    of power is a relatively new thing, less than ten years old, so . . .]

    and, you can hope that 11.4 fixes the issue..

    in fact, you might wanna try installing openSUSE 11.4 Milestone 3 and
    see if the problem is there too...and, if it is be SURE and log a bug
    against it: http://software.opensuse.org/developer/

    otherwise, the bug may never be addressed..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  4. #4
    upscope NNTP User

    Default Re: Shutdown fails to turn off the PC

    DenverD wrote:

    > Onod wrote:
    >
    >> Is it possible to solve this problem or it's a known unsolved bug?

    >
    > let me ask: was the machine like this from the very first time you
    > tried to shutdown?
    >
    > or, did it work ok for a while, and then suddenly stopped closing the
    > power?
    >
    > it seems you have tried most of the things that usually might have an
    > impact....
    >
    > but to answer your (quoted) question above: you can probably find that
    > answer by searching the bugzilla database, begin here:
    > http://en.opensuse.org/Submitting_Bu...ching_for_bugs
    >
    > and, a good workaround might be in there....if so, please post it here
    > for the next Abit BE6 trail tracker..
    >
    > but, i can give you a last resort work around:
    >
    > when you see the screen stopped at "System halted." press the power
    > button to complete the shutdown...[remember, a full automatic shutdown
    > of power is a relatively new thing, less than ten years old, so . . .]
    >
    > and, you can hope that 11.4 fixes the issue..
    >
    > in fact, you might wanna try installing openSUSE 11.4 Milestone 3 and
    > see if the problem is there too...and, if it is be SURE and log a bug
    > against it: http://software.opensuse.org/developer/
    >
    > otherwise, the bug may never be addressed..
    >

    I have same problem with both 11.3 and 11.4 mS1, installed ms3 and have
    test shutdown yet. I can tell you shutdown still works fine in 11.2.
    Have have all three version on this system on a separate disk drive for
    each. See bugzilla ticket#619754 opened 7-3-2010.

    https://bugzilla.novell.com/show_bug.cgi?id=619754

    Only thing I have noticed is the first time I do a kernel update and
    then as root shutdown -h now it shuts down. after that it does not. This
    started doing this with first update of 11.3 and continues with each
    update. 11.4 has done it since first install. When I installed 11.4 MS3
    I completely formatted everything except /boot.

    My Nvidia card drivers are:

    nvidia-gfxG02-kmp-default-260.19.12_k2.6.34.0_12-22.1.x86_64
    x11-video-nvidiaG02-260.19.12-23.1.x86_64
    nvidia-texture-tools-2.0.6-7.2.x86_64
    nvidia-settings-256.35-0.pm.1.1.x86_64

    If you find a fix please post it. I've been thru everything except BIOS
    update (Intel does not list any fix in later BIOS's that appear to
    effect power down (11.2 still shuts down)..
    --
    Russ
    openSUSE 11.3 (2.6.34.7-0.5-default)|KDE 4.5.3 Release 8|
    Intel core2duo 2.5 MHZ,|4GB DDR3|GeForce 8400GS

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Shutdown fails to turn off the PC

    On 2010-11-17 19:00, upscope wrote:
    > I have same problem with both 11.3 and 11.4 mS1, installed ms3 and have
    > test shutdown yet. I can tell you shutdown still works fine in 11.2.
    > Have have all three version on this system on a separate disk drive for
    > each. See bugzilla ticket#619754 opened 7-3-2010.


    I don't know if it is related, because I normally hibernate, not halt the
    machine. After an update, the machine would not power off everytime (some
    did). In:

    /etc/suspend.conf

    I changed:

    ## shutdown method:
    ## platform - go through ACPI BIOS to power off the machine (default on
    ## machines that support it)
    ## shutdown - just power off like after a shutdown
    ## reboot - reboot instead of powering off. For debugging only.
    shutdown method = shutdown


    It was commented out, thus using the default which I read is platform,
    which failed. Now it works everyday - but I'm using 11.2 in this machine.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  6. #6
    upscope NNTP User

    Default Re: Shutdown fails to turn off the PC

    Carlos E. R. wrote:

    > On 2010-11-17 19:00, upscope wrote:
    >> I have same problem with both 11.3 and 11.4 mS1, installed ms3 and
    >> have test shutdown yet. I can tell you shutdown still works fine in
    >> 11.2. Have have all three version on this system on a separate disk
    >> drive for each. See bugzilla ticket#619754 opened 7-3-2010.

    >
    > I don't know if it is related, because I normally hibernate, not halt
    > the machine. After an update, the machine would not power off
    > everytime (some did). In:
    >
    > /etc/suspend.conf
    >
    > I changed:
    >
    > ## shutdown method:
    > ## platform - go through ACPI BIOS to power off the machine (default
    > ## on
    > ## machines that support it)
    > ## shutdown - just power off like after a shutdown
    > ## reboot - reboot instead of powering off. For debugging only.
    > shutdown method = shutdown
    >
    >
    > It was commented out, thus using the default which I read is platform,
    > which failed. Now it works everyday - but I'm using 11.2 in this
    > machine.
    >

    I'll look at that when I get back home this afternoon. My 11.2 system
    works with no modifications. I have not updated it in a long time since
    I'm not using it except to shutdown and I only go as far as the login
    screen most times and shutdown from there.

    Will post result.
    --
    Russ
    openSUSE 11.3 (2.6.34.7-0.5-default)|KDE 4.5.3 Release 8|
    Intel core2duo 2.5 MHZ,|4GB DDR3|GeForce 8400GS

  7. #7
    Join Date
    Nov 2010
    Location
    Florence, Tuscany
    Posts
    2

    Default Re: Shutdown fails to turn off the PC

    Quote Originally Posted by DenverD View Post
    let me ask: was the machine like this from the very first time you
    tried to shutdown?
    From the first time. But, as I wrote above, the Live CD (all of them, not just OpenSuse) shuts down properly. Though I have installed only Suse.

    The good news: the PC has finally shut down. Then I've tried to guess what, of the many things I have set, has been successful.
    I removed previously placed apm=on apm=power-off in the grub string. I've uncommented the line regarding shutdown (thanks to robin_listas, you are the first to point it out) and I have got "platform" option. I think it's that one that made the things work, as all the other setting where tested before without success.

    BIOS settings
    ACPI functions: enabled
    PM control by APM: yes

    /etc/sysconfig/shutdown
    HALT="auto"

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Shutdown fails to turn off the PC

    On 2010-11-19 01:06, Onod wrote:

    > The good news: the PC has finally shut down. Then I've tried to guess
    > what, of the many things I have set, has been successful.
    > I removed previously placed apm=on apm=power-off in the grub string.
    > I've uncommented the line regarding shutdown (thanks to robin_listas,
    > you are the first to point it out) and I have got "platform" option. I
    > think it's that one that made the things work, as all the other setting
    > where tested before without success.


    But that one is only used on hibernation. :-?

    More likely is the apm thing - notice that apm conflicts with acpi, it is
    the old method; but acpi is used for much more than just powering off. When
    both are available default is acpi, unless the bios is blacklisted - I'm
    talking from foggy memory.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •