Results 1 to 7 of 7

Thread: How can I switch my desktop environment from LXDE to XFCE?

  1. #1

    Default How can I switch my desktop environment from LXDE to XFCE?

    Hello everybody,

    I have a laptop that is a little bit older, and OpenSUSE was running pretty heavy on it with the KDE and Gnome desktops (I installed Gnome, tried it for bit, then wiped it and did a clean install with KDE).

    Since it was so sluggish on that laptop, I grabbed a couple live CD's of OpenSUSE with the LXDE and XFCE desktop environments. The XFCE disc doesn't seem to boot at all, which I tried in a couple different computers, and on Virtualbox with the same result.

    LXDE worked fine and I installed it just fine, with hopes of switching over to XFCE later, as I like it better. This brings me to my question, can someone tell me what the easiest way is to switch from the LXDE desktop to XFCE?

    I found a page in the OpenSUSE site that appears to be dedicated to XFCE, here is the link:

    Xfce - openSUSE

    I went there, I clicked on 11.3 on the right hand side, and then clicked on the 1-click install option for X11fce, the first option. It opens the YaST software manager and I followed the prompts, and it finished. All of the packages were installed, except XDM.

    I was expecting that the software would install and configure the desktop, and I'd reboot to see an XFCE login. This was not the case.

    Can someone help me out on what the correct, and safe way would be to switch desktops? I'm still pretty new to linux, and this is an action I know nothing about.

    Thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,498
    Blog Entries
    15

    Default Re: How can I switch my desktop environment from LXDE to XFCE?

    Hi
    Open YaST and in the /etc/sysconfig editor, look for the Desktop->Window manager and in the DEFAULT_WM entry change it to startxfce4 and save, then press ctrl+alt+backspace [twice] to restart the X server.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: How can I switch my desktop environment from LXDE to XFCE?

    To determine if the XFCE desktop is loaded or can be loaded, I would open up YaST / Software Management. Select the View button on the top left and pick Patterns. On the left in the Pattern window, under Graphical Environments, Check the block for XFCE. If it is already checked, you have the desktop, but have never used it. If it is not check, you will load all of the files for XFCE after you check it and say Accept in the bottom right corner.

    Once loaded or if already loaded then log out of your present desktop and in the normal login screen, you need to select the sessions option on the bottom left and pick XFCE. You would need to do this every time you wish to change the desktop environment when you have more than one desktop installed.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: How can I switch my desktop environment from LXDE to XFCE?

    xdm is in package xorg-x11. So it should be installed already. Check in /etc/sysconfig/displaymanager and adjust the value of DISPLAYMANAGER.

    Code:
    # grep 'DISPLAYMANAGER=' /etc/sysconfig/displaymanager
    DISPLAYMANAGER="xdm"
    Did you install the xfce pattern?
    • info:
      Code:
      zypper info -t pattern xfce
    • install:
      Code:
      zypper install -t pattern xfce


    * Sorry guys, you've been to fast for me. Yep, startxfce4 is the correct value, not xdm.
    ** nope, xdm is right (double checked).

  5. #5

    Default Re: How can I switch my desktop environment from LXDE to XFCE?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Open YaST and in the /etc/sysconfig editor, look for the Desktop->Window manager and in the DEFAULT_WM entry change it to startxfce4 and save, then press ctrl+alt+backspace [twice] to restart the X server.
    Wow, thank you both very much! That was WAY easier than I expected! Between both of your responses, I have exactly what I was looking for. I also like knowing that I can switch between them freely, if I have any problem with the other. I've played with quite a few distros for fun, but I never really use the "Sessions" menu in the login screen.

    Thanks again! I now know that switching between session types on the login screen will let me choose my desktop environment, and I now have Xfce (my favorite lightweight desktop) as my default! Thanks!

  6. #6

    Default Re: How can I switch my desktop environment from LXDE to XFCE?

    *** DEFAULT_WM is defined in /etc/sysconfig/windowmanager.

  7. #7

    Default Re: How can I switch my desktop environment from LXDE to XFCE?

    Quote Originally Posted by please_try_again View Post
    xdm is in package xorg-x11. So it should be installed already. Check in /etc/sysconfig/displaymanager and adjust the value of DISPLAYMANAGER.

    Code:
    # grep 'DISPLAYMANAGER=' /etc/sysconfig/displaymanager
    DISPLAYMANAGER="xdm"
    Did you install the xfce pattern?
    • info:
      Code:
      zypper info -t pattern xfce
    • install:
      Code:
      zypper install -t pattern xfce


    * Sorry guys, you've been to fast for me. Yep, startxfce4 is the correct value, not xdm.
    ** nope, xdm is right (double checked).
    Hey, thanks for responding! Those first two responses summed it up. I already had it installed, as I used the 1-click install to install the desktop environment. What I didn't know is that I had to either use the "Sessions" menu at the login screen to switch the desktop environment, or set it as default in the system config editor via YaST.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •