Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Skype wont launch

  1. #1

    Default Skype wont launch

    Hi

    Installed Skype but it wont launch. Running the latest Opensuse Gnome.

    Ive uninstalled it and reinstalled several times but always with the same error.

    When I try to run it from terminal I get this:

    ig@linux-ljqk:~> skype
    skype: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

    Ive just now uninstalled skype and tried reinstalling it again via yast, but now I get the following error

    [PK_TMP_DIR|dir:///var/tmp/TmpDir.xftzR0] Repository already exists.


    Can anyone please give me some pointers?

    Many thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Skype wont launch

    Code:
    skype: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
    You need the package 'libpng12-0'.

    Code:
    [PK_TMP_DIR|dir:///var/tmp/TmpDir.xftzR0] Repository already exists.
    Is that an error message from Skype? Sorry, beats me.

    Edit: sorry, didn't read that it was a YaST message. Show us the output of 'zypper lr -d', please.

  3. #3

    Default Re: Skype wont launch

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Skype is a neat tool, but the RPM that they ship is **** as it does not
    properly list its dependencies. Instead you will need to try to start it,
    figure out what package the missing file is from
    (libpng12-0-32bit-1.2.44-2.1 in your case), and then rinse and repeat
    until all dependencies are met. Complain to Skype about their RPM to help
    with this in the future. Most applications properly list dependencies and
    so an install is literally as simple as `sudo zypper in ./skype.rpm` but
    until they fix that it'll be painful as you're experiencing. If you're
    using 64-bit OpenSUSE make sure you are adding the 32-bit versions of the
    packages you add since Skype is 32-bit only.

    For review, here are the RPMs I installed sometime shortly after Skype,
    though some of them may have been related to other things installed at the
    same time:

    libpng12-0-32bit-1.2.44-2.1
    libqt4-qt3support-32bit-4.6.3-2.1.1
    libqt4-x11-32bit-4.6.3-2.1.1
    libqt4-sql-sqlite-32bit-4.6.3-2.1.1
    Mesa-32bit-7.8.2-1.3
    libmng-32bit-1.0.10-97.1
    libqt4-sql-mysql-32bit-4.6.3-1.3
    libqt4-sql-32bit-4.6.3-2.1.1
    libdrm-32bit-2.4.21-1.2
    liblcms1-32bit-1.18a-8.1
    libmysqlclient_r16-32bit-5.1.46-2.18
    libqt4-32bit-4.6.3-2.1.1
    xorg-x11-libXv-32bit-7.5-1.8

    Good luck.





    On 11/09/2010 04:06 PM, gropiuskalle wrote:
    >
    > Code:
    > --------------------
    > skype: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
    > --------------------
    >
    >
    > You need the package 'libpng12-0'.
    >
    >
    > Code:
    > --------------------
    > [PK_TMP_DIR|dir:///var/tmp/TmpDir.xftzR0] Repository already exists.
    > --------------------
    >
    >
    > Is that an error message from Skype? Sorry, beats me.
    >
    > *Edit:* sorry, didn't read that it was a YaST message. Show us the
    > output of 'zypper lr -d', please.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJM2dbqAAoJEF+XTK08PnB5G5EP/2mqEB7CFOxFPeW7NLaSjMvH
    PCV5imkh+0ah5QaajwUSq/neJSXxWJa7yR+AIi5bLm3zL+UZU7ihHtEBeY5yaJJ7
    ZhJIYDHYZoSQDEG860ySMw+wffoJfAkYpdh756J7tOv2JeMh79kUAq5khwwxzgsg
    puwPXb5JXo5eXStGNagp4IU7cuct55zA7x6FlwhgPQ4GFW86sU7IcuWLvreiIt6G
    b1WNQgos3n5fIxpwhozu3uUTYpg9sPRw1nn4ucmv6oah/vLDeG81tbUtZIUMGhop
    3JTVOD1DBcJtvv+iUGbp6DG89ZoRTS7hixPGi7wMyNJ1L5z4zj1rLxVeGbFdLzEc
    XnPK3zk4wFOo905aGq9cYkTR0lSL1PlPkTd5noqjPPaHAf49dTk+awEpa4Ju9itY
    oWRX+l7IEjDpKYFUvZWGFZjGcdhapnrf7ixwcsAuZUXZ0pYu/doMSw1pomj3SM6I
    emhXwy5LgK2+TmgMTp5IqaomVx7otKJLuGCddYL6Srp1xzkFUmrbFtqJ7SRB/OdK
    H3YJy3d/CZxCMa5Nwy87rtoBRvWDDj727Mk9ONX2DMsWA5S2uHXMCH2LDmf67NNo
    Fe5AI+BUZZ/AuREmRmW2LtCf3IHZfKWpDN6ejbTlsYz5rEK7Bc7Z3++9s+iR3zB8
    yZ+nbU1RYMSCX3C/QJaQ
    =YXBJ
    -----END PGP SIGNATURE-----

  4. #4

    Default Re: Skype wont launch

    Hi thanks for your reply,

    Ive installed the missing file you've suggested and I have tried to reinstall it but same error in Yast

    Here's the output for 'zypper lr -d' as requested:

    ig@linux-ljqk:~> zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+-------------------------------------------------------------------+-------------------------------------------------------------------+---------+---------+----------+----------+-------------------------------------------------------------------+--------
    1 | 11.3 - VideoLan | 11.3 - VideoLan | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.3/ |
    2 | PK_TMP_DIR | PK_TMP_DIR | Yes | Yes | 99 | plaindir | dir:///var/tmp/TmpDir.GYTMqs |
    3 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
    4 | Index of /distribution/11.3/repo/oss/suse | Index of /distribution/11.3/repo/oss/suse | Yes | Yes | 99 | rpm-md | Index of /distribution/11.3/repo/oss/suse |
    5 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    6 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
    7 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    8 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    9 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss |


    Quote Originally Posted by gropiuskalle View Post
    Code:
    skype: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
    You need the package 'libpng12-0'.

    Code:
    [PK_TMP_DIR|dir:///var/tmp/TmpDir.xftzR0] Repository already exists.
    Is that an error message from Skype? Sorry, beats me.

    Edit: sorry, didn't read that it was a YaST message. Show us the output of 'zypper lr -d', please.

  5. #5

    Default Re: Skype wont launch

    Thanks for your reply. I will send those guys an email as suggested!

    I didnt quite understand your post so Im following instructions as per @ gropiuskalle.

  6. #6

    Default Re: Skype wont launch

    I've just emailed them saying they should try harder as Linux is used by millions.

    It's in their interest that they sort out the dependencies issue as it will be better for their bottom line AND it will help Linux grow...a win-win situation, to say the least!

  7. #7
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Skype wont launch

    On Wed, 10 Nov 2010 13:06:02 +0530, Sussudio
    <Sussudio@no-mx.forums.opensuse.org> wrote:

    > skype: error while loading shared libraries: libpng12.so.0: cannot open
    > shared object file: No such file or directory


    i remember having had similar or even the same problem when installing
    skype. is a while ago, but when i was googling the issue, i found that
    there's a naming problem with this libpng12.so. different distros or
    packages apply different names to this library, and skype keeps looking
    for the wrong one.

    i checked in my /usr/lib directory, and find a shortcut named
    "libpng12.so.0" which points to "libpng12.so.0.44.0". if you do have the
    second file (libpng12.so.0.44.0), try to create that shortcut, which skype
    will probably find & accept. as root, run this:

    Code:
    cd /usr/lib
    ln -s libpng12.so.0.44.0 libpng12.so.0
    i found this solution somewhere on the skype forums, but didn't bookmark
    it. should be possible to find it there.

    --
    phani.

  8. #8

    Default Re: Skype wont launch

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Yeah, that's part of the issue, but the bigger problem is that Skype
    doesn't define what it needs in the first place. The system should be
    able to resolve those dependencies based on what is set within the RPM,
    but the RPM (from Skype) doesn't include dependencies properly:

    me@mybox0> rpm -q --requires skype
    /bin/sh
    /bin/sh
    config(skype) = 2.1.0.81-suse111
    qt >= 4.2
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1

    Notice a lack of things like libpng12, etc. Based on this all the system
    needs is a basic shell and a version of RPM that is already on the system.

    Good luck.





    On 11/10/2010 05:41 AM, phanisvara wrote:
    > On Wed, 10 Nov 2010 13:06:02 +0530, Sussudio
    > <Sussudio@no-mx.forums.opensuse.org> wrote:
    >
    >> skype: error while loading shared libraries: libpng12.so.0: cannot open
    >> shared object file: No such file or directory

    >
    > i remember having had similar or even the same problem when installing
    > skype. is a while ago, but when i was googling the issue, i found that
    > there's a naming problem with this libpng12.so. different distros or
    > packages apply different names to this library, and skype keeps looking
    > for the wrong one.
    >
    > i checked in my /usr/lib directory, and find a shortcut named
    > "libpng12.so.0" which points to "libpng12.so.0.44.0". if you do have the
    > second file (libpng12.so.0.44.0), try to create that shortcut, which skype
    > will probably find & accept. as root, run this:
    >
    >
    Code:
    cd /usr/lib
    > ln -s libpng12.so.0.44.0 libpng12.so.0
    >
    > i found this solution somewhere on the skype forums, but didn't bookmark
    > it. should be possible to find it there.
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJM2r+nAAoJEF+XTK08PnB51YUP/AiMm2GwDarJMZWXUn9P3dvX
    jPJ/xWMxRfTL3Q7OvgwGNC/0k70iH+Y1wTDH4VTDjaQMp2vVCDZ6Ak502K+BX78k
    PFaFtkkKJBEwIGh8kj60BWNzZUo3P0/LF66D9zRyiWVlMNat288Y7h2Msw52c13K
    Z5xwHQIrGSBMLxqu7O4tWFUqQUsfnwGN9AkTcNIDm/6X5W1MxOPjc5jae3leP4d+
    M45OCzXxS0yKcOVN2O11x2h8/ZZi/1XFbEPGTQOBZUHGSlaRZZkRwc/M1bDVx2Ir
    yph9mra970i1+5QNBgVoDlJNkyRCGMlVziT1C9LQ+qqgV6QWX91Lc4okdUKqCS7V
    pu1Gsy5V9LrsRsh09eBAhH90jCOhkzuleFtSIbTrgnjnx1m9ivbxwN7b3nh4xC5L
    A11idXpZsmbV37xHlImRmHqTH5oXFAKHvW847xGdMcNWNs0cIeSzIi3QBLXWpxh9
    IEIGjQVwWMrYCUq3TWCf9s1wA/bPh2Fi+dXd7P4YqnLmH5wzwZsGvuQID8Y2MGuU
    gEOz42MejdRLKoVKIenDfSzMi72S19kZpKwj/gLa0PRO1TnTxVepihS9R4/txVUr
    sG/bKYavNwRV/D4DGvrZrJnfYdmGrdjtl2JocsOjm+GvdHNiXpCYUvNxj+CVhHo5
    x8Le5xwN1TUfBrOz/9sz
    =sI6D
    -----END PGP SIGNATURE-----

  9. #9

    Default Re: Skype wont launch

    thansk I downloaded 'libpng12-0' but havent got skype currenntly on my system as I uninstalled it. Now I can not install it as YaST if gives that error.


    How to I clear this?

  10. #10

    Default Re: Skype wont launch

    Hi

    I may have to do this in steps because Im in waaay over my head.

    Ive unistalled skype but now I cant instal it any longer due to this error in YaST

    [PK_TMP_DIR|dir:///var/tmp/TmpDir.xftzR0] Repository already exists.

    How do I clear that?

    Thanks

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •