Results 1 to 8 of 8

Thread: Screensaver headaches

  1. #1

    Default Screensaver headaches

    I'm using OpenSuSE 11.3, and as far as I can see, my screensaver and power management applications do not work properly. I want to disable the DPMS entirely, and for the screensaver to kick in after the appropriate amount of inactivity.

    I prefer using Menu --> Configure Desktop --> General --> Desktop --> Screen Saver, using a slideshow, set to activate after 40 minutes.

    When I use "xset dpms 0 0 0 " or "xset -dpms" to deactivate the screen blanking entirely, this also shuts off the screensaver. I've found no setting or combination of settings within Menu --> Configure Desktop --> Advanced --> Power Management that shut off screen blanking at all -- it's xset or nothing. Doing "xset dpms 1000000" (for example) would be acceptable, except that the maximum value allowed is 16960, or 4.71 hours, which is unacceptable to me. I want unlimited screensaver time, with no screen blanking.

    *Is* there a way of kickstarting the internal screensaver while DPMS is disabled by, say, using a command line in a shell script filed in .kde4/Autostart?

    Thanks!

    W4E

  2. #2
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Screensaver headaches

    I remember that there was a thread in these forums about disabling the screensaver completely. It involved several steps. Maybe you can locate it with the search option.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  3. #3
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Screensaver headaches

    The OP doesn't want to disable the screensaver completely, just screen blanking like I would also like to do.

    I wasn't aware of xset -dpms so will try that next. I already have all Power Management settings that I can find disabled and that doesn't help.
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

  4. #4

    Default Re: Screensaver headaches

    Quote Originally Posted by rafter22 View Post
    The OP doesn't want to disable the screensaver completely, just screen blanking like I would also like to do.
    Correct! I found those threads which prescribe how to disable the screensaver itself, and read through them hoping to find clues as to how to do the exact opposite. No dice. ;)

    Quote Originally Posted by rafter22 View Post
    I wasn't aware of xset -dpms so will try that next. I already have all Power Management settings that I can find disabled and that doesn't help.
    If you wish to make it so that you don't have to run that command manually every time, open a new file (I called mine "xset.sh"), and enter:

    Code:
    #!/bin/sh
    
    xset -dpms
    
    # end xset.sh
    Save and close, then move your new .sh file to ~/.kde4/Autostart/ ... the next time you login to that user account, you should have no screen blanking. Good luck!

    W4E

  5. #5
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,160

    Default Re: Screensaver headaches

    Guys if you're using KDE, which reads like the case, try this:
    1. Kmenu>Configure Desktop
    2.click the advanced tab
    3.Look for a Light Bulb icon listed as Power Management
    4.Under General Settings it'll open to the Settings and Profiles
    5.Under the Profile Assignment where it says When AC Adaptor is plugged in click the dropdown & select Presentation
    That'll stop the blanking & keep your screensaver running, Ive sometimes left it going for 2 hours.
    We are what we think.
    All that we are arises with our thoughts.
    With our thoughts we make the world.

    My 64 bit: Gateway 5670 UPDATED | RADEON RX 570 |CPU AMD - Ryzen 5 1600
    Opensuse Tumbleweed Plasma 5

  6. #6

    Default Re: Screensaver headaches

    Quote Originally Posted by Sagemta View Post
    Guys if you're using KDE, which reads like the case, try this:
    1. Kmenu>Configure Desktop
    2.click the advanced tab
    3.Look for a Light Bulb icon listed as Power Management
    4.Under General Settings it'll open to the Settings and Profiles
    5.Under the Profile Assignment where it says When AC Adaptor is plugged in click the dropdown & select Presentation
    That'll stop the blanking & keep your screensaver running, Ive sometimes left it going for 2 hours.
    I appreciate the suggestion -- but it's something I've already tried. However, I did try it again following your post, on the off-chance that I'd missed something. Unfortunately, it has no effect. The screen still blanks out after about 10 minutes.

    And, I was pretty sure it's KDE to which I was referring, but, it's not exactly labeled as such, and I'm not sure where to dig to make that ID.

    W4E

  7. #7
    Join Date
    Aug 2008
    Location
    Texas, US
    Posts
    224

    Default Re: Screensaver headaches

    I created that file and placed it in the directory specified. Upon login, the file does not run. It is opened with emacs. If I try to run "./xset.sh" manually, I get a permission denied message. I have given the file read-write permissions and also marked it as executable. Not sure what I am doing wrong. If I run the commands in a terminal, all is well and it seems to work. But I would like a way to automate it to avoid having to so it manually each time.

    Quote Originally Posted by Wildcat4Ever View Post
    Correct! I found those threads which prescribe how to disable the screensaver itself, and read through them hoping to find clues as to how to do the exact opposite. No dice.



    If you wish to make it so that you don't have to run that command manually every time, open a new file (I called mine "xset.sh"), and enter:

    Code:
    #!/bin/sh
    
    xset -dpms
    
    # end xset.sh
    Save and close, then move your new .sh file to ~/.kde4/Autostart/ ... the next time you login to that user account, you should have no screen blanking. Good luck!

    W4E

  8. #8
    Join Date
    Aug 2008
    Location
    Texas, US
    Posts
    224

    Default Re: Screensaver headaches

    Ooops! My "home" directory is not on the system drive. I moved the file to the root directory and made a symlink to it in .kde/Autostart. That made it work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •