Results 1 to 7 of 7

Thread: Autostart. A curious thing

  1. #1
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Autostart. A curious thing

    Some months ago I decided to launch automatically Konqueror everytime kde starts up. I did it through System settings -> Startup and shutdown -> Autostart.
    Now I don't want it to autostart anymore.
    But konqueror is neither in System settings -> Startup and shutdown -> Autostart; nor in ~/.kde4/autostart; nor in ~/.kde4/share/autostart.
    Nevertheless it starts automatically at login.

    Any idea about how to disable this?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Autostart. A curious thing

    Are you sur Konqui is not running when you log out? Else, on login, the session will be restored and Konqui started.
    Henk van Velden

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Autostart. A curious thing

    hcvv has a valid item to check in KDE's Personnel Settings / Advanced Tab / Advanced User Settings / Sessions Manager / On Logon Section / Start with an Empty Session Bullet.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: Autostart. A curious thing

    In Personal settings -> Startup and shutdown -> Session Management the option Start with an empty session is selected. It was like that before (I forgot to include this information in my first post).
    Anyway, konqueror starts everytime I log in, no matter if it was running when I logged out or not.
    Obviously it is not more than a strange thing, but it's in fact very curious, isn't it?

  5. #5
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: Autostart. A curious thing

    Finally I found it. It was in ~/.config/autostart

  6. #6
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,294
    Blog Entries
    1

    Default Re: Autostart. A curious thing

    Handy.. I have a program that pops up automatically after the first time I started it (remote desktop hosting) and I can't get it to NOT pop up the invitation dialog box every time I boot up.
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  7. #7
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: Autostart. A curious thing

    Quote Originally Posted by dragonbite View Post
    Handy.. I have a program that pops up automatically after the first time I started it (remote desktop hosting) and I can't get it to NOT pop up the invitation dialog box every time I boot up.
    Have you checked all those folders in which autostart programs can be?
    Now I know at least three in kde: ~/.kde4/autostart ~/.kde4/share/autostart ~/.config/autostart
    apart from /usr/share/autostart
    But autostart could be enabled in some setting of the program itself? For instance, kalarm settings have that option

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •