Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Erratic Yast2 Software Management behaviour

  1. #1

    Default Erratic Yast2 Software Management behaviour

    Can anyone help me to solve these annoying problems I have with Yast2 Software Management?

    1. Sometimes when starting Yast2 Software Management it fails to connect to the SW repositories. It happens inevitably (i.e. without exception) at the first attempt after a fresh boot up, and sometimes otherwise. I can only retry or abort, and retrying usually brings no success anyway. Is it perhaps due to a time-out somewhere?

    2. If I click on the 'abort' button (see above) or 'cancel' in Yast otherwise, I inevitably (i.e. without exception) get the following type of error message
    Code:
    ** (<unknown>:4220): CRITICAL **: giop_thread_request_push: assertion `tdata != NULL' failed
    
    ** (<unknown>:4220): CRITICAL **: giop_thread_request_push: assertion `tdata != NULL' failed
    
    ** (<unknown>:4220): CRITICAL **: giop_thread_request_push: assertion `tdata != NULL' failed
    
    ** (<unknown>:4220): CRITICAL **: giop_thread_request_push: assertion `tdata != NULL' failed
    (sometimes only 2 identical lines of error code)

    I am running OpenSuse 11.3 with Gnome.

    I look forward to hearing your suggestions.

  2. #2
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Erratic Yast2 Software Management behaviour

    Is that the same computer as in your other thread?

    Slow startup after login

    Your installation could be borked somewhat.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Erratic Yast2 Software Management behaviour

    Some users who failed to disable ipv6 upon installing their openSUSE have encountered this. I recommend you give consideration to disabling ipv6.

  4. #4

    Default Re: Erratic Yast2 Software Management behaviour

    Quote Originally Posted by vodoo View Post
    Is that the same computer as in your other thread?

    Slow startup after login

    Your installation could be borked somewhat.
    Yes, it is. Acer Travelmate 2490

  5. #5

    Default Re: Erratic Yast2 Software Management behaviour

    Quote Originally Posted by oldcpu View Post
    Some users who failed to disable ipv6 upon installing their openSUSE have encountered this. I recommend you give consideration to disabling ipv6.
    Did that in Network Services > Network Settings. No noticeable improvement

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Erratic Yast2 Software Management behaviour

    Quote Originally Posted by hnimmo View Post
    Did that in Network Services > Network Settings. No noticeable improvement
    Thats not enough. You also need to disable it as a boot code.

  7. #7

    Default Re: Erratic Yast2 Software Management behaviour

    Quote Originally Posted by oldcpu View Post
    Thats not enough. You also need to disable it as a boot code.
    After doing it from the network settings, I was required to reboot, which I did. Is that not enough? Or how else do I disable it as boot code?

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Erratic Yast2 Software Management behaviour

    I read from the others that you have/had allready some other problems that might be related to this one.

    Nevertheless I would like to point you to the fact that when your update applet is checking for updates (and that happens often right after boot) you can not use any software install product at the same time. Thus either wait until the applet is ready or kill the applet. YaST tells this in a message that clearly says that another prcocess is blocking. You do not report any message, you only say it fails to connect, but you do not tell how you know, thus I can not know.
    Henk van Velden

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Erratic Yast2 Software Management behaviour

    Quote Originally Posted by hnimmo View Post
    After doing it from the network settings, I was required to reboot, which I did. Is that not enough? Or how else do I disable it as boot code?
    The method for disabling ipv6 changed, either in openSUSE-11.2 or 11.3, and one must pass a boot code to the kernel for the disable to succeed. Specifically type this in the grub option line:
    Code:
    ipv6.disable=1
    Also, keep your repositories to the minimum. I recommend 4. You do NOT need any more. Keep them down to OSS, Non-OSS, Update and Packman. Only add others if needed for special applications (not on the 4 repos I mentioned) and then as soon as you completed installing the application from a 5th repos, remove the 5th repos. That simple act is better to avoid instability, to avoid dependency problems, and it will speed up your installations/updates.

  10. #10

    Default Re: Erratic Yast2 Software Management behaviour

    where do i specifically go to disable this grub option??

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •