Results 1 to 6 of 6

Thread: kdenlive 1.7.8 crashing since 11.3 updates

  1. #1

    Default kdenlive 1.7.8 crashing since 11.3 updates

    I am working for a small company editing video's with kdenlive

    After updating my system to opensuse 11.3 and upgrading kdenlive to 0.7.8 I am unable to open my previous project files without kdenlive crashing.

    I am using kdenlive 0.7.8-1.pm.1.1-x86-64 from packman 11.3
    and my kdebase library is
    4.4.4..1-5 from opensuse.

    This is the output from calling kdenlive when it crashes.

    My question... Is this an issue with kdenlive or is it an issue with my system configuration. I am using premiere as a backup, but I much prefer kdenlive ...

    video@linux-z616:~> kdenlive
    File given: true
    Color mode changed to 0
    File given: true
    QWidget::insertAction: Attempt to insert null action
    QWidget::insertAction: Attempt to insert null action
    X Error: BadWindow (invalid Window parameter) 3
    Major opcode: 3 (X_GetWindowAttributes)
    Resource id: 0x0
    kdenlive: xcb_io.c:183: process_responses: Assertion `!(req && current_request && !(((long) (req->sequence) - (long) (current_request)) <= 0))' failed.
    KCrash: Application 'kdenlive' crashing...
    sock_file=/home/video/.kde4/socket-linux-z616/kdeinit4__0

    [1]+ Stopped kdenlive

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: kdenlive 1.7.8 crashing since 11.3 updates

    Quote Originally Posted by holtslander-g View Post
    After updating my system to opensuse 11.3 and upgrading kdenlive to 0.7.8 I am unable to open my previous project files without kdenlive crashing.
    I had this problem for a day (or one similar to it) with version 0.7.7.1, but then it disappeared and I have never been able to reproduce it since.

    Old thread is here: kdenlive crashes when loading project with saved audio track

    I figure simply rebooting fixed the problem.

    In case a reboot does not (fix the problem), please, what is output of:
    Code:
    rpm -qa '*mlt*'
    Its possible you may need to raise this on the kdenlive forum if your mlt versions are ok and if a reboot does not solve this: Forums | Kdenlive

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: kdenlive 1.7.8 crashing since 11.3 updates

    Quote Originally Posted by oldcpu View Post
    I had this problem for a day (or one similar to it) with version 0.7.7.1, but then it disappeared and I have never been able to reproduce it since.
    I should note I am now use kdenlive-0.7.8-1 on both an openSUSE-11.2 and an 11.3 PC and I have no problem.

  4. #4

    Default Re: kdenlive 1.7.8 crashing since 11.3 updates

    rpm -qa '*mlt*'
    mlt-0.5.10-1.pm.1.3.x86_64
    libmlt2-0.5.10-1.pm.1.3.x86_64
    libmlt++3-0.5.10-1.pm.1.3.x86_64

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: kdenlive 1.7.8 crashing since 11.3 updates

    Quote Originally Posted by holtslander-g View Post
    rpm -qa '*mlt*'
    mlt-0.5.10-1.pm.1.3.x86_64
    libmlt2-0.5.10-1.pm.1.3.x86_64
    libmlt++3-0.5.10-1.pm.1.3.x86_64
    I am trying to read between the lines in that answer, ... and rather than force me to speculate, how about a simple answer ... Did a reboot help?

    I'm assuming it did not, but I prefer not to leave this important question to chance and to my speculation.

    I checked those mlt versions, and they are the latest packaged by Packman and they should be fine. I have updated to those versions on my 32-bit PC and there is no problem.

    On my 64-bit openSUSE-11.2 PC, those mlt versions (that you have) are not available yet, as I note I have:
    Code:
    libmlt2-0.5.10-1.pm.1.2.x86_64
    libmlt++3-0.5.10-1.pm.1.2.x86_64
    mlt-0.5.10-1.pm.1.2.x86_64
    hence I still need to update to those versions on my 64-bit PC when they come available.

    I have to rush to work this morning, so I have no time to check the mlt version (and kdenlive functionality) on my 64-bit openSUSE-11.3 equipped laptop, but I will endeavor to do so tonight.

    I note a thread here reporting what may be a similar problem: Crash when opening .kdenlive file | Kdenlive

    ... and in this case the problem was with the user having a very old mlt version.

    I searched for your questions (if any) on the Forums | Kdenlive and I could not find a thread. Is there none? Note that was also a recommendation of mine (to post asking for help there).

    There is also the possibilty that your mlt install was corrupted, so you could check that hypothesis by doing a re-install of all 3 of your MLT packages.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: kdenlive 1.7.8 crashing since 11.3 updates

    Quote Originally Posted by oldcpu View Post
    I have to rush to work this morning, so I have no time to check the mlt version (and kdenlive functionality) on my 64-bit openSUSE-11.3 equipped laptop, but I will endeavor to do so tonight.
    I was able to reproduce this crash on my openSUSE-11.3 equipped laptop. Following the debug links automatically generated by KDEnlive when it crashes lead me to this bug report: 0001869: opening a pre-existing project file crahses kdenlive immediately when opening a pre-existing 0.7.7 project file - MantisBT (possibly yours) which notes "This looks exactly like bug 0001711, which should be fixed in SVN."

    What we need to do is make the openSUSE kdenlive packager aware of the bug, so that when it is available on SVN, that openSUSE packager picks up the SVN version and hopefully builds it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •