Results 1 to 5 of 5

Thread: RealVNC blank screen for openSuse 11.3

  1. #1

    Default RealVNC blank screen for openSuse 11.3

    Well I am pretty new to Linux, but I've done as much research as I can on this problem of mine before making the last resort and posting what I think is a stupid question.

    I've installed RealVNC on my linux box, but when I try to connect (whether is locally, over LAN from my W7 PC, or through HTTP) I always get the same result, the vncviewer window is black/blank with a X as the cursor. I've edited the /home/.vnc/xstartup file to contain:

    Code:
    #!/bin/sh
    
    # Uncomment the following two lines for normal desktop:
    unset SESSION_MANAGER
    exec /etc/X11/xinit/xinitrc
    #exec startkde
    
    [ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
    [ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
    xsetroot -solid grey
    vncconfig -iconic &
    xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
    twm &
    The #exec startkde being there 'cause something I was reading pointed to this as a fix, but alas it didn't work.


    Here is the terminal response and log file from my latest try:
    Code:
    Dabo@Dabolinux:~> vncviewer
    
    VNC Viewer Free Edition 4.1.3 for X - built Oct 15 2008 12:49:56
    Copyright (C) 2002-2008 RealVNC Ltd.
    See http://www.realvnc.com for information on VNC.
    
    Sat Oct 30 15:03:04 2010
     CConn:       connected to host localhost port 5901
     CConnection: Server supports RFB protocol version 3.7
     CConnection: Using RFB protocol version 3.7
    
    Sat Oct 30 15:03:05 2010
     TXImage:     Using default colormap and visual, TrueColor, depth 24.
     CConn:       Using pixel format depth 6 (8bpp) rgb222
     CConn:       Using ZRLE encoding

    Code:
    30/10/2010 15:03:04 Got VNC connection from client 127.0.0.1
    30/10/2010 15:03:04 Using protocol version 3.7
    30/10/2010 15:03:05 Full-control authentication passed by 127.0.0.1
    30/10/2010 15:03:05 Pixel format for client 127.0.0.1:
    30/10/2010 15:03:05   8 bpp, depth 6
    30/10/2010 15:03:05   true colour: max r 3 g 3 b 3, shift r 4 g 2 b 0
    30/10/2010 15:03:05 Enabling full-color cursor updates for client 127.0.0.1
    30/10/2010 15:03:05 rfbProcessClientNormalMessage: ignoring unknown encoding -223
    30/10/2010 15:03:05 rfbProcessClientNormalMessage: ignoring unknown encoding 16
    30/10/2010 15:03:05 Using copyrect encoding for client 127.0.0.1
    30/10/2010 15:03:05 Using hextile encoding for client 127.0.0.1
    30/10/2010 15:03:10 rfbClientConnectionGone
    30/10/2010 15:03:10 VNC Client 127.0.0.1 gone
    30/10/2010 15:03:10 Statistics:
    30/10/2010 15:03:10   key events received 0, pointer events 64
    30/10/2010 15:03:10   framebuffer updates 1, rectangles 2, bytes 3385
    30/10/2010 15:03:10     cursor shape updates 1, bytes 300
    30/10/2010 15:03:10     hextile rectangles 1, bytes 3085
    30/10/2010 15:03:10   raw bytes equivalent 786444, compression ratio 254.925122
    30/10/2010 15:03:10 GenerateVncDisconnectedEvent
    I hope that's enough information for some help, this has been driving me crazy the past few hours. Thanks.

  2. #2

    Default Re: RealVNC blank screen for openSuse 11.3

    Ok, so I was goofing around, and commented out the exec /etc/X11/xinit/xinitrc, which gave me a screen with just a terminal window, soon as I pressed any key the viewer closed.

    Sat Oct 30 15:43:36 2010
    main: End of stream

    was in the terminal window and

    30/10/2010 15:43:33 Got VNC connection from client 127.0.0.1
    30/10/2010 15:43:33 Using protocol version 3.7
    30/10/2010 15:43:35 Full-control authentication passed by 127.0.0.1
    30/10/2010 15:43:35 Pixel format for client 127.0.0.1:
    30/10/2010 15:43:35 8 bpp, depth 6
    30/10/2010 15:43:35 true colour: max r 3 g 3 b 3, shift r 4 g 2 b 0
    30/10/2010 15:43:35 Enabling full-color cursor updates for client 127.0.0.1
    30/10/2010 15:43:35 rfbProcessClientNormalMessage: ignoring unknown encoding -223
    30/10/2010 15:43:35 rfbProcessClientNormalMessage: ignoring unknown encoding 16
    30/10/2010 15:43:35 Using copyrect encoding for client 127.0.0.1
    30/10/2010 15:43:35 Using hextile encoding for client 127.0.0.1
    30/10/2010 15:43:35 Pixel format for client 127.0.0.1:
    30/10/2010 15:43:35 32 bpp, depth 24, little endian
    30/10/2010 15:43:35 true colour: max r 255 g 255 b 255, shift r 16 g 8 b 0
    30/10/2010 15:43:35 Enabling full-color cursor updates for client 127.0.0.1
    30/10/2010 15:43:35 rfbProcessClientNormalMessage: ignoring unknown encoding -223
    30/10/2010 15:43:35 Using hextile encoding for client 127.0.0.1
    30/10/2010 15:43:35 Using copyrect encoding for client 127.0.0.1
    30/10/2010 15:43:35 rfbProcessClientNormalMessage: ignoring unknown encoding 16

    Backtrace:
    0: Xvnc (xorg_backtrace+0x37) [0x81b1cb7]
    1: Xvnc (0x8048000+0x16d30a) [0x81b530a]
    2: (vdso) (__kernel_rt_sigreturn+0x0) [0xffffe410]
    3: Xvnc (NewCurrentScreen+0xdd) [0x80bb70d]
    4: Xvnc (mieqProcessDeviceEvent+0x1a0) [0x81030d0]
    5: Xvnc (mieqProcessInputEvents+0xeb) [0x810323b]
    6: Xvnc (0x8048000+0x6a530) [0x80b2530]
    7: Xvnc (0x8048000+0x584a5) [0x80a04a5]
    8: /lib/libc.so.6 (__libc_start_main+0xfe) [0xb743cc0e]
    9: Xvnc (0x8048000+0x15431) [0x805d431]
    Segmentation fault at address 0xd

    Fatal server error:
    Caught signal 11 (Segmentation fault). Server aborting

    xterm: fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":1.0"
    XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":1.0"
    after 927 requests (927 known processed) with 0 events remaining.

    in the log.
    Last edited by Dabo7; 30-Oct-2010 at 12:45. Reason: typo

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: RealVNC blank screen for openSuse 11.3

    I don't use realvnc. I sue the version TightVNC, so can't really help, but here are a couple of thoughts:

    1. OK I see how you're starting the viewer and I see how you're configuring the server with the xstartup file. I wonder about the server. How are you launching the vncserver?
    2. And fwiw if you want to "startkde" you would but it like this: /usr/bin/startkde


    There might some help here: TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  4. #4

    Default Re: RealVNC blank screen for openSuse 11.3

    I tried starting the server a few ways:

    - Typing vncserver in the command line, either blank or with :1, :2, -geometry differentwidths X differentheights.
    - If you search vncserver there's also a short cut to launch it, didn't work for me either.

    Just tried using tightvnc instead and it worked the first time, so I guess I'm using that as I'm not really picky at this point about it. Works just as well through a browser/RealVNC viewer client and iphone/ipad client for work as realvnc does.

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: RealVNC blank screen for openSuse 11.3

    Problem solved then -- enjoy
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •