Results 1 to 2 of 2

Thread: upgrade libqt4-x11

  1. #1

    Default upgrade libqt4-x11

    This is regrding Machine #2

    I am trying to install a piece of software called KMid, which is supposed to be part of the KDE multimedia package, which I thought I have installed. Yast says the KDE Multimedia package is installed, but KMid check box is blank.
    So, when I try to install KMid [from Yast] it tells me that I need to upgrade from my current libqt4-x11 to the newest version which is 4.70. In which repo will I find this latest libqt4-x11?
    I have the standard repos installed [oss, non-oss, updates, packman]. I do all required updates as they come along.
    I know I can get libqt4-x11 v 4.70 from the internet as a rpm pkg, but am unsure if I should just install it over older version or uninstall older version first?
    I would like to try to upgrade it thru Yast or zypper, rather than just dbl click rpm.
    Is there a repo which I could add that would show the latest version of this libqt4-x11?
    Machine # 1 - Asus Prime Z390A, i7-9700k 3.6GHz, 32.0 GB ram, openSUSE Leap 15.0 64-bit, KDE Plasma 5.12.8
    Machine # 2 - Asus P8Z77-V Deluxe, i7-3770k 3.5GHz, 16.0 GB ram, opensuse Tumbleweed KDE Plasma 5.17.0

  2. #2
    Join Date
    Nov 2009
    Location
    Santiago, Chile
    Posts
    171

    Default Re: upgrade libqt4-x11

    I've found the KDE-Qt repo to get the latest stable Qt libraries, so LaQuirrELL you may add this url to your repositories list: Index of /repositories/KDE:/Qt/openSUSE_11.3 .
    Now I'm not sure if there are some other apps dependencies updating from Qt4.6 to Qt4.7 (zypper doesn't says anything) that may create unpleasant system behaviors. Would someone ensure this please?

    PS: Have heard issues about.

    Thanks!
    Last edited by faco84; 30-Oct-2010 at 12:22. Reason: more info
    HP pavilion dv6-6185la - Intel i7 - AMD Radeon 6770M - openSUSE 12.2 - KDE 4.9

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •