Results 1 to 2 of 2

Thread: KWin OpenGL compositing self-check failed

  1. #1

    Default KWin OpenGL compositing self-check failed

    Hi.

    I have recently updated my ATI drivers to Catalyst 10.10 (ati-driver-installer-10-10-x86.x86_64.run) from the AMD website and I have not been able to get KWin to enable compositing.

    I am using:
    openSUSE 11.3 x64
    KDE 4.5.2
    kernel 2.6.34.7
    kwin 4.5.2
    ATI Radeon HD 4870

    This is what KWin is saying when I try to enable compositing.
    Code:
    kwin(9353) KWin::CompositingPrefs::detectDriverAndVersion: GL vendor is "ATI Technologies Inc." 
    kwin(9353) KWin::CompositingPrefs::detectDriverAndVersion: GL renderer is "ATI Radeon HD 4800 Series         " 
    kwin(9353) KWin::CompositingPrefs::detectDriverAndVersion: GL version is "1.4 (3.3.10243 Compatibility Profile Context)" 
    kwin(9353) KWin::CompositingPrefs::detectDriverAndVersion: Detected driver "fglrx" , version "3.3.1024" 
    kwin(9353): OpenGL compositing self-check failed, disabling compositing. 
    kwin(9353): Failed to initialize compositing, compositing disabled
    I tried fgl_glxgears and glxgears and they both work perfectly fine.
    fgl_glxgears:
    Code:
    Using GLX_SGIX_pbuffer
    13671 frames in 5.0 seconds = 2734.200 FPS
    11627 frames in 5.0 seconds = 2325.400 FPS
    glxgears:
    Code:
    *** NOTE: Don't use glxgears as a benchmark.
        OpenGL implementations are not optimized for frame rates >> 60fps,
        thus these numbers are meaningless when compared between vendors.
    
    43336 frames in 5.0 seconds = 8667.183 FPS
    I tried modifying ~/.kde4/share/config/kwinrc and changing OpenGLIsUnsafe to false
    Code:
    [Compositing]
    AnimationSpeed=3
    Backend=OpenGL
    DisableChecks=false
    Enabled=true
    GLDirect=true
    GLMode=TFP
    GLTextureFilter=1
    GLVSync=true
    HiddenPreviews=5
    OpenGLIsUnsafe=false
    XRenderSmoothScale=false
    I mainly wanted to update KDE, KWin, and my ATI drivers because I was having problems with KWin enabling at start up but now it's not working at all.

  2. #2

    Default Re: KWin OpenGL compositing self-check failed

    for me, i disabled the functionality checks long ago for the same type of annoyance, i.e. effects work fine but is disabled on session startup. Either hit the checkbox available in DesktopEffects>AdvancedTab or change the line in kwinrc to "DisableChecks=true"..... seems something kwin expects to verify simply isn't returned properly at session start, i think there are bugs reported on this issue.

    not really a solution, but you aren't the only one!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •