Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Dolphin stopped listing hidden files

  1. #1
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    400

    Default Dolphin stopped listing hidden files

    Dolphin just stopped showing hidden files in the list in my home folder. They had always been listed before, and they do display in Konquerer and Krusader.

    System is openSUSE 11.2 and KDE 4.3.5. I think there were no recent updates that involved Dolphin.

    Dolphin is set to split mode. I had my home folder open in both sides, and hidden files were listed. On one side, I went to a sub-folder then back up, and the hidden files were not shown. One the other side, they were still listed. I went to a sub-folder on that other side, back up, and the hidden files were gone there, too.

    I have unchecked and checked the "Show Hidden Files" box, and removed and re-installed Dolphin, but the hidden files still will not list. This happens when viewing the home folder on this machine and on other machines on the network.

    Any ideas what happened or how to fix it?

    Thanks,
    Howard

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,278
    Blog Entries
    2

    Default Re: Dolphin stopped listing hidden files

    Maybe this?
    (Folder View Widget properties)

    An FYI - Hiding Files and Folders in KDE 4.x and later

    Tony

  3. #3
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Dolphin stopped listing hidden files

    crmrhm, I suppose you accidentally toggled the hiding feature - hit Alt + '.' to switch back and forth.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: Dolphin stopped listing hidden files

    Quote Originally Posted by crmrhm View Post
    Dolphin just stopped showing hidden files in the list in my home folder. They had always been listed before, and they do display in Konquerer and Krusader.

    System is openSUSE 11.2 and KDE 4.3.5. I think there were no recent updates that involved Dolphin.

    Dolphin is set to split mode. I had my home folder open in both sides, and hidden files were listed. On one side, I went to a sub-folder then back up, and the hidden files were not shown. One the other side, they were still listed. I went to a sub-folder on that other side, back up, and the hidden files were gone there, too.

    I have unchecked and checked the "Show Hidden Files" box, and removed and re-installed Dolphin, but the hidden files still will not list. This happens when viewing the home folder on this machine and on other machines on the network.

    Any ideas what happened or how to fix it?

    Thanks,
    Howard
    A couple of things: uninstalling and reinstalling things in linux hardly ever works. Only if you destroyed a global config file, or threw away part of a package. What you can do, is remove the program's config file in your homedir. It somehow holds a setting causing the awkward behaviour. In this case, see that Dolphin is not open, then open a terminal window and do:
    Code:
    mkdir OLDKDEconfigs
    mv ~/.kde4/share/config/dolphin* ~/OLDKDEconfigs
    Now start Dolphin, see if the problem persists.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    400

    Default Re: Dolphin stopped listing hidden files

    gropiuskalle, you are indeed a Wise Penguin, and you suppose correctly. Alt + '.' fixed it. Thank you.

    I find this feature also works in Konquerer, but not in Krusader.

    Knurpht, thanks for the explanation of why the behavior survived removal and reinstallation of Dolphin.

    Where can I learn more about this feature, and others that maybe lurking in the weeds? Is there a description somewhere?

    Thanks,
    Howard

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: Dolphin stopped listing hidden files

    The "feature" I think you're referring to, is known as shortcuts. In KDE's Systemsettings you can find all of them under "Shortcuts and Gestures".

    TIP: go in Systemsettings, enter something configurable that you're looking for, f.e. "key" and see what happens to the icons...some grey out, the others contain options to do with "key".
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    400

    Default Re: Dolphin stopped listing hidden files

    I see Alt + . is shown as a keyboard shortcut in the dropdown menu of "View". I had missed that earlier.

    The feature is described in the openSUSE 11.2 November 09, 2009 KDE User Guide, page 22 (file book_kdeuser.pdf), but there appears to be a typo. The guide states:

    "3 To make Dolphin also show hidden files, select View > Show Hidden Files or press Alt + +."

    Alt + + did nothing that I could see. Alt + . works.

    Regards,
    Howard

  8. #8
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Dolphin stopped listing hidden files

    Quote Originally Posted by crmrhm
    gropiuskalle, you are indeed a Wise Penguin, and you suppose correctly. Alt + '.' fixed it. Thank you.
    *blush*

    I am glad I could help you. Happy (un)hiding. :-)

  9. #9
    Join Date
    Nov 2014
    Location
    Argentina
    Posts
    111

    Default Re: Dolphin stopped listing hidden files

    Hello, I found that searching for hidden files does not work on openSUSE 13.2, Dolphin 14.12.3.
    Yes, I pressed Alt + . and didn't worked.
    I tried disabling baloo (desktop search), didn't work either. Then I added index hidden files=true and index hidden folders=true into baloofilerc, and nothing.

    Do you guys know any workarround to fix this?

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Dolphin stopped listing hidden files

    It can take time for the index to build

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •