Page 1 of 5 123 ... LastLast
Results 1 to 10 of 43

Thread: Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

  1. #1

    Default Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

    Dear All:

    I am new to this field.

    I have installed openSUSE 11.3 in my old compaq Presario V3026TU machine which has the Intel PRO/WIRELESS 3945ABG WLAN card. Yast can detect the network card. But I cant make it work in any way. The switch to manually on-off the wireless doesnt work (the LED never become active).

    The "ifconfig" does not show the wireless interface, but "ifconfig -a" and "iwconfig" show the wlan0 interface.

    One more thing to mention, during my installation and while I run on live cd, the wireless becomes active. But after installation, I am facing this problem.

    I used openSUSE 11.1, Ubuntu and Fedora and I never faced this problem before. Does anyone know any solution?

    Thanks and Regards
    Arefin

  2. #2

    Default Re: Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

    If it's working in the live cd it should definitely work on the installed version. You should collect all the data from the live environment and compare to see what's different. The sticky posts here show all the commands to find out the relative information, such as....

    lsusb
    lspci -nnk
    uname -r
    dmesg | grep firmware

    You should also check wether your installed environment is using network manager or ifup (traditional method).

  3. #3

    Default Re: Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

    Quote Originally Posted by rodhuffaker View Post
    If it's working in the live cd it should definitely work on the installed version. You should collect all the data from the live environment and compare to see what's different. The sticky posts here show all the commands to find out the relative information, such as....

    lsusb
    lspci -nnk
    uname -r
    dmesg | grep firmware

    You should also check wether your installed environment is using network manager or ifup (traditional method).
    I apologize, the live CD I used was OpenSUSE 11.1. But I am providing some information which may be helpful for identifying the problem.

    I have been using openSUSE 11.3 for about 3 months. When I first install this OS, everything was working fine. Suddenly one morning, i found that my wireless LED is not working and the wireless device too. I tried to make it work using ifup, restart etc.. But nothing worked. Then I tried with live CD that I have with me. But I forgot to check the OpenSUSE version.... Sorry for this.

    The thing is If I type "ifconfig", the wlan0 is not showing. But if I use "ifconfig -a", my wireless device is showing.

    Please suggest me.

    Regards
    Arefin

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

    I have this device and it works.
    Please just confirm, does your device still work with the 11.1 live cd or with any other installed OS's

    Please post the result of this from your 11.3 install

    /sbin/lspci -nnk
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

    Quote Originally Posted by caf4926 View Post
    I have this device and it works.
    Please just confirm, does your device still work with the 11.1 live cd or with any other installed OS's

    Please post the result of this from your 11.3 install

    /sbin/lspci -nnk

    Currently I am using OpenSUSE 11.3 and my device is not working. The output of /sbin/lapci -nnk is as follows:

    00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: agpgart-intel
    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: i915
    00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: HDA Intel
    00:1c.0 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d0] (rev 02)
    Kernel driver in use: pcieport
    00:1c.2 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 3 [8086:27d4] (rev 02)
    Kernel driver in use: pcieport
    00:1c.3 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 4 [8086:27d6] (rev 02)
    Kernel driver in use: pcieport
    00:1d.0 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 [8086:27c8] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: uhci_hcd
    00:1d.1 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 [8086:27c9] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: uhci_hcd
    00:1d.2 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 [8086:27ca] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: uhci_hcd
    00:1d.3 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 [8086:27cb] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: uhci_hcd
    00:1d.7 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller [8086:27cc] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: ehci_hcd
    00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
    00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: ata_piix
    00:1f.2 SATA controller [0106]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller [8086:27c5] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: ahci
    00:1f.3 SMBus [0c05]: Intel Corporation N10/ICH 7 Family SMBus Controller [8086:27da] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    05:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
    Subsystem: Intel Corporation PRO/Wireless 3945BG Network Connection [8086:1005]
    Kernel driver in use: iwl3945
    08:08.0 Ethernet controller [0200]: Intel Corporation PRO/100 VE Network Connection [8086:1092] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: e100
    08:09.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832]
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: ohci1394
    08:09.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 19)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    Kernel driver in use: sdhci-pci
    08:09.2 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 0a)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]
    08:09.3 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev 05)
    Subsystem: Hewlett-Packard Company Device [103c:30b2]


    Regards
    Arefin

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

    This is the device
    Code:
    05:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
    	Subsystem: Intel Corporation PRO/Wireless 3945BG Network Connection [8086:1005]
    	Kernel driver in use: iwl3945
    As you can see the correct driver is in place: Kernel driver in use: iwl3945

    Have you been able to use the wired connection to get the machine updated?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

    Quote Originally Posted by caf4926 View Post
    This is the device
    Code:
    05:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
    	Subsystem: Intel Corporation PRO/Wireless 3945BG Network Connection [8086:1005]
    	Kernel driver in use: iwl3945
    As you can see the correct driver is in place: Kernel driver in use: iwl3945

    Have you been able to use the wired connection to get the machine updated?

    I have updated the OS using ethernet. My wireless stop working suddenly. At the first time it worked fine. After that, i could not make it work.

    Regards
    Arefin

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

    Try creating a new user login and see if wireless works there
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

    The creating a new user does not work. Actually when I turn on the wireless device physicall, the LED does not change. But the same thing works on open suse 11.1 or ubuntu.

    Regards
    Arefin

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Intel PRO/WIRELESS 3945ABG problem with OpenSUSE 11.3

    Have you worked thru this
    Getting Your Wireless to Work
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 5 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •