Results 1 to 9 of 9

Thread: digiKam 1.5

  1. #1
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    436

    Default digiKam 1.5

    hi


    with opensuse 11.3, kde 4.5 somebody is able to install digikam 1.5?

    they seem to have dependencies problem

    thanks

  2. #2
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: digiKam 1.5

    On Sat, 23 Oct 2010 17:36:01 +0530, collinm <collinm@no-mx.forums.opensuse.org> wrote:

    > with opensuse 11.3, kde 4.5 somebody is able to install digikam 1.5?
    >
    > they seem to have dependencies problem


    i'm having digikam installed & running since KDE 4.1. don't know when it changed to 1.5, but it's running fine here: KDE 4.5.2 (factory repos), oS 11.3 (.x86_64). perhaps you've got some repos mixed up?

    --
    phani.

  3. #3

    Default Re: digiKam 1.5

    Same problem. opensuse 11.3 kde 4.4.4 digikam 1.5.
    error: symbol lookup error: /usr/lib/libdigikamcore.so.1: undefined symbol: _ZN11KDcrawIface19RawDecodingSettingsaSERKS0_

    and similar for showfoto.

    Any ideas? Thanks.

  4. #4
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: digiKam 1.5

    On Sat, 23 Oct 2010 20:36:02 +0530, bluesky46 <bluesky46@no-mx.forums.opensuse.org> wrote:

    >
    > Same problem. opensuse 11.3 kde 4.4.4 digikam 1.5.
    > error: symbol lookup error: /usr/lib/libdigikamcore.so.1: undefined
    > symbol: _ZN11KDcrawIface19RawDecodingSettingsaSERKS0_
    >
    > and similar for showfoto.
    >
    > Any ideas? Thanks.


    what KDE repos are you using? there was a bit of confusion at some point when KDE changed their repo names. many people were using KDE factory, then it was recommended to change to release/45, since factory would soon turn into KDE 4.6.x

    release/45 uses qt ver. 4.6, while factory uses 4.7. there are related repos, playground and such, and if you try to mix KDE factory with KDE release/45, this type of trouble is sure to happen. not knowing what exactly you are using, i'd check in detail where you installed digikam and your other KDE stuff from.

    --
    phani.

  5. #5

    Default Re: digiKam 1.5

    phani, thank you. I did check my repos and these are all the oficial kde4.4 repos.

    However, reading some other threads re the subject I deleted digikamrc file and the application started. It remains to be seen if it is fully functional. I will revert once I completed the test.

    bluesky46


    p.s. Just completed the test. digikam is now crashing during 'scanning collections'. Back to the drawing board!!!!!

  6. #6
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    436

    Default Re: digiKam 1.5

    repository i have for kde

    Index of /repositories/KDE:/Release:/45/openSUSE_11.3
    Index of /repositories/KDE:/Extra/openSUSE_11.3
    Index of /repositories/KDE:/UpdatedApps/openSUSE_11.3

    i get:

    digikam 1.5 need libmarblewidget.so.4

    i have marble installed but it's provided only: libmarblewidget.so.10

  7. #7
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: digiKam 1.5

    On Sat, 23 Oct 2010 21:36:01 +0530, bluesky46 <bluesky46@no-mx.forums.opensuse.org> wrote:

    > p.s. Just completed the test. digikam is now crashing during 'scanning
    > collections'. Back to the drawing board!!!!!


    puzzles me; digikam never gave me any trouble, thru' all versions of KDE 4, using alternately KDE factory and /release45 repos, and back again to factory. what happens if you start digikam from a terminal? that should produce output, particularly interesting what happens before & during the crash.

    --
    phani.

  8. #8
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: digiKam 1.5

    On Sat, 23 Oct 2010 22:06:02 +0530, collinm <collinm@no-mx.forums.opensuse.org> wrote:

    >
    > repository i have for kde
    >
    > 'Index of /repositories/KDE:/Release:/45/openSUSE_11.3'
    > (http://tinyurl.com/2whoy8q)
    > 'Index of /repositories/KDE:/Extra/openSUSE_11.3'
    > (http://download.opensuse.org/reposit...openSUSE_11.3/)
    > 'Index of /repositories/KDE:/UpdatedApps/openSUSE_11.3'
    > (http://tinyurl.com/374aebh)


    i think there's a couple problems in your repo selection:

    1. using release:/45 as your main repo, you should be using
    http://download.opensuse.org/reposit...DE_Release_45/
    NOT http://download.opensuse.org/reposit...openSUSE_11.3/

    but this repo doesn't contain digikam, so it may not be the reason for its malfunction.

    2. Index of /repositories/KDE:/UpdatedApps/openSUSE_11.3 is meant as addon for the standard stable repo, i.e., KDE 4.4, and i suspect that this is the reason for your problem. KDE Release:/45 includes digikam 1.4. IMO you should switch to that version and i believe digikam would run ok.

    here's a link to the available KDE repos with some explanations which ones to use--in case i misunderstood something...
    http://en.opensuse.org/KDE_repositories

    --
    phani.

  9. #9
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    436

    Default Re: digiKam 1.5

    thanks for theses information

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •