Page 1 of 6 123 ... LastLast
Results 1 to 10 of 60

Thread: Toshiba laptop Fan control

  1. #1

    Default Toshiba laptop Fan control

    Okay, I like other have had a problem with this. I can't seem to find out how to solve this so i'm hoping someone here can help.

    I Have a Toshiba satellite with openSUSE 11.3 (i586) KDE: 4.4.4 (KDE 4.4.4) "release 3"
    and when i start my computer my fan is either off or running very slow. (Excellent) After being on for a few minutes the fan kicks on as it should but then it just doesn't stop. It keeps running at high speed making a loud whine and doesn't stop until I shut down. My graphics card is ATI Technologies Inc Model: Radeon X1200

    p.s Computer won't wake up form Hibernate or suspend. Completely different issue just as a side note.

  2. #2
    Join Date
    Jul 2010
    Location
    Fuerth, Germany
    Posts
    71

    Default Re: Toshiba laptop Fan control

    Can you be more specific about that laptop? The CPU might be a bit too knew and the kernel might use it not in the right way and use no power management. There is a very helpful tool to find out what is happening there: powertop. It is not installed by default, but give it a try.

  3. #3

    Default Re: Toshiba laptop Fan control

    Quote Originally Posted by cyberiad View Post
    Can you be more specific about that laptop? The CPU might be a bit too knew and the kernel might use it not in the right way and use no power management. There is a very helpful tool to find out what is happening there: powertop. It is not installed by default, but give it a try.
    It's a Satellite l305d-25893 Model: Pslcou-02601p

    cpu is an AMD Turion(tm) 64 X2 Mobile Technology TL-60 Speed: 2,000.00 MHz

    When I try to run powertop nothing seems to happen.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,905
    Blog Entries
    15

    Default Re: Toshiba laptop Fan control

    Quote Originally Posted by tadcrazio
    cyberiad;2241919 Wrote:
    > Can you be more specific about that laptop? The CPU might be a bit too
    > knew and the kernel might use it not in the right way and use no power
    > management. There is a very helpful tool to find out what is happening
    > there: powertop. It is not installed by default, but give it a try.


    It's a Satellite l305d-25893 Model: Pslcou-02601p

    cpu is an AMD Turion(tm) 64 X2 Mobile Technology TL-60 Speed: 2,000.00
    MHz

    When I try to run powertop nothing seems to happen.

    Hi
    Does the command sensors work? You could try adding the option at boot
    time in the grub menu options as a test;
    Code:
    acpi_enforce_resources=lax
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.23-0.3-default
    up 1 day 4:46, 4 users, load average: 0.00, 0.02, 0.04
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.12


  5. #5

    Default Re: Toshiba laptop Fan control

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Does the command sensors work? You could try adding the option at boot
    time in the grub menu options as a test;
    Code:
    acpi_enforce_resources=lax
    -2
    Well nothing happens when I enter it into a terminal. I don't know how to ad the option at boot time in the grub menu option.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,905
    Blog Entries
    15

    Default Re: Toshiba laptop Fan control

    Quote Originally Posted by tadcrazio
    malcolmlewis;2242294 Wrote:
    > Hi
    > Does the command sensors work? You could try adding the option at boot
    > time in the grub menu options as a test;
    > >

    Code:
    --------------------
    > >

    > acpi_enforce_resources=lax
    >

    --------------------
    > >

    >
    > -2


    Well nothing happens when I enter it into a terminal. I don't know how
    to ad the option at boot time in the grub menu option.

    Hi
    It only works at grub, you have to enter the command in the options
    down the bottom of the menu at boot time. Just start typing the command
    and it will automatically start to enter there, else use the arrow
    up/down keys to stop the boot timer, then enter the command.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.23-0.3-default
    up 1 day 14:31, 4 users, load average: 0.09, 0.06, 0.01
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.12


  7. #7

    Default Re: Toshiba laptop Fan control

    well the fan runs, just not loud. Do i have to type that in all the time now?

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,905
    Blog Entries
    15

    Default Re: Toshiba laptop Fan control

    Quote Originally Posted by tadcrazio
    well the fan runs, just not loud. Do i have to type that in all the time
    now?
    Hi
    OK, so do you get any fan output from;
    Code:
    sensors
    acpi -V
    To add the option you need to edit (as root user)
    the /boot/grub/menu.lst and add the option to the menu.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.3 (x86_64) Kernel 2.6.34.7-0.4-default
    up 1 day 11:02, 2 users, load average: 0.09, 0.09, 0.06
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.12


  9. #9

    Default Re: Toshiba laptop Fan control

    anthony@linux-75uw:~> sensors
    acpitz-virtual-0
    Adapter: Virtual device
    temp1: +35.0C (crit = +105.0C)

    k8temp-pci-00c3
    Adapter: PCI adapter
    Core0 Temp: +38.0C
    Core0 Temp: +30.0C
    Core1 Temp: +35.0C
    Core1 Temp: +26.0C

    anthony@linux-75uw:~> acpi -v
    acpi 0.09

    Copyright (C) 2001 Grahame Bowland.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    anthony@linux-75uw:~>



    What was suppose to happen with that second code?

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,905
    Blog Entries
    15

    Default Re: Toshiba laptop Fan control

    Hi
    Sometimes there is additional output with the acpi command to confirm fan rpm.

    So the core temperatures seem better now?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 6 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •