Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: root password problem with Yast

  1. #1

    Default root password problem with Yast

    Hi,

    Yast has recently decided to refuse my root password when started from the application launcher. However, I have no problem opening a shell, logining in as root (su command), then starting yast (yast command).

    I am working on a OpenSuse 11.2 machine.

    Any help to resolve this mystery would be appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: root password problem with Yast

    I suppose the problem is rather caused by kdesu, not YaST itself, test that with

    Code:
    kdesu yast2
    ...and post the output here.

    If you use KDE, in case of GNOME it's 'gksu' I think.

  3. #3

    Default Re: root password problem with Yast

    'kdesu yast2' opens the same window as the one open from the application launcher (so I guess there is a good chance that you found the culprit). After I type my root password, the window displays: Incorrect password, please try again.

  4. #4
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: root password problem with Yast

    Again: please post the output of the command line (not of the kdesu-window).

    Edit: maybe you type that command in a KRunner line (Alt + F2)? I mean an actual terminal.

  5. #5

    Default Re: root password problem with Yast

    Nope, ran it from shell.

    There is no output to the shell after the window is open.

  6. #6
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: root password problem with Yast

    Weird, because this is how it looks for me:

    Code:
    kalle@hoppers:~> kdesu yast2
    kdesu(8767)/kdesu (kdelibs) KDESu::PtyProcess::exec: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/process.cpp : 295 ]  Running "/bin/su"
    kdesu(8767)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/su.cpp : 259 ]  Read line "Password: "
    kdesu(8767)/kdesu (kdelibs) KDESu::PtyProcess::exec: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/process.cpp : 295 ]  Running "/bin/su"
    kdesu(8767)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/su.cpp : 259 ]  Read line "Password: "
    kdesu(8767)/kdesu (kdelibs) KDESu::PtyProcess::WaitSlave: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/process.cpp : 381 ]  Child pid 8772
    kdesu(8767)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/su.cpp : 259 ]  Read line ""
    kdesu(8767)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/su.cpp : 259 ]  Read line "kdesu_stub"
    kdesu(8767)/kdesu (kdelibs) KDESu::PtyProcess::exec: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/process.cpp : 295 ]  Running "/bin/su"
    kdesu(8767)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/su.cpp : 259 ]  Read line "Password: "
    kdesu(8767)/kdesu (kdelibs) KDESu::PtyProcess::WaitSlave: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/process.cpp : 381 ]  Child pid 8777
    kdesu(8767)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/su.cpp : 259 ]  Read line ""
    kdesu(8767)/kdesu (kdelibs) KDESu::SuProcess::ConverseSU: [ /usr/src/packages/BUILD/kdelibs-4.5.2/kdesu/su.cpp : 259 ]  Read line "kdesu_stub"
    You do run 'kdesu' as user, don't you?

  7. #7

    Default Re: root password problem with Yast

    Yes, running it from shell as user not root.

    If I run kdesu with the -t option, the shell displays the following text after I enter my password:
    kdesu_stub

    And that's it.

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,956
    Blog Entries
    2

    Default Re: root password problem with Yast

    You might take a look at this recent thread to see if anything in it works for you

    new kernel - shell error message

    HTH,
    Tony

  9. #9
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: root password problem with Yast

    I think it's unlikely that these two are related, tsu2.

    pomchip, please post the output of

    Code:
    kde4-config --version
    zypper se -s kdebase4-runtime

  10. #10

    Default Re: root password problem with Yast

    Code:
    >kde4-config --version
    Qt: 4.5.3
    KDE: 4.5.3 (KDE 4.3.5) "release 0"
    kde4-config: 1.0
    > zypper se -s kdebase4-runtime
    Repository 'openSUSE:11.2:Contrib' is out-of-date. You can run 'zypper refresh' as root to update it.
    Loading repository data...
    Reading installed packages...
    
    S | Name                               | Type       | Version      | Arch   | Repository
    --+------------------------------------+------------+--------------+--------+---------------------
    i | kdebase4-runtime                   | package    | 4.3.5-0.1.2  | i586   | openSUSE-11.2-Update
    v | kdebase4-runtime                   | package    | 4.3.1-5.6.3  | i586   | openSUSE-11.2-Oss
      | kdebase4-runtime                   | srcpackage | 4.3.5-0.1.2  | noarch | openSUSE-11.2-Update
    i | kdebase4-runtime-branding-openSUSE | package    | 11.2-29.31.1 | i586   | openSUSE-11.2-Update
    v | kdebase4-runtime-branding-openSUSE | package    | 11.2-29.30.1 | i586   | openSUSE-11.2-Oss
      | kdebase4-runtime-branding-upstream | package    | 4.3.5-0.1.2  | i586   | openSUSE-11.2-Update
      | kdebase4-runtime-branding-upstream | package    | 4.3.1-5.6.3  | i586   | openSUSE-11.2-Oss

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •