Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: opensuse 11.2 "broken" eth0

  1. #1

    Default opensuse 11.2 "broken" eth0

    hi all

    I am occuring a problem with my ethernet connection. Two days ago everything was fine. Yesterday when I turned on my computer I had no internet connection, so I "played" a little bit with the modem and restarted few time the computer. During one of the restarts I couldn't login any more (no space available problem), solved it however there was no ethernet connection. Furthermore some of my configurations got lost (default app for file extension, all items at the panel etc) I tested the modem/connection via vista/ubuntu and everything worked so I narrowed down the problem to my instance of the opensuse 11.2. I searched a little bit on the forum and after typing "rcnetwork restart" I am having this output:
    Code:
    Shutting down network interfaces:
        eth0      device: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
        eth0                                                                                                                                                                 done
        wlan0     device: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
        wlan0                                                                                                                                                                done
    Shutting down service network  .  .  .  .  .  .  .  .  .                                                                                                                 done
    Hint: you may set mandatory devices in /etc/sysconfig/network/config
    Setting up network interfaces:
        eth0      device: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
        eth0      is controlled by ifplugd
        eth0                                                                                                                                                                 waiting
        wlan0     device: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
        wlan0     starting wpa_supplicant
    SIOCSIFFLAGS: Unknown error 132
    Could not set interface 'wlan0' UP
    RTNETLINK answers: Unknown error 132
        wlan0     Starting DHCP4 client. . . .  
        wlan0     DHCP4 client NOT running
    RTNETLINK answers: Unknown error 132
    Cannot enable interface wlan0.
    interface wlan0 is not up
        wlan0                                                                                                                                                                failed
    Setting up service network  .  .  .  .  .  .  .  .  .  .                                                                                                                 done
    SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
    SuSEfirewall2: using default zone 'ext' for interface wmaster0
    WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
    WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
    WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
    WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
    WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
    SuSEfirewall2: batch committing...
    SuSEfirewall2: Firewall rules successfully set
    From /var/log/messages output (just the ones from execution of the cmd I hope)

    Code:
    Oct 20 16:59:04 linux-kszg ifplugd(eth0)[14734]: Executing '/etc/sysconfig/network/scripts/ifplugd-selectif eth0 down'.
    Oct 20 16:59:04 linux-kszg ifplugd(eth0)[14734]: client: ifdown eth0 -o ifplugd
    Oct 20 16:59:04 linux-kszg ifplugd(eth0)[14734]: client:     eth0      device: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
    Oct 20 16:59:04 linux-kszg ifdown:     eth0      device: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
    Oct 20 16:59:04 linux-kszg dhcpcd[14919]: eth0: received SIGTERM, stopping
    Oct 20 16:59:04 linux-kszg dhcpcd[14919]: eth0: exiting
    Oct 20 16:59:05 linux-kszg avahi-daemon[4511]: Withdrawing address record for fe80::21e:68ff:fe18:c06c on eth0.
    Oct 20 16:59:05 linux-kszg ifplugd(eth0)[14734]: Program executed successfully.
    Oct 20 16:59:05 linux-kszg ifplugd(eth0)[14734]: Exiting.
    Oct 20 16:59:05 linux-kszg ifdown:     eth0      device: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
    Oct 20 16:59:05 linux-kszg ifdown:     wlan0     device: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
    Oct 20 16:59:06 linux-kszg ifplugd(eth0)[17432]: ifplugd 0.28 initializing.
    Oct 20 16:59:06 linux-kszg ifplugd(eth0)[17432]: Using interface eth0/00:1E:68:18:C0:6C with driver <r8169> (version: 2.3LK-NAPI)
    Oct 20 16:59:06 linux-kszg ifplugd(eth0)[17432]: Using detection mode: SIOCETHTOOL
    Oct 20 16:59:06 linux-kszg ifplugd(eth0)[17432]: Initialization complete, link beat detected.
    Oct 20 16:59:06 linux-kszg ifplugd(eth0)[17432]: Executing '/etc/sysconfig/network/scripts/ifplugd-selectif eth0 up'.
    Oct 20 16:59:06 linux-kszg kernel: [ 4048.469431] r8169: eth0: link up
    Oct 20 16:59:06 linux-kszg ifplugd(eth0)[17432]: client: ifup eth0 -o ifplugd
    Oct 20 16:59:06 linux-kszg ifup:     eth0      device: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
    Oct 20 16:59:06 linux-kszg ifup:     eth0      is controlled by ifplugd
    Oct 20 16:59:06 linux-kszg ifplugd(eth0)[17432]: client:     eth0      device: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
    Oct 20 16:59:06 linux-kszg ifup:     eth0      device: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
    Oct 20 16:59:06 linux-kszg ifup-dhcp: Starting DHCP4 client on eth0
    Oct 20 16:59:06 linux-kszg dhcpcd[17602]: eth0: dhcpcd 3.2.3 starting
    Oct 20 16:59:06 linux-kszg dhcpcd[17602]: eth0: hardware address = 00:1e:68:18:c0:6c
    Oct 20 16:59:06 linux-kszg dhcpcd[17602]: eth0: broadcasting for a lease
    Oct 20 16:59:06 linux-kszg dhcpcd[17602]: eth0: option 43 has zero length
    Oct 20 16:59:06 linux-kszg dhcpcd[17602]: eth0: failed to parse packet
    Oct 20 16:59:06 linux-kszg ifup:     wlan0     device: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
    Oct 20 16:59:06 linux-kszg ifup-wireless:     wlan0     starting wpa_supplicant
    Oct 20 16:59:07 linux-kszg avahi-daemon[4511]: Registering new address record for fe80::21e:68ff:fe18:c06c on eth0.*.
    Oct 20 16:59:07 linux-kszg ifup-dhcp: . 
    Oct 20 16:59:09 linux-kszg dhcpcd[17602]: eth0: option 43 has zero length
    Oct 20 16:59:09 linux-kszg dhcpcd[17602]: eth0: failed to parse packet
    Oct 20 16:59:09 linux-kszg ifup-dhcp: . 
    Oct 20 16:59:12 linux-kszg ifup-dhcp: . 
    Oct 20 16:59:12 linux-kszg dhcpcd[17602]: eth0: option 43 has zero length
    Oct 20 16:59:12 linux-kszg dhcpcd[17602]: eth0: failed to parse packet
    Oct 20 16:59:12 linux-kszg ifup-dhcp:     wlan0     Starting DHCP4 client
    Oct 20 16:59:12 linux-kszg dhcpcd[18407]: wlan0: dhcpcd 3.2.3 starting
    Oct 20 16:59:12 linux-kszg dhcpcd[18407]: wlan0: ioctl SIOCSIFFLAGS: Unknown error 132
    Oct 20 16:59:12 linux-kszg dhcpcd[18407]: wlan0: exiting
    Oct 20 16:59:13 linux-kszg ifup-dhcp: . . 
    Oct 20 16:59:13 linux-kszg ifup-dhcp: . . 
    Oct 20 16:59:14 linux-kszg ifup-dhcp: . 
    Oct 20 16:59:14 linux-kszg ifup-dhcp:  
    Oct 20 16:59:14 linux-kszg ifup-dhcp:     wlan0     DHCP4 client NOT running
    Oct 20 16:59:14 linux-kszg ifup: Cannot enable interface wlan0.
    Oct 20 16:59:14 linux-kszg ifup-route: interface wlan0 is not up
    Oct 20 16:59:14 linux-kszg SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
    Oct 20 16:59:14 linux-kszg SuSEfirewall2: using default zone 'ext' for interface wmaster0
    Oct 20 16:59:15 linux-kszg SuSEfirewall2: batch committing...
    Oct 20 16:59:15 linux-kszg SuSEfirewall2: Firewall rules successfully set
    Oct 20 16:59:15 linux-kszg dhcpcd[17602]: eth0: option 43 has zero length
    Oct 20 16:59:15 linux-kszg dhcpcd[17602]: eth0: failed to parse packet
    Oct 20 16:59:16 linux-kszg kernel: [ 4058.658040] eth0: no IPv6 routers present
    Oct 20 16:59:16 linux-kszg ifup-dhcp: . 
    Oct 20 16:59:18 linux-kszg dhcpcd[17602]: eth0: option 43 has zero length
    Oct 20 16:59:18 linux-kszg dhcpcd[17602]: eth0: failed to parse packet
    Oct 20 16:59:19 linux-kszg ifup-dhcp: . 
    Oct 20 16:59:21 linux-kszg dhcpcd[17602]: eth0: option 43 has zero length
    Oct 20 16:59:21 linux-kszg dhcpcd[17602]: eth0: failed to parse packet
    Oct 20 16:59:21 linux-kszg ifup-dhcp: .
    As far as I checked the /var/log/messages file. The problem is I think in the fact that eth0 can not get the IP from modem. Cause when I checked logs from 2days ago when eth0 was leasing for the IP it was getting it. Also I can't ping the gateway.

    Anyone has an idea how I can solve this problem. Will greatly appreciate the help.

    thx in advance

  2. #2
    Join Date
    Nov 2009
    Location
    USA
    Posts
    101

    Default Re: opensuse 11.2 "broken" eth0

    Check your fiewall settings under yast. Mine is set to External Zone for my net card.
    You can also stop and start the firewall to see if thats what is stopping you from getting on the net.
    I have A Momentary Lapse of Reason | Learning to Fly <and looking for> Signs of Life <after> The Dogs of War <have had> One Slip On the Turnning Away <but> Yet Another Movie <and> A New Machine <with> Terminal Frost <and> Sorrow.

  3. #3

    Default Re: opensuse 11.2 "broken" eth0

    Check your fiewall settings under yast. Mine is set to External Zone for my net card.
    You can also stop and start the firewall to see if thats what is stopping you from getting on the net.
    Mine is also set to external zone, also when I've stopped the firewall I still couldn't connect (tested via ping, waited 3min to get IP, which I haven't receive). Besides I have never changed any firewall settings.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,871
    Blog Entries
    2

    Default Re: opensuse 11.2 "broken" eth0

    According to your logs, for some reason your ethernet (hardwired) interface is managed by ifplugd. For some reason somewhere between when ifplugd starts managing your eth0 interface and when your dhcpcd starts running something failed.

    Recommend you take a look at the various ifplugd commands, try them to analyze what might have gone wrong (eg are you physically plugged in, is the ethernet port light on?).

    HTH,
    Tony

  5. #5

    Default Re: opensuse 11.2 "broken" eth0

    Recommend you take a look at the various ifplugd commands, try them to analyze what might have gone wrong (eg are you physically plugged in, is the ethernet port light on?).
    The light is on when the cabel is physically plugged in. Can you recommend me some ifplugd cmds to use. Since I don't know this cmd I don't know what is important or what will be helpfull to solve the problem. What I was able to determin is that ifplugd detects when the cable is pluged in/out.

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,871
    Blog Entries
    2

    Default Re: opensuse 11.2 "broken" eth0

    Quote Originally Posted by blah01 View Post
    The light is on when the cabel is physically plugged in. Can you recommend me some ifplugd cmds to use. Since I don't know this cmd I don't know what is important or what will be helpfull to solve the problem
    Scratch what I said for the moment, it might be possible to find the YAST setting that controls ifplugd.

    Are you using IFUP/IFDOWN and not NetworkManager? If so, try take a look at the YAST network card settings > Edit> General tab.

    Verify that the "Activate device" dropdown is set either to Boot Time or to On Connection. I'm taking a look at my OpenSuSE 11.3 which for some reason uses the HotPlug daemon instead of the ifplugd daemon and I don't have an 11.2 setup to know if this is just a recent change across versions or the "On Connection" option is configured for ifplugd... If someone else can clarify this point, that'd be good.

    In any case, save the setting and reboot (particularly if you're set to "Boot Time").

    Hopefully that will fix your problem.
    If that doesn't work, then maybe go back into the setting and set to "On Connection," save and see if things work immediately (give it about 3 minutes maybe to reset the network device and acquire settings). If that doesn't work, then set back to Boot time, reboot and check... and if it STILL doesn't work then post back.

    Tony

  7. #7

    Default Re: opensuse 11.2 "broken" eth0

    Are you using IFUP/IFDOWN and not NetworkManager?
    Don't know to be honest, how can I verify that?

    Originaly I was using "On Cable connection" I have changed that to "On Boot" (rebooted) didn't work changed again to "On Connection" didn't work (not so big supprise ). I have verified that the modem is actually giving me the IP adress (logged in to the modem, checked IP adresses given), don't know if that is some kind of a clue. Also I am getting this "error" constantly

    Code:
    eth0: 43 has zero length
    eth0: failed to parse packet
    Don't know if that is something important.

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,871
    Blog Entries
    2

    Default Re: opensuse 11.2 "broken" eth0

    Quote Originally Posted by blah01 View Post
    Don't know to be honest, how can I verify that?

    Originaly I was using "On Cable connection" I have changed that to "On Boot" (rebooted) didn't work changed again to "On Connection" didn't work (not so big supprise ). I have verified that the modem is actually giving me the IP adress (logged in to the modem, checked IP adresses given), don't know if that is some kind of a clue. Also I am getting this "error" constantly

    Code:
    eth0: 43 has zero length
    eth0: failed to parse packet
    Don't know if that is something important.
    Howdy,
    Pls post ifconfig to verify for sure whether you're assigned an IP address on the eth0 interface, whether there are any other interfaces (besides I see your wlan which is not connected), and if your modem says it issued a lease whether the date is today.

    So, for instance awhile back I deployed OpenSuSE on a virtual machine and every time it was moved from from one network to another and back again, for whatever reason it wasn't able to use an existing ethernet interface and kept creating new interfaces, incrementing (eg eth1, eth2). And, of course each time I would then have to modify the network settings to use the new interface, or manually remove the extra interfaces to start from eth0 again.

    Tony

  9. #9

    Default Re: opensuse 11.2 "broken" eth0

    if your modem says it issued a lease whether the date is today.
    I also checked just out of curiosity the wlan0, the same problem. As I checked "logs" on the modem it looks fine (time, date etc), "from modem point of view" everything looks fine. The IP adress was given both to ethernet and wlan. However the computer "don't have" them.

    ifconfig -a //output when ethenrnet cable is plugged in and modem states that eth has IP

    Code:
    eth0      Link encap:Ethernet  HWaddr 00:1E:68:18:C0:6C  
              inet6 addr: fe80::21e:68ff:fe18:c06c/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1734 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1573 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:563159 (549.9 Kb)  TX bytes:532710 (520.2 Kb)
              Interrupt:29 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:232 errors:0 dropped:0 overruns:0 frame:0
              TX packets:232 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:16552 (16.1 Kb)  TX bytes:16552 (16.1 Kb)
    
    wlan0     Link encap:Ethernet  HWaddr 00:1C:BF:AB:AB:52  
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:133 errors:0 dropped:0 overruns:0 frame:0
              TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:41006 (40.0 Kb)  TX bytes:22896 (22.3 Kb)
    
    wmaster0  Link encap:UNSPEC  HWaddr 00-1C-BF-AB-AB-52-00-00-00-00-00-00-00-00-00-00  
              [NO FLAGS]  MTU:0  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    The interesting thing is the fact that eth0 has inet6 adr while modem issued std IPv4.

    Just for the record when I tried wlan0 I was getting this (same as for eth0)

    Code:
    wlan0: 43 has zero length
    wlan0: failed to parse packet

  10. #10
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,871
    Blog Entries
    2

    Default Re: opensuse 11.2 "broken" eth0

    Without actually addressing whatever is causing your problem, most people are advised that whenever you have a wireless interface they recommend using NetworkManager instead of IFUP/IFDOWN (which I see you seem to be doing).

    YAST > Network Devices > Click on "Global Options"

    On that tab, you should be presented with several options, the first is "User Controlled with NetworkManager"

    Although may not be necessary, I recommend rebooting afterwards.
    You should then be able to invoke Network Manager either from a tray icon (lower right on the bottom Panel) or from the "Run Command" typing networkmanager or knetworkmanager.

    Once Network Manager is launched, you can then go in and start configuring your wired and possibly your wireless connections if your settings aren't already inherited.

    Just curious what you're using currently for your WiFi configuration...

    Also, am curious if you have both your wired and wireless network adapters enabled at the same time... If they're both enabled and connecting to the same Internet Gateway, I can sure imagine some weird routing issues and who knows what else... If this is what's happening, just disable one of your network connections and the other ought to work (Probably require a reboot if /sbin/network restart doesn't work).

    Tony

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •