Results 1 to 7 of 7

Thread: Old GTK1.x libraries for openSUSE

  1. #1
    Join Date
    Oct 2010
    Location
    London, UK
    Posts
    18

    Default Old GTK1.x libraries for openSUSE

    Hello, I'm executing the Wolfenstein Enemy Territory installer, and since finding the first package it missed, I've been stumped.
    It wants a gtklib-1.2.so, and I've been on the internet looking everywhere I know, I don't like to pester with easily-solvable problems.

    I've found a lot about it, however no solutions when '-ubuntu' is added - seems Ubuntu folk apt-get this and that all the time, whereas I can't find what I'm looking for in the Software Manager or Software Search on openSuSE.org/en
    I know the missing libraries are a simply case of back-tracking a bit and installing GTK1.x type packages, the thing is I can only find 2 onwards - I have everything in 64 and 32 versions, but just too reecent it seems.

    For this case and in future similar cases - where are the old-school versions to be found, and how can they easily be added to SUSE if they come in an .rpm etc?
    A way of adding a broader selection to the package browser?

    I am very new to all this, and very grateful for any help.

    Many thanks!

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Old GTK1.x libraries for openSUSE

    I couldn't find it anywhere. Maybe you have to compile it on openSUSE? - I found this thread on these forums but I don't think it will be that helpful:
    Compiling GTK+ 1.2 on suse 11.3 x64 in order to install xmms 1
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3
    Join Date
    Oct 2010
    Location
    London, UK
    Posts
    18

    Default Re: Old GTK1.x libraries for openSUSE

    Hi, thanks so much for looking. I found that thread earlier, but (I may be wrong) I didn't think it was quite what I was looking for. The packages listed seem too specific / may omit the one I want? I'm certainly inexperienced enough to be missing out on a valuable answer though.

  4. #4
    Join Date
    Oct 2010
    Location
    London, UK
    Posts
    18

    Default Re: Old GTK1.x libraries for openSUSE

    I'm sure it has its reasons, but the 10-minute edit meant I lost a follow-up that didn't require a message of its own.

    I said; I'm sorry if I've been a nuisance for not including more info from the start, this is the error:
    Code:
    /.setup14691: error while loading shared libraries: libgtk-1.2.so.0: cannot open shared object file: No such file or directory
    ./setup.sh: line 143: 14719 Aborted                 "$setup" "$@" 2>> $NULL
    The setup program seems to have failed on x86/glibc-2.1
    I managed to find a glibc-obsolete package, in case it filled the historic gaps my up-to-date glibc might be lacking, with no result. I'll double check if a reboot makes a difference / is needed.

  5. #5
    Join Date
    Feb 2009
    Location
    Canada
    Posts
    131

    Default Re: Old GTK1.x libraries for openSUSE

    GTk 1 was dropped from openSUSE in 11.3. Since so few people use it in our community, no one has bothered to package it for their own use.

    If you have a .deb, you could attempt to use a ulility called "alien" that can convert .deb to .rpm. There's no guarantee it will work, but it is an option outside of doing a fresh compile of the libraries.

    Alternatively, you could try to install the appropriate packages from openSUSE 11.2.

    I suspect in the end, you'll have to PM the person who compiled GTK 1.2 for XMMS and get their direction.
    Primary OS: openSUSE 11.4
    Testing OS: openSUSE 12.1
    oS TCT

  6. #6
    Join Date
    Oct 2010
    Location
    London, UK
    Posts
    18

    Default Re: Old GTK1.x libraries for openSUSE

    Thanks, if the first option fails I'll give the second a go. Thank you very much for your reply.

  7. #7
    Join Date
    Oct 2010
    Location
    London, UK
    Posts
    18

    Smile Re: Old GTK1.x libraries for openSUSE

    Wowee! Managed it. RPMs always fail to install for me, but I managed to work around that by opening them in FileRoller and then extracting specific folders from inside.
    Then using terminal to copy specific packages to /usr/lib.
    After installing a package I returned to terminal to see what it needed next, after these four packages (listing them in case anyone else has problems with Enemy Territory) the installer loaded up fine!

    Thanks to the marvellous Welcome to the RPM repository on hany.sk, which I can't praise enough, I got hold of the following RPM's:

    gtk+
    - libgtk-1.2.so.0
    - libgdk-1.2.so.0
    glib
    - libgmodule-1.2.so.0
    - libglib-1.2.so.0

    No idea why I mixed i386 and i586s when I downloaded them, but as far as I've read it shouldn't make a difference unless I was running i386, only problems arise from them not being backwards compatible?

    If this thread could be re-title to include 'Enemy Territory' it might be more helpful to searchers, as it looks like this problem with these libraries would be of most help to someone installing ET more than general help. Nonetheless it will turn up due to contents if they know what they're looking for.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •