Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Problem when trying to update

  1. #1

    Default Problem when trying to update

    Hello,
    I have a problem when trying to update or install new application via Yast, I'm using opensuse 11.3.
    PackageKit Error repo-not-available: Failed to download /content from Index of /distribution/11.3/repo/oss

    thanks for help

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,785
    Blog Entries
    14

    Default Re: Problem when trying to update

    Hi, welcome to the openSUSE forums.

    This is exactly what it says it is: the repo is (temporarily) not available.
    Lately I've seen some cases where the CD/DVD remained as a repo entry, it should not. To find out if this is your problem, please open a terminal window and do:
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem when trying to update

    On 2010-11-28 12:06, ranimbouraoui wrote:
    >
    > Hello,
    > I have a problem when trying to update or install new application via
    > Yast, I'm using opensuse 11.3.
    > PackageKit Error repo-not-available: Failed to download /content from
    > 'Index of /distribution/11.3/repo/oss'
    > (http://download.opensuse.org/distrib...11.3/repo/oss/)


    If it happens every day, look in the logs.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  4. #4

    Default Re: Problem when trying to update

    The problem appear when Yast try to download /content from Index of /distribution/11.3/repo/non-oss

  5. #5

    Default Re: Problem when trying to update

    zypper lr -d Result :
    # | Alias | Nom | Activ | Rafrachir | Priorit | Type | URI | Service
    --+-------------------------------+--------------------------------+--------+------------+----------+--------+-----------------------------------------------------------------+--------
    1 | download.opensuse.org-non-oss | Dpt principal (NON-OSS) | Oui | Oui | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    2 | download.opensuse.org-oss | Dpt principal (DEBUG) | Oui | Oui | 99 | yast2 | Index of /debug/distribution/11.3/repo/oss |
    3 | download.opensuse.org-oss_1 | Dpt principal (OSS) | Oui | Oui | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    4 | download.opensuse.org-oss_2 | Dpt principal (Sources) | Oui | Oui | 99 | yast2 | Index of /source/distribution/11.3/repo/oss |
    5 | download.opensuse.org-update | Dpt principal de mise jour | Oui | Oui | 99 | rpm-md | Index of /update/11.3 |

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,785
    Blog Entries
    14

    Default Re: Problem when trying to update

    First remove #2 and #4 through Yast - Software - Repositories

    Now do:
    Code:
    su -c 'zypper ref'
    and post output here.

    BTW, you do have an internet connection active, don't you ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: Problem when trying to update

    su -c 'zypper ref' result :
    cant download /contnent from 'Dpt principal (NON-OSS)'

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,785
    Blog Entries
    14

    Default Re: Problem when trying to update

    Quote Originally Posted by ranimbouraoui View Post
    su -c 'zypper ref' result :
    cant download /contnent from 'Dpt principal (NON-OSS)'
    Can you please copy and paste exact output. You can select it with mouse, right click in selection, choose copy.

    In the same terminal window, please issue this command:
    Code:
    ip addr
    copy and paste output here.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem when trying to update

    On 2010-11-28 15:36, ranimbouraoui wrote:
    >
    > The problem appear when Yast try to download /content from 'Index of
    > /distribution/11.3/repo/non-oss'
    > (http://download.opensuse.org/distrib.../repo/non-oss/)


    Logs.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10

    Default Re: Problem when trying to update

    ranim@linux-paoi:~> ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
    inet 127.0.0.2/8 brd 127.255.255.255 scope host secondary lo
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:26:9e:67:7f:92 brd ff:ff:ff:ff:ff:ff
    3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
    link/ether 00:1e:64:10:69:28 brd ff:ff:ff:ff:ff:ff
    4: pan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
    link/ether 76:95:bf:39:db:3b brd ff:ff:ff:ff:ff:ff
    8: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 3
    link/ppp
    inet 41.228.89.190 peer 10.64.64.64/32 scope global ppp0

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •