I hope someone can help me with this:
I have got problems with my ldap and kshutdown, which I think are related somehow.
For some reason my Llinux never managed to reach the ldap-server (maybe some configuration issue, I do not know), so I turned ldap off a few days ago. Ever since, kshutdown does not work as it should.
I regularly update, too, that day I did and two more times since then, the last time was just yesterday in the evening.
What happens is: I use K-Menu to start kshutdown and I get the pop-up with my options to log out, reboot and shutdown. I pick my choice an click, the pop-up vanishes and... nothing. I can still use everything, it is as if I never tried to log out etc. But I cannot start kshutdown again - although it is not listed as a running process.
In my /var/log/messages there seems to be no error regarding kshutdown.
So... what I did is: I configured a new ldap-server (hopefully right), without TSL/SSL and activated the ldap-client again. So far no error a la "cannot find ldap-server". Kshutdown is still not working, so maybe ldap has no influence whatsoever (I am not that experienced in such matters).
The only thing I am always able to do (as root) is the shutdown-command, e.g. "shutdown -r now" or "shutdown -h now". Ok, I can do that, no problem. If a friend is using my computer, that is not an option. They should rather be able to log out etc. by themselves without root. And anyway - I like using kshutdown

Anybody able to help? If you need more information, I will see that you get it.

I am using OpenSUSE Linux 11.1 with KDE 4, newest updates yesterday evening.