Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Wine not working

  1. #1

    Default Wine not working

    Hi,

    I want to play WarcraftIII with garena on SUSE. It seems it works only with wine with AcceptEx patch. So i build my own wine from the source using some guides here and on wine pages (downloaded 32b libraries, made symlinks, used ./configure --prefix=/usr --x-libraries=/usr/X11R6/lib --x-includes=/usr/include/X11/ --with-x ,etc.).

    Wine compiles ok and even installs, but when I try to run winecfg it says ../.wine is a 64-bit instalation, it cannot be used with a 32-bit wineserver.
    I've tried to recompile it, use another source files but nothing seems to work. To me it seems like it still uses 64b libraries during compilation, but dunno, I'm noob.

    Any ideas what could be the cause? and solution? Thx

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Wine not working

    I assume you are running 64 bit Linux??

    So you would need to use the 64 bit libraries. Or be sure the whole wine stack is 32 bit. You can't intermingle 64 bit and 32 bit.

  3. #3

    Default Re: Wine not working

    Quote Originally Posted by gogalthorp View Post
    I assume you are running 64 bit Linux??

    So you would need to use the 64 bit libraries. Or be sure the whole wine stack is 32 bit. You can't intermingle 64 bit and 32 bit.
    Yes, i do.

    Well, I followed these instructions:
    Configuring Wine with a patch Problems -post #9

    WineOn64bit - The Official Wine Wiki

    But as I wrote above, it compiles fine, installs and then by executing winecfg returnes that error

  4. #4
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Wine not working

    Are you trying out 1.3 development version? If you just need only 1.2 version, better install the packaged one.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  5. #5
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Wine not working

    And if you need the 1.3 development version there is a repo for it.
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  6. #6

    Default Re: Wine not working

    According to wines appsdb garena should work with wine 1.3.1 with acceptex patch
    WineHQ - Garena Garena 2010

    With 1.2.1 its not supposed to work. However, ive tried 1.3.4 from repos and wasnt able to run garena properly either, (1st attempt garena started, I was even able to join a room, but pings were extremely high - about 500ms, then whenever i tried to start it again it crashed during logging) so I wanted to try 1.3.1 version with patch..

    Have any1 experience with making garena run with wine?

  7. #7
    Will Honea NNTP User

    Default Re: Wine not working

    gogalthorp wrote:

    >
    > I assume you are running 64 bit Linux??
    >
    > So you would need to use the 64 bit libraries. Or be sure the whole
    > wine stack is 32 bit. You can't intermingle 64 bit and 32 bit.


    64-bit wine pulls in the wine 32 bit stuff - I was trying to avoid the
    problem you describe and wiped every part of wine of to start over and down
    it came. Actually, I don't see any unusual problems with either the 64-bit
    or the pure 32-bit packages on an AMD 64.

    --
    Will Honea

  8. #8

    Default Re: Wine not working

    Have you tried to rename /home/user/.wine and run winecfg again?
    This error usually appears when you replace 64bit wine package with 32bit wine package and keep the old .wine folder.

  9. #9

    Default Re: Wine not working

    Well I was forced to reinstall suse, this time with gnome and it appears that garena is working finally((; I just used 1.3.4 wine from repos and was able to make it run(thats strange, cuz I did EXACTLY the same thing previously in KDE and garena just crashed at start).

    Anyway, thx all of you for your help, I appreciate it

  10. #10
    Join Date
    Jun 2009
    Location
    Berlin
    Posts
    158

    Default Re: Wine not working

    sometimes it helps to delete ~/.wine directory. this is how i get wine back running after i had the same problem.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •