Results 1 to 5 of 5

Thread: KDE 4.5 mailto links & thunderbird

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,567

    Default KDE 4.5 mailto links & thunderbird

    Recently updated Opensuse 11.3 from KDE 4.4 to 4.5 using the dedicated kde 4.5 repo.
    Loving it and no problems so far other than clicking on mailto links in Firefox.

    In config desktop I have thunderbird set as the default mail application. When I click on a mailto link in Firefox I get the following error message

    Could not start process Unable to create io-slave:
    klauncher said: Error loading 'kmailservice %u'.
    anybody have any idea on how to correct this?

  2. #2
    Join Date
    Dec 2009
    Location
    Menominee, Michigan
    Posts
    56

    Default Re: KDE 4.5 mailto links & thunderbird

    I am seeing the same error. I have changed the default email program to kmail and again get the same error.

    Opensuse 11.2, 64 bit, kdelibs4-4.5.2-5.2 from: Index of /repositories/KDE:/Release:/45/openSUSE_11.2

    I'm not sure when this broke as I haven't clicked on an email link for quite awhile.

    Mark

  3. #3
    Join Date
    Jun 2009
    Location
    Snohomish, WA USA
    Posts
    26

    Default Re: KDE 4.5 mailto links & thunderbird

    I changed the "mailto" to "use thunderbird" in the applications tab of Firefox's preferences, and it works for me. As I understand it you guys changed the default applications in personal settings?

  4. #4
    Join Date
    Dec 2009
    Location
    Menominee, Michigan
    Posts
    56

    Default Re: KDE 4.5 mailto links & thunderbird

    Thanks cesorensen. Changing the setting in firefox did fix the issue. Firefox was set to: Use KDE (default). If I set it to kmail or thunderbird the compose window opens for the respective email application.

    Mark

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,567

    Default Re: KDE 4.5 mailto links & thunderbird

    yes, fixes for me too. Thanks.

    As per the error message . . .bug in KDE 4.5.2 perhaps - as if firefox set to KDE default should launch thunderbird as did with prev versions of KDE?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •