Results 1 to 4 of 4

Thread: Lost the use of pre-arranged hotkeys (Fn+F1,2,...) after installation of openSuSE 11.3

  1. #1

    Default Lost the use of pre-arranged hotkeys (Fn+F1,2,...) after installation of openSuSE 11.3

    I recently installed openSuSE 11.3 on a Toshiba Satellite Pro C650 in dual boot with Windows 7. The computer itself has a bunch of hotkeys already set up. It is a combination of the 'Fn' key with 'F1', 'F2', etc. For example, to blank my screen I
    hit 'Fn+Fi', etc. All these combinations work fine under Windows 7 yet in Linux environment are completely inactive.

    Any ideas on how to re-activate them?

    Thanks

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Lost the use of pre-arranged hotkeys (Fn+F1,2,...) after installation of openSuSE 11.3

    I don't have any experience with Toshiba laptops, but I have read about the fnfx package that supports this feature. Give it a try:
    Code:
    sudo zypper install fnfx
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3

    Default Re: Lost the use of pre-arranged hotkeys (Fn+F1,2,...) after installation of openSuSE 11.3

    Quote Originally Posted by syampillai View Post
    I don't have any experience with Toshiba laptops, but I have read about the fnfx package that supports this feature. Give it a try:
    Code:
    sudo zypper install fnfx

    So, I installed fnfx package. When I tried to run fnfxd daemon as root I got:

    Code:
    fatal error: Could open /proc/acpi/toshiba/keys.
    
    Please make sure that your kernel has enabled the Toshiba option in the ACPI section.
    For more information read the documentation and/or http://fnfx.sf.net/index.php?section=doc#kernel
    The link: 'http://fnfx.sf.net/index.phip?section=doc#kernel' is not active.

    Now what?

  4. #4
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Lost the use of pre-arranged hotkeys (Fn+F1,2,...) after installation of openSuSE 11.3

    Looks like you need a kernel with Toshiba option enabled under the ACPI section. You need to wait for someone else who knows about this to show up.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •