Results 1 to 4 of 4

Thread: Kmail always rings twice

  1. #1

    Default Kmail always rings twice

    On my OpenSuse 11.2 KDE 4.3.5, when I launch kmail for the first time it does not start. I have to re-launch it to get it running.

    By launching it from the command line, I get the message:

    <unknown program name>(7693)/: Communication problem with "kmail" , it probably crashed.
    Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." "

    I find all this quite annoying. What could be the solution?

    As you may have guessed, I'm relatively a newbye...

  2. #2

    Default Re: Kmail always rings twice

    Hello Garfo75 and welcome to the community!

    Quote Originally Posted by Garfo75
    On my OpenSuse 11.2 KDE 4.3.5, when I launch kmail for the first time it does not start. I have to re-launch it to get it running.

    By launching it from the command line, I get the message:

    <unknown program name>(7693)/: Communication problem with "kmail" , it probably crashed.
    Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." "

    I find all this quite annoying. What could be the solution?
    I don't use kmail myself and never encountered this problem.
    Some questions: Did kmail work?
    Did you update/change something before it stopped working?

    But I think it could be a wrong setting in your .kde4 folder.
    To test this make a new user.
    Log-in as that user and try to start kmail (from terminal).

    If it works, then your normal user has most likely some wrong setting.
    To solve the problem you need to remove the config file containing the wrong setting.
    The next time you start KMail it will generate a new config file.

    First of all make a backup.
    Then try renaming a config file and try starting KMail again.
    If the error is still there you can rename the file back.

    Or you could remove all KMail config files and only place the import once back.
    As described here: KMail/FAQs Hints and Tips - KDE UserBase

    If it doesn't work then it's most likely an installation problem.

    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3

    Default Re: Kmail always rings twice

    Thanks Edward,

    Kmail regularly starts the second time that I launch it, at every login.
    Furthermore, if I use the large "Kcontact" or "Korganizer" suite that includes Kmail,
    I do not have any problem: everything runs at the first try after login. I would anyway prefer to run Kmail alone.
    I will try what you have suggested.

  4. #4
    arkascha NNTP User

    Default Re: Kmail always rings twice

    Hi,

    Garfo75 wrote:
    > On my OpenSuse 11.2 KDE 4.3.5, when I launch kmail for the first time it
    > does not start. I have to re-launch it to get it running.


    this sounds exactly like a bug described in DEs or Novells Bugzilla-System.
    It has to do with the communication between different kontact componens.

    Is there a specific reason why you use such an outdated kde version ?
    I never encountered that problem during the last month whilst I had exactly
    the same symptoms month ago.

    arkascha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •