Results 1 to 3 of 3

Thread: Eric sip-scintilla problem

  1. #1

    Default Eric sip-scintilla problem

    Dear all,

    I am on Opensuse 11.3 and using the Release:45 repo to get KDE RC 4.5.

    Problem is, I cannot start eric (nor spyder, nor any other Pyqt-based python editors). On startup, eric tells me

    Code:
    RuntimeError: the sip module implements API v8.0 but the PyQt4.Qsci module requires API v7.1
    This boils down to a dependency conflict between python-qscintilla and python-sip - but it fast turns into dependency hell.

    In a nutshell: repo Release:45 has no python-qscintilla.rpm, and two python-sip (4.10 and 4.11) rpms. Installing 4.11 is fine but raises the above problem; trying to downgrade to 4.10 results in a broken python-kde4 and hence in broken kde 4.5.

    I tried several workarounds and third-party packages but with no luck.

    I guess the answer should be to contact the release:45 repo maintainer and ask them to upload a compatible version of python-qscintilla. Do they read the forum?

    Or is there any other workaround?

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Eric sip-scintilla problem

    paolocrosetto1 wrote:
    > Do they read the forum?


    most likey never!


    > Or is there any other workaround?


    sure, the preferred way is to enter a bug, see:
    http://en.opensuse.org/Submitting_Bug_Reports

    --
    DenverD
    When it comes to chocolate, resistance is futile.
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  3. #3

    Default Re: Eric sip-scintilla problem

    Well, there are two solutions:

    1) Downgrade the KDE installation from KDE:/Release:/45/openSUSE_11.3/ repo to vanilla openSUSE_11.3

    2) Add the KDE:/Qt/openSUSE_11.3/ (currently Qt 4.7) repo an upgrade all of the packages form the repo.

    In the later repo the qscintilla is compiled against proper API version of SIP.

    The resolution of the bug you submitted at https://bugzilla.novell.com/show_bug.cgi?id=644600 would be to include the qscintilla into the repo (which will automatically recompile against proper API version).

    bb4now,
    PMC

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •