Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: During the Online Update in Opesuse 11.3 some repositories links seem to be not active

  1. #1

    Default During the Online Update in Opesuse 11.3 some repositories links seem to be not active

    I do not know if some links are broken or not, but everytime I tried to update my system online I got the following error messages:

    1) File /repodata/repomd.xml.asc not found in medium
    Index of /distribution/11.3/repo/non-oss

    2) File /repodata/repomd.xml.key not found in medium
    Index of /distribution/11.3/repo/non-oss

    3) File /repodata/repomd.xml not found in medium
    Index of /distribution/11.3/repo/non-oss

    Is the address of this repository changed?

    Do I have to change anything in my system?

    Thank you in advance

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,645
    Blog Entries
    14

    Default Re: During the Online Update in Opesuse 11.3 some repositories links seem to be not active

    Using exactly those repos as well, no issues at all. I'd try again later.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: During the Online Update in Opesuse 11.3 some repositories links seem to be not active

    Sorry if I am insisting on this, bit I tried again and again.

    It cannot be the internet connection because in the same time other repositories can be updated without no problem. It is like the files are not being found in the place where they shold be.

    It is possible that their links have been changed ?

    Are they available from elsewhere ?

    Thanks

  4. #4

    Default Re: During the Online Update in Opesuse 11.3 some repositories links seem to be not active

    Hello...

    The repo URL is -> 'http://download.opensuse.org/distribution/11.3/repo/non-oss/' (without the quotation marks)

    Ralph

  5. #5
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: During the Online Update in Opesuse 11.3 some repositories links seem to be not active

    You could also try port 80

    "http://download.opensuse.org:80/distribution/11.3/repo/oss/]Index of /distribution/11.3/repo/oss"

  6. #6
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: During the Online Update in Opesuse 11.3 some repositories links seem to be not active

    Sorry, should be, for port 80,

    "http://download.opensuse.org:80/distribution/11.3/repo/non-oss/"

  7. #7
    Carlos E. R. NNTP User

    Default Re: During the Online Update in Opesuse 11.3 some repositories linksseem to be not active

    On 2010-10-06 14:06, FabrizioS wrote:
    >
    > I do not know if some links are broken or not, but everytime I tried to
    > update my system online I got the following error messages:
    >
    > 1) File /repodata/repomd.xml.asc not found in medium
    > 'Index of /distribution/11.3/repo/non-oss'
    > (http://download.opensuse.org/distrib...3/repo/non-oss)


    Just browse with a browser. I don't see that file there. I don't remember if that is one of the
    files that not seen with a browser, only the updater.

    The server is a server redirector, it sends you to a mirror near to you. You can choose a mirror
    manually.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  8. #8

    Default Re: During the Online Update in Opesuse 11.3 some repositories linksseem to be not active

    This is what I got yesterday night. This time I used the linecommand tool:

    Code:
    linux-hchb:/home/golem # zypper -vv ref
    
    Verbosity: 2
    Initialising Target
    Specified repositories: 
    Checking whether to refresh metadata for Updates for openSUSE 11.3 11.3-1.82
    Retrieving: http://download.opensuse.org/update/11.3/repodata/repomd.xml [done (0 B/s)]
    Repository 'Updates for openSUSE 11.3 11.3-1.82' is up to date.
    Skipping disabled repository 'openSUSE-11.3-Debug'
    Checking whether to refresh metadata for openSUSE-11.3-Non-Oss
    Retrieving: http://download.opensuse.org/distribution/11.3/repo/non-oss/repodata/repomd.xml.asc [error]
    Retrieving: http://download.opensuse.org/distribution/11.3/repo/non-oss/repodata/repomd.xml.key [error]
    Retrieving: http://download.opensuse.org/distribution/11.3/repo/non-oss/repodata/repomd.xml [error]
    File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/distribution/11.3/repo/non-oss/'
    
    Abort, retry, ignore? [a/r/i/?] (a): i
    Retrieving repository 'openSUSE-11.3-Non-Oss' metadata [error]
    Repository 'openSUSE-11.3-Non-Oss' is invalid.
    History:
     - SKIP request: User-requested skipping of a file
     - Can't provide /repodata/repomd.xml : User-requested skipping of a file
     - [|] Valid metadata not found at specified URL(s)
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'openSUSE-11.3-Non-Oss' because of the above error.
    Checking whether to refresh metadata for openSUSE-11.3-Oss
    Retrieving: http://download.opensuse.org/distribution/11.3/repo/oss/content [done (0 B/s)]
    Retrieving: http://download.opensuse.org/distribution/11.3/repo/oss/media.1/media [done]
    Repository 'openSUSE-11.3-Oss' is up to date.
    Skipping disabled repository 'openSUSE-11.3-Source'
    Some of the repositories have not been refreshed because of an error.
    The strange thing is that I found the three missing files:

    repomd.xml.asc
    repomd.xml.key
    repomd.xml

    In a different link: Index of /update/11.3/repodata
    But when I tried to edit manually this link YAST replied that it was not possible to initilize or create the repository.

    I tried everything from creating a new repository to editing the exisisting one, but to no avail. It seems that the default repositories are not editable.

    Am I doing something wrong or there is a bug here?

    Thanks

  9. #9

    Default Re: During the Online Update in Opesuse 11.3 some repositories linksseem to be not active

    Yep, I'm getting a similar thing and was getting it all weekend too. My problems are mostly with the updates from the kde45 repo but also had a few problems with the standard oS11.3 repos.

    I'm going to try assigning another mirror manually. Looks like there may have been a problem with how some of the mirrors have updated.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  10. #10
    Carlos E. R. NNTP User

    Default Re: During the Online Update in Opesuse 11.3 some repositories linksseem to be not active

    On 2010-10-12 10:36, FabrizioS wrote:
    >
    > This is what I got yesterday night. This time I used the linecommand
    > tool:
    >
    >
    > Code:
    > --------------------
    > linux-hchb:/home/golem # zypper -vv ref

    ....
    > Checking whether to refresh metadata for openSUSE-11.3-Non-Oss
    > Retrieving: http://download.opensuse.org/distrib...repomd.xml.asc [error]
    > Retrieving: http://download.opensuse.org/distrib...repomd.xml.key [error]
    > Retrieving: http://download.opensuse.org/distrib...ata/repomd.xml [error]
    > File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/distribution/11.3/repo/non-oss/'

    ....

    >
    > The strange thing is that I found the three missing files:
    >
    > repomd.xml.asc
    > repomd.xml.key
    > repomd.xml
    >
    > In a different link: 'Index of /update/11.3/repodata'
    > (http://download.opensuse.org/update/11.3/repodata)


    AH!!! You have defined the wrong type of repo. Run "zypper lr --details", I bet that "Non-Oss" is
    not of type "yast2" but "rpm-md". It has to be type yast2. I'm not sure if there is a command to
    change the type, see the help for zypper - or remove it, add it again.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •