Results 1 to 10 of 10

Thread: can't ssh into laptop -- password doesn't work

  1. #1

    Question can't ssh into laptop -- password doesn't work

    grr--I was about to post this but my browser crashed so I have to write it again--

    So, I jaibroke my iPod touch and have OpenSSH and I can ssh into my iPod, but I cannot ssh back into my Laptop??

    I did
    Code:
    $ echo '192.168.*.*' >> /etc/hosts.allow ##I googled and it said to do this
    $ echo 'sshd: 192.168.*.*' >> /etc/hosts.allow
    I also uncommented these lines in /etc/ssh/sshd_config:
    Code:
    Port 22
    AddressFamily any
    ListenAddress 0.0.0.0
    ListenAddress ::
    And I did
    Code:
     $ /etc/init.d/sshd restart
    after editing these files.
    Then I do this on my iPod:

    Code:
    matt@192.168.2.83's password: 
    Permission denied, please try again.
    matt@192.168.2.83's password: 
    Permission denied, please try again.
    matt@192.168.2.83's password: 
    Permission denied (publickey,password,keyboard-interactive).
    I am 100% sure I am putting in the right password. I even did that ^ code from my laptop, the one I am ssh'ing into, but it still will not accept my password. I even tried root@ instead of matt@.. still nothing! If you can help, I'd appreciate it! Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: can't ssh into laptop -- password doesn't work

    Get more debug info by running ssh on the iPod with the -v option.

  3. #3

    Default Re: can't ssh into laptop -- password doesn't work

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    And also get the /var/log/messages (from Linux) output when trying this.
    If it's failing for a good reason (wrong password for example) it will
    likely tell you as much in /var/log/messages.

    Good luck.






    On 10/26/2010 08:36 AM, ken yap wrote:
    >
    > Get more debug info by running ssh on the iPod with the -v option.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJMxuiRAAoJEF+XTK08PnB5DhMP/iA+OcIOTdOL7qL3Zasi/87m
    +H5EIyf1TAASuLWHZVlgHLEG4iEDYTZsP0OFlb93KnLOXcPldZ3NskcTrmNsbd7Q
    /2UyGbNY6xbzajZhURemO66G2XAivD7I++ZmZYc6RFx9qgFQLJIOekZ6hkeLPyit
    QUllMJtHQ3HB0WxhAk1uione95Hl89pRDv5gzFu9yL/cJEElCZNU0KyXVM03bte1
    CQ4hpaFdD3AgTRDo5fsX0oUB5YooZ5azh0gkcKm/vi79U3pyJWK+sEwbwZeL5fMB
    PzyAHhJ15KK51jLSE9f1/Lvmzv5prx4fyUwO7BZCE+Zvp53/wV4uv7LxLdsFA7vS
    hkMeiUjXiau18XrxorzimC3DsqoevjJF/iUN3mXHDFQJB3uf1eTJFyrOSpQFROA9
    1crjF/ES4tINQk4WZ5CeOwN3Q5w5RpSqUkygdjl1Q0HlO2/d5QOMcn7PuZLbDP6e
    V8e64lcnLOGPd6aR/txBV9i8/FhbYOw5W7WWzAE/9kmaEGtqEzs1540skeY3nwAg
    coBpBZQ1MhYrEBzDEM1nqYUGormoZBkIltZw7oYHD8p5LRzM5TLCykIkiAO3F7/w
    AUJAqhqwBNyom1QmuRnTarLaxxBOzPBLRcohGBkgokcK8KG46if3JmR1pKyPSUVJ
    q9gPZaxUGI6Q7+yx+PmN
    =4kAm
    -----END PGP SIGNATURE-----

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: can't ssh into laptop -- password doesn't work

    On 2010-10-26 16:06, mvmacd wrote:
    >
    > grr--I was about to post this but my browser crashed so I have to write
    > it again--
    >
    > So, I jaibroke my iPod touch and have OpenSSH and I can ssh into my
    > iPod, but I cannot ssh back into my Laptop??
    >
    > I did


    By default in an openSUSE install for get ssh-in working, you only need two things: a) open the
    firewall, b) start the daemon.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  5. #5

    Default Re: can't ssh into laptop -- password doesn't work

    Code:
    $ ssh -v root@192.168.2.83
    OpenSSH_5.4p1, OpenSSL 1.0.0 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 192.168.2.83 [192.168.2.83] port 22.
    debug1: Connection established.
    debug1: identity file /home/matt/.ssh/id_rsa type -1
    debug1: identity file /home/matt/.ssh/id_rsa-cert type -1
    debug1: identity file /home/matt/.ssh/id_dsa type -1
    debug1: identity file /home/matt/.ssh/id_dsa-cert type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.2
    debug1: match: OpenSSH_5.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.4
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '192.168.2.83' is known and matches the RSA host key.
    debug1: Found key in /home/matt/.ssh/known_hosts:5
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: Roaming not allowed by server
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: publickey
    debug1: Trying private key: /home/matt/.ssh/id_rsa
    debug1: Trying private key: /home/matt/.ssh/id_dsa
    debug1: Next authentication method: keyboard-interactive
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: password
    root@192.168.2.83's password: 
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    Permission denied, please try again.
    root@192.168.2.83's password: 
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    Permission denied, please try again.
    root@192.168.2.83's password: 
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: No more authentication methods to try.
    Permission denied (publickey,password,keyboard-interactive).
    Hmm come to think of it I didn't edit my firewall. could that be it?

    also, there's nothing in the /var/log/messages

    edit: I tried disabling my firewall, then tried it again. the same thing happened... so I don't think it is the firewall??
    @robin_listas, my daemon is running:
    Code:
    $ /etc/init.d/sshd status
    Checking for service sshd                                            running

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: can't ssh into laptop -- password doesn't work

    If you are getting through, the firewall port is open.

    Do you have an AllowUsers line in your sshd_config that only allows certain users?

    Also I think those lines with /etc/hosts.allow are not needed and may be counterproductive. Take them out.

    And you may learn something by ssh to itself from the server using the external address of the machine. Sure you got the right machine? Do you have more than one server?

  7. #7

    Default Re: can't ssh into laptop -- password doesn't work

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    No, if it were the firewall you wouldn't even get connected so that's
    definitely not it. Nothing in /var/log/messages is definitely strange.
    Are you sure you are checking properly? You cannot read that file unless
    you have permissions (you will not by default, unless you're evil and
    using root as your regular user). `sudo tail -f /var/log/messages` and
    while running that (again, on the server, not the client) attempt your
    login to the server and send the output.

    Good luck.





    On 10/26/2010 10:36 AM, mvmacd wrote:
    >
    > Code:
    > --------------------
    >
    > *$ ssh -v root@192.168.2.83*
    > OpenSSH_5.4p1, OpenSSL 1.0.0 29 Mar 2010
    > debug1: Reading configuration data /etc/ssh/ssh_config
    > debug1: Applying options for *
    > debug1: Connecting to 192.168.2.83 [192.168.2.83] port 22.
    > debug1: Connection established.
    > debug1: identity file /home/matt/.ssh/id_rsa type -1
    > debug1: identity file /home/matt/.ssh/id_rsa-cert type -1
    > debug1: identity file /home/matt/.ssh/id_dsa type -1
    > debug1: identity file /home/matt/.ssh/id_dsa-cert type -1
    > debug1: Remote protocol version 2.0, remote software version OpenSSH_5.2
    > debug1: match: OpenSSH_5.2 pat OpenSSH*
    > debug1: Enabling compatibility mode for protocol 2.0
    > debug1: Local version string SSH-2.0-OpenSSH_5.4
    > debug1: SSH2_MSG_KEXINIT sent
    > debug1: SSH2_MSG_KEXINIT received
    > debug1: kex: server->client aes128-ctr hmac-md5 none
    > debug1: kex: client->server aes128-ctr hmac-md5 none
    > debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    > debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    > debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    > debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    > debug1: Host '192.168.2.83' is known and matches the RSA host key.
    > debug1: Found key in /home/matt/.ssh/known_hosts:5
    > debug1: ssh_rsa_verify: signature correct
    > debug1: SSH2_MSG_NEWKEYS sent
    > debug1: expecting SSH2_MSG_NEWKEYS
    > debug1: SSH2_MSG_NEWKEYS received
    > debug1: Roaming not allowed by server
    > debug1: SSH2_MSG_SERVICE_REQUEST sent
    > debug1: SSH2_MSG_SERVICE_ACCEPT received
    > debug1: Authentications that can continue: publickey,password,keyboard-interactive
    > debug1: Next authentication method: publickey
    > debug1: Trying private key: /home/matt/.ssh/id_rsa
    > debug1: Trying private key: /home/matt/.ssh/id_dsa
    > debug1: Next authentication method: keyboard-interactive
    > debug1: Authentications that can continue: publickey,password,keyboard-interactive
    > debug1: Next authentication method: password
    > root@192.168.2.83's password:
    > debug1: Authentications that can continue: publickey,password,keyboard-interactive
    > Permission denied, please try again.
    > root@192.168.2.83's password:
    > debug1: Authentications that can continue: publickey,password,keyboard-interactive
    > Permission denied, please try again.
    > root@192.168.2.83's password:
    > debug1: Authentications that can continue: publickey,password,keyboard-interactive
    > debug1: No more authentication methods to try.
    > Permission denied (publickey,password,keyboard-interactive).
    >
    > --------------------
    >
    >
    > Hmm come to think of it I didn't edit my firewall. could that be it?
    >
    > also, there's nothing in the /var/log/messages
    >
    > edit: I tried *disabling* my firewall, then tried it again. the same
    > thing happened... so I don't think it is the firewall??
    > @robin_listas, my daemon is running:
    >
    > Code:
    > --------------------
    >
    > $ /etc/init.d/sshd status
    > Checking for service sshd *running*
    >
    > --------------------
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJMxxCHAAoJEF+XTK08PnB5ESsP/1yOUf+MNWKkxRWeagRW6Lx1
    02GZhmo4Ah9erEojHPp/HsD20PmLukD1RaMXGXRbd5h96GuHgim6YenjKpWBY2/z
    MS5r1r+89PJ0E2F1QHDqpjj4Rr9RQxFGt2gnb7rqgerYsFd6URnbE0T84asGfbWZ
    ql4uFXRB8GVKIJNfU4qQdT5Cy36NM+RzlXDPhFZ1R+kfekImUcYAMpZ4sBASlDkp
    W+7z6zGdaMKGxiX/Re1lKs1+zcR2HARYk0KIQI0HmuRPOogHWcmgmITgAZJrU5MB
    U6WFyE/La9GIrEHdbUUM7HWVMOaseYKTJzNKyFyhV/5Go0ZtrQWrbF7JVr1Ua+eX
    otmSpdDQplXyyPDBjqTuuheT3L+ODIjeBzVaIfptR85tY2XsMY9lLW/YR1YSEsRh
    6nR0Gi2UA3F16/XMaK9532uBCLnY/6K9EknW0IipbYDZCoiKXU+HKyp+R6bBgXCu
    1Vq/tig0q3D0ivNN2Ar5pXckz2R0qXHhD81hOWVnu+bgzG81gS2Fj+Tn0J1DmhM3
    Z/24Ty6TDuH7QEhc3CrmbCraGav27U/TmB0xz7c0oWxlXIK81FdTKfW5HzENoTox
    ixrNEo70PG6+ZtJYoX+nVE3O0Vk12D9KmVmHbEH1cbTml2hOXGLP54R5qbba9+n2
    fOAAKfONvgEEGvJLrGmR
    =/PJb
    -----END PGP SIGNATURE-----

  8. #8

    Default Re: can't ssh into laptop -- password doesn't work

    Hmm.. woah. I am not sure when, but my local IP address changed. It was 192.168.2.83, but then I checked just now [with ifconfig] and it changed to 192.168.2.82...... I tried it again with the right addr, and it worked! I didn't bother re-checking my local addr since it did not say "No route to host" like it should if it was an invalid address.... oh my word, no wonder... It happens that the 192.168.2.83 is my brother's [jailbroken] iPod, so I was trying to log into his with my password!! oops

    how do I mark this as solved?

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,846
    Blog Entries
    14

    Default Re: can't ssh into laptop -- password doesn't work

    Quote Originally Posted by mvmacd View Post
    how do I mark this as solved?

    You can't. Search the forums and you will find some threads in which it's explained/discussed.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: can't ssh into laptop -- password doesn't work

    On 2010-10-26 20:06, mvmacd wrote:
    >
    > Hmm.. woah. I am not sure when, but my local IP address changed. It was
    > 192.168.2.83, but then I checked just now [with ifconfig] and it changed
    > to 192.168.2.82...... I tried it again with the right addr, *and it
    > worked!*


    X'-)

    Perhaps you are using dhcp, ie, automatic address.

    > how do I mark this as solved?


    Yes X'-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •