Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: During the Online Update in Opesuse 11.3 some repositories links seem to be not active

  1. #11

    Default Re: During the Online Update in Opesuse 11.3 some repositories linksseem to be not active

    I report below the result

    linux-hchb:/home/golem # zypper lr -d
    Code:
    # | Alias                               | Name                                | Enabled | Refresh | Priority | Type   | URI                                                             | Service
    --+-------------------------------------+-------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.3/                       |        
    2 | openSUSE-11.3 11.3-1.82             | openSUSE-11.3 11.3-1.82             | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/sr0                                         |        
    3 | repo-debug                          | openSUSE-11.3-Debug                 | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.3/repo/oss/  |        
    4 | repo-non-oss                        | openSUSE-11.3-Non-Oss               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/11.3/repo/non-oss/    |        
    5 | repo-oss                            | openSUSE-11.3-Oss                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/        |        
    6 | repo-source                         | openSUSE-11.3-Source                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.3/repo/oss/ |
    So the non-oss repository is a "rpm-md" one, but I do not understand what difference does it make. The problem is that the three files are not present in the repository (they cannot be downloaded).

    Furthermore when I read all the zypper manual I did no see any possibility to change the repository type

    Regards

  2. #12
    Carlos E. R. NNTP User

    Default Re: During the Online Update in Opesuse 11.3 some repositories linksseem to be not active

    On 2010-10-14 11:36, FabrizioS wrote:
    >
    > I report below the result
    >
    > linux-hchb:/home/golem # zypper lr -d
    >
    > Code:
    > --------------------
    > # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    > --+-------------------------------------+-------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    > 1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/11.3/ |
    > 2 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    > 3 | repo-debug | openSUSE-11.3-Debug | Yes | Yes | 99 | yast2 | http://download.opensuse.org/debug/d...11.3/repo/oss/ |
    > 4 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/distrib.../repo/non-oss/ |
    > 5 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...11.3/repo/oss/ |
    > 6 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/...11.3/repo/oss/ |
    > --------------------
    >
    >
    > So the non-oss repository is a "rpm-md" one, but I do not understand
    > what difference does it make. The problem is that the three files are
    > not present in the repository (they cannot be downloaded).


    The problem is that you defined, somehow, the wrong type. If you have "rpm-md" it will search for
    those files, that do not exist because the repo is type yast2, and that is not under your control.
    The repo isn't yours to decide how it works :-)


    > Furthermore when I read all the zypper manual I did no see any
    > possibility to change the repository type


    Remove, add.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #13

    Default Re: During the Online Update in Opesuse 11.3 some repositories linksseem to be not active

    Wow it worked!!!!!!!!!!!!!!!!

    Now from the terminal I got the following:

    Code:
    linux-hchb:/home/golem # zypper -vv ref
    Verbosity: 2
    Initialising Target
    Specified repositories: 
    Checking whether to refresh metadata for Opensuse-11.3-Non-Oss                                                                                                                                             
    Retrieving: http://download.opensuse.org/distribution/11.3/repo/non-oss/content [done (0 B/s)]
    Retrieving: http://download.opensuse.org/distribution/11.3/repo/non-oss/media.1/media [done]
    Repository 'Opensuse-11.3-Non-Oss' is up to date.                                                                                                                                                          
    Checking whether to refresh metadata for Updates for openSUSE 11.3 11.3-1.82                                                                                                                               
    Retrieving: http://download.opensuse.org/update/11.3/repodata/repomd.xml [done (4.3 KiB/s)]
    Retrieving: http://download.opensuse.org/update/11.3/repodata/repomd.xml [done (0 B/s)]
    Retrieving: http://download.opensuse.org/update/11.3/repodata/repomd.xml.asc [done]
    Retrieving: http://download.opensuse.org/update/11.3/repodata/repomd.xml.key [done (0 B/s)]
    Retrieving: http://download.opensuse.org/update/11.3/repodata/repomd.xml [done (0 B/s)]
    Retrieving: http://download.opensuse.org/update/11.3/repodata/531620b1a72d94583696a5ef890239fdb8026c92-susedata.xml.gz [done (2.9 KiB/s)]
    Retrieving: http://download.opensuse.org/update/11.3/repodata/2e5e920cfffbe9e5abeb30d7ae766f056af03ba2-updateinfo.xml.gz [done (14.9 KiB/s)]
    Retrieving: http://download.opensuse.org/update/11.3/repodata/f6f35606093eb22c45d8ec1f5a490f8d405c6596-primary.xml.gz [done (60.6 KiB/s)]
    Retrieving: http://download.opensuse.org/update/11.3/repodata/a210cc6fe7fc2245c05dc6249709848f98c24589-deltainfo.xml.gz [done (65.1 KiB/s)]
    Retrieving repository 'Updates for openSUSE 11.3 11.3-1.82' metadata [done]
    Building repository 'Updates for openSUSE 11.3 11.3-1.82' cache [done]
    Checking whether to refresh metadata for openSUSE-11.3-Debug                                                                                                                                               
    Retrieving: http://download.opensuse.org/debug/distribution/11.3/repo/oss/content [done]
    Retrieving: http://download.opensuse.org/debug/distribution/11.3/repo/oss/media.1/media [done]
    Repository 'openSUSE-11.3-Debug' is up to date.                                                                                                                                                            
    Checking whether to refresh metadata for openSUSE-11.3-Oss                                                                                                                                                 
    Retrieving: http://download.opensuse.org/distribution/11.3/repo/oss/content [done (0 B/s)]
    Retrieving: http://download.opensuse.org/distribution/11.3/repo/oss/media.1/media [done]
    Repository 'openSUSE-11.3-Oss' is up to date.
    Skipping disabled repository 'openSUSE-11.3-Source'
    All repositories have been refreshed.
    I did as you said:

    1) I deleted the non oss repository
    2) I added again and this time was a "Yast2" type

    Notwithstanding I would like to know which different there is between a "Yast2" and "rpm-md" one and why they act so differently.

    Thank you for your help

  4. #14
    Carlos E. R. NNTP User

    Default Re: During the Online Update in Opesuse 11.3 some repositories linksseem to be not active

    On 2010-10-15 12:36, FabrizioS wrote:
    >
    > Wow it worked!!!!!!!!!!!!!!!!


    ....

    > I did as you said:
    >
    > 1) I deleted the non oss repository
    > 2) I added again and this time was a "Yast2" type


    Good :-)


    > Notwithstanding I would like to know which different there is between a
    > "Yast2" and "rpm-md" one and why they act so differently.


    Have a look at the documentation for the package "createrepo", it should say or tell where to seek
    more info on that.

    Some pointers:

    <http://en.opensuse.org/openSUSE:Maintenance/Code11/Howto>
    <http://old-en.opensuse.org/Standards/RPM_metadata>
    <http://old-en.opensuse.org/Standards/YaST2_repository_metadata>
    <http://old-en.opensuse.org/Software_Repositories>

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  5. #15

    Default Re: During the Online Update in Opesuse 11.3 some repositories links seem to be not active

    I am having similar issues with official 11.3 repositories. I been working on it for few days. They seem to work one day and not the other. Not a network problem. All connectivity checks out. Here is what i get:

    zypper lr -d

    1 | debug | debug | Yes | Yes | 99 | yast2 | Index of /debug/distribution/11.3/repo/oss |
    2 | download.videolan.org-SuSE | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.3/ |
    3 | ftp.uni-erlangen.de-suse | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/mirrors/packman/suse/11.3/ |
    4 | non-oss | non-oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    5 | non-oss_from_opensuse | non-oss_from_opensuse | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    6 | oss | oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    7 | oss_from_opensuse | oss_from_opensuse | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    8 | source | source | No | Yes | 99 | yast2 | Index of /source/distribution/11.3/repo/oss |
    9 | update | update | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
    10 | update_OPENSUSE | update_OPENSUSE | Yes | Yes | 99 | rpm-md | Index of /update/11.3

    As you can see i tried many.

    So here is an error:

    zypper -vv refresh
    Verbosity: 2
    Initializing Target
    Specified repositories:
    Checking whether to refresh metadata for debug
    Retrieving: http://download.opensuse.org/debug/d...po/oss/content [error (0 B/s)]
    Failed to download /content from Index of /debug/distribution/11.3/repo/oss
    Abort, retry, ignore? [a/r/i/?] (a): i
    Error retrieving metadata for 'debug':
    History:
    - Failed to download /content from Index of /debug/distribution/11.3/repo/oss
    - [AbstractCommand.cc:224] URI=http://download.opensuse.org/debug/distribution/11.3/repo/oss/content
    - SKIP request: User-requested skipping of a file
    Skipping repository 'debug' because of the above error.
    Checking whether to refresh metadata for VideoLan Repository
    Retrieving: http://download.videolan.org/pub/vid...ata/repomd.xml [error (0 B/s)]
    Failed to download /repodata/repomd.xml from Index of /pub/videolan/vlc/SuSE/11.3/
    Abort, retry, ignore? [a/r/i/?] (a): i
    Error retrieving metadata for 'VideoLan Repository':
    History:
    - Failed to download /repodata/repomd.xml from Index of /pub/videolan/vlc/SuSE/11.3/
    - [AbstractCommand.cc:224] URI=http://download.videolan.org/pub/videolan/vlc/SuSE/11.3/repodata/repomd.xml
    - SKIP request: User-requested skipping of a file
    Skipping repository 'VideoLan Repository' because of the above error.
    Checking whether to refresh metadata for Packman Repository
    Retrieving: http://ftp.uni-erlangen.de/pub/mirro...ata/repomd.xml [error]
    Failed to download /repodata/repomd.xml from Index of /pub/mirrors/packman/suse/11.3/
    Abort, retry, ignore? [a/r/i/?] (a): i
    Error retrieving metadata for 'Packman Repository':
    History:
    - Failed to download /repodata/repomd.xml from Index of /pub/mirrors/packman/suse/11.3/
    - [AbstractCommand.cc:224] URI=http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/11.3/repodata/repomd.xml
    - SKIP request: User-requested skipping of a file
    Skipping repository 'Packman Repository' because of the above error.
    Checking whether to refresh metadata for non-oss
    Retrieving: http://130.57.19.201/distribution/11...on-oss/content [error]
    Failed to download /content from Index of /distribution/11.3/repo/non-oss
    Abort, retry, ignore? [a/r/i/?] (a): i
    Error retrieving metadata for 'non-oss':
    History:
    - Failed to download /content from Index of /distribution/11.3/repo/non-oss
    - [AbstractCommand.cc:224] URI=http://130.57.19.201/distribution/11.3/repo/non-oss/content
    - SKIP request: User-requested skipping of a file
    Skipping repository 'non-oss' because of the above error.
    Checking whether to refresh metadata for non-oss_from_opensuse
    Retrieving: http://download.opensuse.org/distrib...on-oss/content [error]
    Failed to download /content from Index of /distribution/11.3/repo/non-oss
    Abort, retry, ignore? [a/r/i/?] (a):



    and so on for all of them. Agian it was working yesterday. I was also able to do zypper up ! did it last week. was working fine then with default directories. I discovered an issue when i ran zypper up again and discovered errors. If this is an issue with 11.3 ill go back to 11.2. Hopefully 11.2 is fine. But ill check.

  6. #16
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: During the Online Update in Opesuse 11.3 some repositories linksseem to be not active

    On 2010-10-26 18:06, yelenafeldman wrote:
    >
    > I am having similar issues with official 11.3 repositories. I been
    > working on it for few days. They seem to work one day and not the other.
    > Not a network problem. All connectivity checks out. Here is what i get:
    >
    > zypper lr -d


    > 1 | debug | debug | Yes | Yes| 99 | yast2 | 'Index of /debug/distribution/11.3/repo/oss'(http://download.opensuse.org/debug/d...11.3/repo/oss/) |


    Why do you have the debug repo active? Leave it at no, no, unless you really need it.

    > 2 | download.videolan.org-SuSE | VideoLan Repository | Yes | Yes| 99 | rpm-md | 'Index of /pub/videolan/vlc/SuSE/11.3/'(http://download.videolan.org/pub/vid...vlc/SuSE/11.3/) |


    Give it a priority of 115.

    >
    > 3 | ftp.uni-erlangen.de-suse | Packman Repository | Yes | Yes| 99 | rpm-md | 'Index of /pub/mirrors/packman/suse/11.3/'(http://ftp.uni-erlangen.de/pub/mirro...man/suse/11.3/) |


    110.

    >
    > 4 | non-oss | non-oss | Yes | Yes| 99 | yast2 | 'Index of /distribution/11.3/repo/non-oss'(http://130.57.19.201/distribution/11.3/repo/non-oss/) |


    Remove.

    >
    > 5 | non-oss_from_opensuse | non-oss_from_opensuse | Yes | Yes| 99 | yast2 | 'Index of /distribution/11.3/repo/non-oss'(http://download.opensuse.org/distrib.../repo/non-oss/) |
    >
    > 6 | oss | oss | Yes | Yes| 99 | yast2 | 'Index of /distribution/11.3/repo/oss'(http://130.57.19.201/distribution/11.3/repo/oss/) |


    Remove.

    > 7 | oss_from_opensuse | oss_from_opensuse | Yes | Yes| 99 | yast2 | 'Index of /distribution/11.3/repo/oss'(http://download.opensuse.org/distrib...11.3/repo/oss/) |
    >
    > 8 | source | source | No | Yes| 99 | yast2 | 'Index of /source/distribution/11.3/repo/oss'(http://download.opensuse.org/source/...11.3/repo/oss/) |
    >
    > 9 | update | update | Yes | Yes| 99 | rpm-md | 'Index of /update/11.3'(http://130.57.19.201/update/11.3/) |


    Remove.

    > 10 | update_OPENSUSE | update_OPENSUSE | Yes | Yes| 99 | rpm-md | 'Index of /update/11.3'(http://download.opensuse.org/update/11.3/)
    >



    > As you can see i tried many.


    Indeed.
    Duplicating repos is an error.


    > So here is an error:
    >
    > zypper -vv refresh
    > Verbosity: 2
    > Initializing Target
    > Specified repositories:
    > Checking whether to refresh metadata for debug
    > Retrieving:
    > http://download.opensuse.org/debug/d...po/oss/content
    > [error (0 B/s)]
    > Failed to download /content from 'Index of
    > /debug/distribution/11.3/repo/oss'
    > (http://download.opensuse.org/debug/d...11.3/repo/oss/)
    > Abort, retry, ignore? [a/r/i/?] (a): i


    You have to try on a browser at the same time. The repo is in fact a redirector to a mirror near
    you, and it could happen that the choosen mirror is bad. I'm not sure if the real mirror choosen is
    listed in the logs.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •