Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Digikam 1.4 can't start on openSUSE

  1. #1
    Join Date
    Jan 2009
    Location
    China
    Posts
    40

    Exclamation Digikam 1.4 can't start on openSUSE

    I installed Digikam 1.4 version from Index of /repositories/KDE:/UpdatedApps/openSUSE_11.3 repository. When start it, I got below errors:
    Code:
    digikam: symbol lookup error: /usr/lib64/libdigikamcore.so.1: undefined symbol: _ZN11KDcrawIface19RawDecodingSettingsaSERKS0_
    I tried to reinstall digikam and marble, but the problem also exist.

    Then, I uninstalled 1.4 version, and installed 1.2 version from Index of /distribution/11.3/repo/oss
    It's ok. So, I think the build version 1.4 have some problem.
    Yesterday is past, tomorrow I do not know, today is a gift.
    System:openSUSE 11.3 KDE4.6.0 x86_64 AMD Turion(tm) X2 Ultra Dual-Core Mobile ZM-80 DDR2 2G NVIDIA 9100MG HD Realtek ALC888 250G SATA

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Digikam 1.4 can't start on openSUSE

    Are you saying 1.2 works for you?

    rpm -qi digikam
    Name : digikam Relocations: (not relocatable)
    Version : 1.4.0 Vendor: obs://build.opensuse.org/KDE
    Release : 34.1 Build Date: Tue 05 Oct 2010 09:00:30 BST
    Is mine and it works fine
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jan 2009
    Location
    China
    Posts
    40

    Default Re: Digikam 1.4 can't start on openSUSE

    Yes, 1.2 works for me!
    But, 1.4 can't!

    Which repository did you get the digikam?
    Yesterday is past, tomorrow I do not know, today is a gift.
    System:openSUSE 11.3 KDE4.6.0 x86_64 AMD Turion(tm) X2 Ultra Dual-Core Mobile ZM-80 DDR2 2G NVIDIA 9100MG HD Realtek ALC888 250G SATA

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Digikam 1.4 can't start on openSUSE

    Index of /repositories/KDE:/Release:/45/openSUSE_11.3

    I also have it working in 11.4 which is from Factory for the development release.

    I suggest you do this on your supplying kde repo
    http://dl.dropbox.com/u/10573557/Swi...itch%20kde.png
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Digikam 1.4 can't start on openSUSE

    Come to think of it
    Perhaps you better let me see your repos

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jan 2009
    Location
    China
    Posts
    40

    Default Re: Digikam 1.4 can't start on openSUSE

    I will try to install it from the repository you said above.
    I have lots of repositories.
    Yesterday is past, tomorrow I do not know, today is a gift.
    System:openSUSE 11.3 KDE4.6.0 x86_64 AMD Turion(tm) X2 Ultra Dual-Core Mobile ZM-80 DDR2 2G NVIDIA 9100MG HD Realtek ALC888 250G SATA

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Digikam 1.4 can't start on openSUSE

    I have lots of repositories.
    Here is your problem, especially when you have no idea how to manage them.

    Just installing randomly, willy nilly from here there and everywhere is very poor practice.

    Like I said, your repo list... And I can advise accordingly.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Jan 2009
    Location
    China
    Posts
    40

    Default Re: Digikam 1.4 can't start on openSUSE

    Hi, caf4926,

    Thanks you very much!
    I added the /repositories/KDE:/Release:/45/openSUSE_11.3 repository, and I click the "Switch system package ..." on that repository.
    Now, system is upgrading to kde 4.5.2.
    After upgraded, I will see if the problem exist!
    Yesterday is past, tomorrow I do not know, today is a gift.
    System:openSUSE 11.3 KDE4.6.0 x86_64 AMD Turion(tm) X2 Ultra Dual-Core Mobile ZM-80 DDR2 2G NVIDIA 9100MG HD Realtek ALC888 250G SATA

  9. #9
    Join Date
    Jan 2009
    Location
    China
    Posts
    40

    Default Re: Digikam 1.4 can't start on openSUSE

    Hi, caf4926,

    After upgraded to KDE 4.5.2, the digikam 1.4 version works well now.
    Thank you very much!
    Yesterday is past, tomorrow I do not know, today is a gift.
    System:openSUSE 11.3 KDE4.6.0 x86_64 AMD Turion(tm) X2 Ultra Dual-Core Mobile ZM-80 DDR2 2G NVIDIA 9100MG HD Realtek ALC888 250G SATA

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,972
    Blog Entries
    14

    Default Re: Digikam 1.4 can't start on openSUSE

    Still, follow Caf's advice and post output of 'zypper lr -d', we might be able to give some suggestions to avoid future trouble. "Lots of repos" is not good.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •