Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: YaST2 Failing to install RPMs

  1. #1

    Default YaST2 Failing to install RPMs

    Hi,

    I've been trying for awhile to install the restricted formats, but when in the download & and install process, YaST2 pops up saying that such and such RPM has failed. I hit ignore, and it happens again and again to all the other packages, bar the odd few that work.

    I'm on KDE 11.3.

    Thanks.

  2. #2

    Default Re: YaST2 Failing to install RPMs

    And yes I've tried One Click install, and through amarok.

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YaST2 Failing to install RPMs

    matACCADACCA wrote:
    > And yes I've tried One Click install, and through amarok.


    show us the output of the following commands in a terminal by
    copy/paste them back to this thread, thanks:

    Code:
    zypper lr -d
    --
    DenverD
    When it comes to chocolate, resistance is futile.
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  4. #4

    Default Re: YaST2 Failing to install RPMs

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-------------------------------------------------------------------+-------------------------------------------------------------------+---------+---------+----------+--------+-------------------------------------------------------------------+--------
    1 | Libdvdcss repository | Libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/11.3/ |
    2 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/mirrors/packman/suse/11.3/ |
    3 | Index of /distribution/11.3/repo/oss/suse | Index of /distribution/11.3/repo/oss/suse | Yes | Yes | 99 | rpm-md | Index of /distribution/11.3/repo/oss/suse |
    4 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://www.opensuse-guide.org/repo/11.3 |
    5 | openSUSE-11.3-Non-Oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    6 | openSUSE-11.3-Oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    7 | packman | packman | Yes | Yes | 99 | rpm-md | Index of /suse/11.3/ |
    8 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
    9 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    10 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    11 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
    12 | repo-update | openSUSE-11.3-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.3

    Sorry, that's as neat as I could get it, and thanks for the reply.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,973

    Default Re: YaST2 Failing to install RPMs

    About the "as neat as I could get it": surround computer text with CODE tags. You can do this by hand of course, but easier is going to Advanced (lower right) and then choose the # button from the toolbar.

    And about your respos: it seems that you have a few of those repos twice or even thrice in the list. Please clean up.
    Henk van Velden

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YaST2 Failing to install RPMs

    @matACC... you wrote that your problem is that during install of the
    restricted codecs "ST2 pops up saying that such and such RPM has
    failed." so, after you follow hcvv's advice to remove all the
    duplicate repos..(and, get down to FOUR: leave just oss, non-oss,
    update and packman)...try your codecs install again...and, if it fails
    on some rpms, TELL us what they are...and, does it give a reason for
    the failure??

    which way are you trying to install them? as far as i know the best
    way is in the sticky at the top of the multimedia forum..

    as for four repos, read the info here which begins with IMPORTANT:
    http://forums.opensuse.org/english/i...ml#post2058902

    i recommend that every time you use a one click install, after the
    install is finished, go into YaST and *disable* any repos added by the
    one click operation and get back to just those four.....if you want a
    stable system...

    --
    DenverD
    When it comes to chocolate, resistance is futile.
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  7. #7

    Default Re: YaST2 Failing to install RPMs

    First up is Flash, and the error message for that is:

    Code:
    Subprocess failed. Error: RPM failed: error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) setting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) setting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) setting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    And so on (Sorry, I maxed out my whole char limit with the full message)
    Then it changes to:

    Code:
    error: error(-30987) getting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    If that helps.

  8. #8
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YaST2 Failing to install RPMs

    matACCADACCA wrote:
    > First up is Flash, and the error message for that is:


    follow the repair RPM database directions in this excellent post:
    http://forums.opensuse.org/english/g...ml#post2029216

    my _guess_ is the db was corrupted by something preventing YaST (or
    zypper, or the rpm command) from completing a process....that could be
    a power failure, or a user who gets tired of waiting for the process
    to finish, or thinks the process is 'frozen' or otherwise taking too
    long, and kill it..

    YaST/zypper/rpm do LOTs of stuff, some take more time than others,
    some go to several different servers on the web to check things...

    so, be patient..

    repair your db and i guess _this_ problem will be history..

    --
    DenverD
    When it comes to chocolate, resistance is futile.
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,973

    Default Re: YaST2 Failing to install RPMs

    You failed to report that you have cleaned up your repos and to show what they are after the cleanup. At least I will not start looking at error messages as long as you do not have a decent repository list.
    Henk van Velden

  10. #10

    Default Re: YaST2 Failing to install RPMs

    Sorry, yes I cleaned my room mum. I should have mentioned that before.
    But, trying to install Java from terminal brings up the same error message!


    Thanks for your time.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •