Results 1 to 8 of 8

Thread: Suse 11.2 wifi - only pulling 2 mbps - all others pull 23mbps

  1. #1
    Join Date
    Apr 2010
    Location
    Michigan USA
    Posts
    102

    Default Suse 11.2 wifi - only pulling 2 mbps - all others pull 23mbps

    I am wondering why I used to pull a much faster download and upload (approx 20 down 3 up). Now I only get 2 down and barely 1 up). I am not sure why this happened.

    Any ways to check on this?? Just this one, dell d505 running suse 11.2.

    All other wifi computers are pulling bandwidth as expected.

  2. #2
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Suse 11.2 wifi - only pulling 2 mbps - all others pull 23mbps

    I am not sure why this happened.
    I am not sure how we could know why this happened. People trying to help are not looking over your shoulder. We need some hard facts, like relevant output of dmesg (please restrict to relevant lines and format as #code), result of /sbin/lspci, /sbin/ifconfig and /sbin/route -n
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  3. #3
    Join Date
    Apr 2010
    Location
    Michigan USA
    Posts
    102

    Default Re: Suse 11.2 wifi - only pulling 2 mbps - all others pull 23mbps

    I apologize for the late reply and appreciate your assistance. Below is the information requested.


    /sbin/lspci
    00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
    00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
    00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
    00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
    00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
    00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
    00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
    00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
    00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 01)
    00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 01)
    00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
    00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
    01:01.0 CardBus bridge: Texas Instruments PCI4510 PC card Cardbus Controller (rev 02)
    01:01.1 FireWire (IEEE 1394): Texas Instruments PCI4510 IEEE-1394 Controller
    01:03.0 Network controller: Broadcom Corporation BCM4309 802.11a/b/g (rev 02)
    01:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (MOB) Ethernet Controller (rev 81)

    /sbin/ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0D:56:E0:48:B4
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:14 errors:0 dropped:0 overruns:0 frame:0
    TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:820 (820.0 b) TX bytes:820 (820.0 b)

    wlan0 Link encap:Ethernet HWaddr 00:90:4B:74:33:07
    inet addr:192.168.1.109 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::290:4bff:fe74:3307/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:94536 errors:0 dropped:0 overruns:0 frame:0
    TX packets:111149 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:59489653 (56.7 Mb) TX bytes:21961796 (20.9 Mb)

    wmaster0 Link encap:UNSPEC HWaddr 00-90-4B-74-33-07-37-34-00-00-00-00-00-00-00-00
    UP RUNNING MTU:0 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    /sbin/route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0

  4. #4
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Suse 11.2 wifi - only pulling 2 mbps - all others pull 23mbps

    Check this thread: Solved: WLAN on Dell Mini 10 (Inspiron 1012)

    You have:

    Code:
    01:03.0 Network controller: Broadcom Corporation BCM4309 802.11a/b/g (rev 02)
    Try to install the broadcom-wl package from the packman repository. Pick the right broadcom-wl-kmp-xxx for your kernel, where xxx = default | desktop | pae. Please note that your chip is a BCM4309 but the drivers are said to work for the 43xx series of chips, listing BCM4311-, BCM4312-, BCM4321-, BCM4322- based hardware.

    So it might work, but there's no guarantee here. Can someone having a 4309 confirm, please?
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,235
    Blog Entries
    14

    Default Re: Suse 11.2 wifi - only pulling 2 mbps - all others pull 23mbps

    Quote Originally Posted by vodoo View Post
    Check this thread: Solved: WLAN on Dell Mini 10 (Inspiron 1012)

    You have:

    Code:
    01:03.0 Network controller: Broadcom Corporation BCM4309 802.11a/b/g (rev 02)
    Try to install the broadcom-wl package from the packman repository. Pick the right broadcom-wl-kmp-xxx for your kernel, where xxx = default | desktop | pae. Please note that your chip is a BCM4309 but the drivers are said to work for the 43xx series of chips, listing BCM4311-, BCM4312-, BCM4321-, BCM4322- based hardware.

    So it might work, but there's no guarantee here. Can someone having a 4309 confirm, please?

    Spot on, should work. You need broadcom-wl and the broadcom-wl-kmp packages. Reboot and all should be OK.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Apr 2010
    Location
    Michigan USA
    Posts
    102

    Default Re: Suse 11.2 wifi - only pulling 2 mbps - all others pull 23mbps

    ok, well. now I have 3 different options at the boot screen, and no wifi at all now. Any ideas?
    Laptop: openSUSE 13.1 | Gnome 3.2.1 | i3 350m 2.27 GHz | HP Pavilion dv6 | 4GB RAM | Intel HD Integrated Graphics

    Installed openSUSE, never going back!

  7. #7
    Join Date
    Apr 2010
    Location
    Michigan USA
    Posts
    102

    Default Re: Suse 11.2 wifi - only pulling 2 mbps - all others pull 23mbps

    Ok, it only killed my wifi installing -wl and default. Then of course since it did killed it, I installed the others too. default, desktop, xen and pae and now have a crazy looking boot screen with all their options and failsafe options.

    However, I did go into Yast and removed all -wl installed, I have my wifi back at the same slow download screen and still have a crazy looking boot screen.

    Any other ideas on why it would be so slow. at least I have something though. Also, how do I fix that boot screen? or should I just leave it alone?
    Laptop: openSUSE 13.1 | Gnome 3.2.1 | i3 350m 2.27 GHz | HP Pavilion dv6 | 4GB RAM | Intel HD Integrated Graphics

    Installed openSUSE, never going back!

  8. #8
    Join Date
    Apr 2010
    Location
    Michigan USA
    Posts
    102

    Default Re: Suse 11.2 wifi - only pulling 2 mbps - all others pull 23mbps

    Ok, upgraded to 11.3 Same issue with wifi download speeds. 11.3 seems to run pretty good! If anyone has any tip or tricks to see why my download speeds suck on wifi, let me know. thx. Nervous on the -wl broadcom, not sure I want to try that again.
    Laptop: openSUSE 13.1 | Gnome 3.2.1 | i3 350m 2.27 GHz | HP Pavilion dv6 | 4GB RAM | Intel HD Integrated Graphics

    Installed openSUSE, never going back!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •