Results 1 to 6 of 6

Thread: Plötzlich Verbinden in umtsmon dauerhaft mit Fehler endend

  1. #1

    Default Plötzlich Verbinden in umtsmon dauerhaft mit Fehler endend

    Hallo !


    Ein neu eingerichtetes SUSE 11.3 kommt nicht mehr ins Mobile Internet (O2):

    Was ist geschehen:

    Download Opensuse 11.3
    Boot-DVD brennen
    Kernel:Linux 2.6.34-12-desktop x86_64
    ...
    DistributionpenSUSE 11.3 (x86_64)
    KDE:4.4.4 (KDE 4.4.4) "release 2"
    Download umtsmon (11.3,64Bit, 0.9.72.20090509-1.1)
    Installieren umtsmon
    Rechte dialout und uucp vergeben
    sudo chmod +s /usr/sbin/pppd
    sudo chmod +s /usr/sbin/usb_modeswitch
    umtsmon-Profil anlegen


    Internet nun funktionstüchtig

    YAST Software installieren:
    weitere angebotene Softwarepakete wurden installiert
    dabei kam es zu mehreren Abbrüchen ( anschließend Restart SUSE ... )

    nach mehreren erfolgreichen Restarts ( OPENSUSE+UMTSMON+Software installieren )
    endet umtsmon beim Verbinden immer mit ERROR:
    "Verbindung schlug fehl ...."

    letzter Downloadversuch bei Download flash-player

    Fehlermeldungen:


    ppstdout

    Using interface ppp0
    Connect: ppp0 <--> /dev/ttyUSB1
    Terminating on signal 15
    Connection terminated.
    Receive serial link is not 8-bit clean:
    Problem: all had bit 7 set to 0
    Modem hangup

    netstat -apneeA inet

    Aktive Internetverbindungen (Server und stehende Verbindungen)
    Proto Recv-Q Send-Q Local Address Foreign Address State Benutzer Inode PID/Program name
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 0 6785 1976/rpcbind
    tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 0 7333 2140/cupsd
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 0 8123 2403/master
    udp 0 0 0.0.0.0:111 0.0.0.0:* 0 6778 1976/rpcbind
    udp 0 0 0.0.0.0:631 0.0.0.0:* 0 7336 2140/cupsd
    udp 0 0 0.0.0.0:875 0.0.0.0:* 0 6784 1976/rpcbind
    udp 0 0 0.0.0.0:5353 0.0.0.0:* 106 7338 2160/avahi-daemon:
    udp 0 0 0.0.0.0:47196 0.0.0.0:* 106 7339 2160/avahi-daemon:


    Ein anschließender Restart von Windows 7 / Mobiles Internet führte stets zu folgender Fehlermeldung:
    Fehler 618: Der angegebene Port wurde nicht geöffnet.

    Es lag aber kein Hardwarefehler vor. Denn nach einer Ausschaltpause funktionierte das Internet unter Windows 7 oder Opensuse 11.2.

    Wie grenzt man den Fehler weiter ein ( Fehlerprotokolle ?) ?
    Wie kann ich in Opensuse 11.3 das Internet erneut funktionstüchtig machen?

    Vielen Dank für jeden Rat.

    Mit freundlichen Grüßen

    Basti1

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Plötzlich Verbinden in umtsmon dauerhaft mit Fehler endend

    * Basti1,

    bist Du sicher, dass Du UMTSMON brauchst? Ich bin bei der 11.3 mit dem KNetworkmanager sehr zufrieden; er zeigt meine UMTS-Karte an und bedient sie klaglos.

    Gruß
    Uwe


  3. #3

  4. #4

    Default Re: Plötzlich Verbinden in umtsmon dauerhaft mit Fehler endend

    Quote Originally Posted by buckesfeld View Post
    bist Du sicher, dass Du UMTSMON brauchst? Ich bin bei der 11.3 mit dem KNetworkmanager sehr zufrieden; er zeigt meine UMTS-Karte an und bedient sie klaglos.
    Prinzipiell richtig, mehr zur allgemeinen Erheiterung ein Sch**** aus meiner Erfahrung, der witzigerweise mit dem Problem des TE zu tun haben könnte.

    Als ich das exakt selbe Problem hatte (und JA, in meinem "dahingeklatschten" Google-Link findet sich die Lösung in zigfacher Ausführung, genau mit dieser Suche habe ich damals die Infos gefunden um das exakt selbe Problem gelöst zu bekommen), war der Auslöser, daß umtsmon und KnetworkManager (bzw. dessen Unterbau, also NWM und Komponenten) liefen und sich in die Quere kamen, weil beide versuchen auf dem Modem "herumzuschreiben" und dann gibts Durcheinander.

    Also _zusätzlich_ zur Lösung des Problems, die man in meinem Google-Link finden kann, gilt die Maxime "umtsmon und NWM kommen sich gerne mal in die Quere", man entscheide sich für eines der beiden Tools und deaktiviere das andere, zumindest, wenn man umtsmon verwenden will sollte man NWM abschalten (oder man richtet das Ganze gleich mit ifup ein, so wie ich das mittlerweile mache, ist aber eher was für Bastler, besonders, wenn man die PIN-Abfrage _nicht_ deaktivieren will).

  5. #5

    Thumbs up Re: Plötzlich Verbinden in umtsmon dauerhaft mit Fehler endend

    Hallo,

    ich habe nun auch den Internetzugang mit Knetworkmanager eingerichtet und mich von UMTSMON verabschiedet. Bisher bin ich zufrieden mit der Installation. Vielen Dank für den hilfreichen Rat.


    Gruß

    Basti1

  6. #6
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Default Re: Plötzlich Verbinden in umtsmon dauerhaft mit Fehler endend

    Und für den der kein Englisch kann (Google ist toll aber nur wenn man Englisch spricht): Übersetzt von link:
    Recieve serial link is not 8-bit clean
    Usint rp-3 I went into 'advanced' and unchecked the box which says "let PPP perform authentication"
    Apparently, this turned off the signals being sent by ppp and not recognized.
    "Usint rp-3. Ich bin in die "fortgeschrittenen Einstellungen" gegangen und habe dort den Hacken aus der Box "let PPP perform autentication / lasse PPP die Verifizierung durchführen" entfernt. Scheinbar schaltet dies die Signale aus die von PPP gesendet und von der Funkbrücke nicht erkannt werden".

    Aber da du ja eine Lösung mit Networkmanager gefunden hast war das nur der Vollständigkeit halber, falls noch jemand sucht.
    Grüße.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •