Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: CUPS problem

  1. #1
    JosephKK NNTP User

    Default CUPS problem


    I am trying to make my printer visible to my other machines on my
    local (home) net. Suse 11.1 Kde 3.5 CUPS 1.2.12 ETC., What files
    of configuration information do i need to provire to get help with
    this?

    --
    Say what ?:-(

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: CUPS problem

    You can browse to
    Code:
    http://localhost:631
    on your machine with the printer connected. Click on administration then click on 'Share printers connected to this system'. And if I remember correctly you also have to go into the printer settings under Manage Printers and allow sharing through there as well
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3
    Join Date
    Jul 2008
    Location
    ukraine/mk/pervomaysk
    Posts
    528

    Default Re: CUPS problem

    in adition you should setup remote clients with yast to use remote CUPS as it own


    and ports for cups should be openned on both in firewall (if any)
    intelGMA3100#amd|radeonHD4200+radeonHD5450@catalyst12.4
    WC5020B,PagePro1480MF,LBP2900,hpCP1510,PHOTO1290,Scanmaker3600,PerfectionV200

  4. #4
    josephkk NNTP User

    Default Re: CUPS problem

    On Mon, 04 Oct 2010 01:36:02 GMT, ah7013
    <ah7013@no-mx.forums.opensuse.org> wrote:

    >
    >You can browse to
    >
    >Code:
    >--------------------
    >
    > http://localhost:631
    >
    >--------------------
    >
    >on your machine with the printer connected. Click on administration
    >then click on 'Share printers connected to this system'. And if I
    >remember correctly you also have to go into the printer settings under
    >Manage Printers and allow sharing through there as well


    Yes, it is bookmarked. On the other machine i can see it advertising
    using wireshark.

  5. #5
    josephkk NNTP User

    Default Re: CUPS problem

    On Mon, 04 Oct 2010 11:06:07 GMT, didencool
    <didencool@no-mx.forums.opensuse.org> wrote:

    >
    >in adition you should setup remote clients with yast to use remote CUPS
    >as it own
    >[image:
    >http://lh3.ggpht.com/_EGHByq6hIgo/TK...work-YaST.png]
    >
    >and ports for cups should be openned on both in firewall (if any)


    Though the example is 11.3 i saw the relevant settings for my 11.1.
    Even though i can ping the machine it said the server did not exist.
    I then tried looking for any server on the local net, and Yast reported it
    as brother ql500 (one currently attached via usb) with a different model
    printer driver than the printer model (Epson R1800 instead of R200). Very
    weird. Cups on the print serving machine does not show any print job
    arriving today (neither local or remote).

    Since this is on a home net, firewalls should be automatically updated by
    Yast. The router is a different matter, the computers will see the 8-port
    switch first.

  6. #6
    Carlos E. R. NNTP User

    Default Re: CUPS problem

    On 2010-10-07 03:25, josephkk wrote:
    > On Mon, 04 Oct 2010 11:06:07 GMT, didencool <> wrote:


    > Since this is on a home net, firewalls should be automatically updated by
    > Yast.


    No, they are not. Specially if you configured the local network as external, as I do.
    We had a discussion with the maintainer about this.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7

    Default Re: CUPS problem

    Quote Originally Posted by josephkk View Post
    Though the example is 11.3 i saw the relevant settings for my 11.1.
    Even though i can ping the machine it said the server did not exist.
    I then tried looking for any server on the local net, and Yast reported it
    as brother ql500 (one currently attached via usb) with a different model
    printer driver than the printer model (Epson R1800 instead of R200). Very
    weird. Cups on the print serving machine does not show any print job
    arriving today (neither local or remote).
    To list available printers, you can try:
    lpstat -p
    To show the default printer:
    lpstat -d

    Also make sure that the cups daemon is running.

  8. #8
    josephkk NNTP User

    Default Re: CUPS problem

    On Thu, 07 Oct 2010 04:18:51 GMT, "Carlos E. R." <robin.listas@localhost>
    wrote:

    >On 2010-10-07 03:25, josephkk wrote:
    >> On Mon, 04 Oct 2010 11:06:07 GMT, didencool <> wrote:

    >
    >> Since this is on a home net, firewalls should be automatically updatedby
    >> Yast.

    >
    >No, they are not. Specially if you configured the local network as external, as I do.
    >We had a discussion with the maintainer about this.


    Must have missed that conversation. I have configured my firewall on my
    machines and they behave much more as expected now. Still can't print to
    the other local box. Since i have a good hardware router i chose to go
    with my interfaces in the demilitarized zone.

    What configuration information from my suse 11.1 systems do you want for
    troubleshooting?

  9. #9
    Carlos E. R. NNTP User

    Default Re: CUPS problem

    On 2010-10-09 12:24, josephkk wrote:
    > On Thu, 07 Oct 2010 04:18:51 GMT, "Carlos E. R." <robin.listas@localhost>
    > wrote:
    >
    >> On 2010-10-07 03:25, josephkk wrote:
    >>> On Mon, 04 Oct 2010 11:06:07 GMT, didencool <> wrote:

    >>
    >>> Since this is on a home net, firewalls should be automatically updated by
    >>> Yast.

    >>
    >> No, they are not. Specially if you configured the local network as external, as I do.
    >> We had a discussion with the maintainer about this.

    >
    > Must have missed that conversation.


    <http://lists.opensuse.org/opensuse/2010-07/msg01456.html>

    > I have configured my firewall on my
    > machines and they behave much more as expected now. Still can't print to
    > the other local box. Since i have a good hardware router i chose to go
    > with my interfaces in the demilitarized zone.
    >
    > What configuration information from my suse 11.1 systems do you want for
    > troubleshooting?


    Well, the trick is to look at the suse firewall log at the moment you try a print operation, and see
    what is rejected.

    You normally need to open port "ipp" (631) on both machines.

    FW_SERVICES_*_TCP="ipp".

    And perhaps udp too (not sure).

    Time ago, when you configured printing in yast you could say to open the firewall for you. This
    feature was removed (11.3?)


    A safer option, is to restrict which IPs can use printing services:

    FW_TRUSTED_NETS="172.16.168.129,tcp,ipp 172.16.168.129,udp,ipp"


    Some more info:

    <http://lists.opensuse.org/opensuse/2009-07/msg00068.html>

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10
    josephkk NNTP User

    Default Re: CUPS problem

    On Sun, 10 Oct 2010 01:43:15 GMT, "Carlos E. R." <robin.listas@localhost>
    wrote:

    >On 2010-10-09 12:24, josephkk wrote:
    >> On Thu, 07 Oct 2010 04:18:51 GMT, "Carlos E. R." <robin.listas@localhost>
    >> wrote:
    >>
    >>> On 2010-10-07 03:25, josephkk wrote:
    >>>> On Mon, 04 Oct 2010 11:06:07 GMT, didencool <> wrote:
    >>>
    >>>> Since this is on a home net, firewalls should be automatically updated by
    >>>> Yast.
    >>>
    >>> No, they are not. Specially if you configured the local network as external, as I do.
    >>> We had a discussion with the maintainer about this.

    >>
    >> Must have missed that conversation.

    >
    ><http://lists.opensuse.org/opensuse/2010-07/msg01456.html>
    >
    >> I have configured my firewall on my
    >> machines and they behave much more as expected now. Still can't printto
    >> the other local box. Since i have a good hardware router i chose to go
    >> with my interfaces in the demilitarized zone.
    >>
    >> What configuration information from my suse 11.1 systems do you want for
    >> troubleshooting?

    >
    >Well, the trick is to look at the suse firewall log at the moment you try a print operation, and see
    >what is rejected.
    >
    >You normally need to open port "ipp" (631) on both machines.
    >
    >FW_SERVICES_*_TCP="ipp".
    >
    >And perhaps udp too (not sure).
    >
    >Time ago, when you configured printing in yast you could say to open thefirewall for you. This
    >feature was removed (11.3?)
    >
    >
    >A safer option, is to restrict which IPs can use printing services:
    >
    >FW_TRUSTED_NETS="172.16.168.129,tcp,ipp 172.16.168.129,udp,ipp"
    >
    >
    >Some more info:
    >
    ><http://lists.opensuse.org/opensuse/2009-07/msg00068.html>


    Made plenty big openings in the firewall on both machines. Explicitly
    opened port 631 to all DMZ, and added cups to allowed services for (all of
    my) interfaces attached to DMZ . No help, no change.

    Ok, where are the configuration files on 11.1? Yast refuses to do
    anything useful with the cups configuration. The Yast firewall settings
    are rather coarse and crude as well.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •