Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Code::Blocks not starting

  1. #1
    Join Date
    Oct 2010
    Location
    India
    Posts
    21

    Unhappy Code::Blocks not starting

    I have installed this rpm on my system.
    codeblocks-10.05-0-suse112.i686.rpm

    But the problem is codeblocks is not starting after it shows the splash screen.
    Any pointer on how to resolve this issue?

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Code::Blocks not starting

    What happens when you try to run it from the terminal?
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Code::Blocks not starting

    sree ec wrote:
    > I have installed this rpm on my system.
    > codeblocks-10.05-0-suse112.i686.rpm


    is there a reason you do not install Code::Blocks using YaST..

    its all packaged up for you in the dev/tools repo

    search here: http://software.opensuse.org/search

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]
    When it comes to chocolate, resistance is futile.

  4. #4
    Join Date
    Oct 2010
    Location
    India
    Posts
    21

    Default Re: Code::Blocks not starting

    These are the error messages I get when running the command in 2 modes.
    While I do sudo codeblocks, I dont even get a splash screen

    Code:
    > sudo codeblocks
    root's password:
    Error: Unable to initialize gtk, is DISPLAY set properly?
    
    > codeblocks 
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:46: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:47: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:48: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:46: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:47: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:48: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
    codeblocks: relocation error: /usr/lib/libcodeblocks.so.0: symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference

  5. #5
    Join Date
    Oct 2010
    Location
    India
    Posts
    21

    Default Re: Code::Blocks not starting

    mean while these are the 2 rpms i have installed,
    Code:
    codeblocks-10.05-0.i686
    codeblocks-contrib-10.05-0.i686

  6. #6
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Code::Blocks not starting

    what openSUSE version are you using and what is the output of

    Code:
    zypper info wxGTK
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  7. #7
    Join Date
    Oct 2010
    Location
    India
    Posts
    21

    Default Re: Code::Blocks not starting

    Quote Originally Posted by ah7013 View Post
    what openSUSE version are you using and what is the output of

    Code:
    zypper info wxGTK
    This is the output
    Code:
    sreejith@linux-yer7:~/work/softwares/codeblock/suse> zypper info wxGTK
    Loading repository data...
    Reading installed packages...
    
    
    Information for package wxGTK:
    
    Repository: @System
    Name: wxGTK
    Version: 2.8.10.1-11.2
    Arch: i586
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 12.8 MiB
    Summary: C++ Framework for Cross-Platform Development
    Description: 
    wxWidgets is a free C++ framework to make cross-platform programming
    easy. It supports Windows 3.1/95/98/NT, and Unix with
    GTK/Motif/Lesstif. This is the version for GTK+. This package only
    contains the runtime libraries and other data needed by the runtime
    libraries.
    
    Additional documentation is available in the package wxGTK-doc and you
    can find some examples in the package wxGTK-examples.
    OpenSuse version is 11.3

  8. #8
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Code::Blocks not starting

    Use codeblocks from software.opensuse.org. Remove the codeblocks you have installed with
    Code:
    zypper remove codeblocks codeblocks-contrib
    And use this one click install:
    http://software.opensuse.org/ymp/dev...ery=codeblocks

    You might ask yourself why and that is because the codeblocks you have installed is built for openSUSE 11.2 and this one click install codeblocks if for 11.3
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  9. #9
    Join Date
    Oct 2010
    Location
    India
    Posts
    21

    Default Re: Code::Blocks not starting

    Quote Originally Posted by ah7013 View Post
    Use codeblocks from software.opensuse.org. Remove the codeblocks you have installed with
    Code:
    zypper remove codeblocks codeblocks-contrib
    And use this one click install:
    http://software.opensuse.org/ymp/dev...ery=codeblocks

    You might ask yourself why and that is because the codeblocks you have installed is built for openSUSE 11.2 and this one click install codeblocks if for 11.3
    Well.. Thanks.. Now it works like a charm!!!
    Can I ask you one more thing, Is this 'suse112' in the rpm name made you understand that it was built for 11.2?[Just to understand and not to come back again with a similar problem]

  10. #10
    Join Date
    Oct 2010
    Location
    India
    Posts
    21

    Default Re: Code::Blocks not starting

    Quote Originally Posted by DenverD View Post
    sree ec wrote:
    > I have installed this rpm on my system.
    > codeblocks-10.05-0-suse112.i686.rpm


    is there a reason you do not install Code::Blocks using YaST..

    its all packaged up for you in the dev/tools repo

    search here: software.opensuse.org: Search Results

    --
    DenverD
    CAVEAT: C A V E A T [posted via NNTP w/openSUSE 10.3]
    When it comes to chocolate, resistance is futile.
    I am just exploring my new OpenSuse Installation and I just did not know this option.
    Thanks for reminding

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •