Results 1 to 7 of 7

Thread: clean re-install amarok?

  1. #1
    Join Date
    Sep 2008
    Location
    Helsinki
    Posts
    88

    Default clean re-install amarok?

    Hei!

    I have experienced amarok crash after which i am not able to bring
    it back to working state. I tried to reinstall it multiple times from standart
    playground and kde KDE:UpdatedApps repositories. Every time
    i start amarok it hangs on splash screen consuming 49% of CPU
    with no signs to load completely.
    I guess i need to clean reinstall with deleting all tracing info form
    previous install?
    here's output from console:

    Code:
    InnoDB: The log sequence number in ibdata files does not match
    InnoDB: the log sequence number in the ib_logfiles!
    101003 11:21:54  InnoDB: Database was not shut down normally!
    InnoDB: Starting crash recovery.
    InnoDB: Reading tablespace information from the .ibd files...
    InnoDB: Restoring possible half-written data pages from the doublewrite
    InnoDB: buffer...
    Calling appendChild() on a null node does nothing.
    Object::connect: No such signal Podcasts::SqlPodcastProvider::playlistAdded( Playlists::PlaylistPtr )
    Object::connect: No such signal Podcasts::SqlPodcastProvider::playlistRemoved( Playlists::PlaylistPtr )
    Object::connect: No such signal Playlists::SqlUserPlaylistProvider::playlistAdded( Playlists::PlaylistPtr )
    Object::connect: No such signal Playlists::SqlUserPlaylistProvider::playlistRemoved( Playlists::PlaylistPtr )
    Object::disconnect: Unexpected null parameter
    You can't help respecting anybody who can spell TUESDAY, even if he doesn't spell it right; but spelling isn't everything. There are days when spelling Tuesday simply doesn't count. Winnie the Pooh

  2. #2
    Join Date
    Jul 2008
    Location
    ukraine/mk/pervomaysk
    Posts
    528

    Default Re: clean re-install amarok?

    not sure but
    101003 11:21:54 InnoDB: Database was not shut down normally!
    you have a problem with DB
    you can remove your amarok config file
    intelGMA3100#amd|radeonHD4200+radeonHD5450@catalyst12.4
    WC5020B,PagePro1480MF,LBP2900,hpCP1510,PHOTO1290,Scanmaker3600,PerfectionV200

  3. #3
    Join Date
    Sep 2008
    Location
    Helsinki
    Posts
    88

    Default Re: clean re-install amarok?

    Thanks for quick reply,

    I susspected that i have to delete some old database files or smth.
    Where is amarok config file ?

    I use opensuse 11.3, KDE 4.5.1
    You can't help respecting anybody who can spell TUESDAY, even if he doesn't spell it right; but spelling isn't everything. There are days when spelling Tuesday simply doesn't count. Winnie the Pooh

  4. #4
    Join Date
    Jul 2008
    Location
    ukraine/mk/pervomaysk
    Posts
    528

    Default Re: clean re-install amarok?

    ~/.kde/share/apps/amarok

    PS:you can normally use

    locate amarok

    to find wher it is located

    PSS:
    one more edit locate amarok does not help for that
    />cd ~
    ~>find . -name "amarok" -print0

    I have an answer
    ./.kde4/share/apps/amarok./.kde4/share/apps/amarok/mysqle/amarok
    intelGMA3100#amd|radeonHD4200+radeonHD5450@catalyst12.4
    WC5020B,PagePro1480MF,LBP2900,hpCP1510,PHOTO1290,Scanmaker3600,PerfectionV200

  5. #5
    Join Date
    Sep 2008
    Location
    Helsinki
    Posts
    88

    Default Re: clean re-install amarok?

    I must apologize for the question, but how amaroks' config file is called?
    here's list of files in parent directory of amarok:
    amarok.notifyrc
    errmsg.sys
    You can't help respecting anybody who can spell TUESDAY, even if he doesn't spell it right; but spelling isn't everything. There are days when spelling Tuesday simply doesn't count. Winnie the Pooh

  6. #6
    Join Date
    Jul 2008
    Location
    ukraine/mk/pervomaysk
    Posts
    528

    Default Re: clean re-install amarok?

    I have no such knowlage. But I'll made in such situation so

    mv ~/.kde4/share/apps/amarok ~/.kde4/share/apps/amarok.bak
    intelGMA3100#amd|radeonHD4200+radeonHD5450@catalyst12.4
    WC5020B,PagePro1480MF,LBP2900,hpCP1510,PHOTO1290,Scanmaker3600,PerfectionV200

  7. #7
    Join Date
    Sep 2008
    Location
    Helsinki
    Posts
    88

    Default Re: clean re-install amarok?

    Hi,
    I got it working! Thanks!

    I missread your first repost and searched files in /usr/share/kde4, not in ~/.kde4
    I deleted all amarok files from ~/.kde4 and amarok runs nicely again!!!

    Thanks and sorry for misleading disturbace

    A
    You can't help respecting anybody who can spell TUESDAY, even if he doesn't spell it right; but spelling isn't everything. There are days when spelling Tuesday simply doesn't count. Winnie the Pooh

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •