Results 1 to 7 of 7

Thread: firefox icon not matching theme icons

  1. #1

    Default firefox icon not matching theme icons

    Hey folks,

    Wondering if anyone can tell me how to change this icon to match the theme. Seems to be to only application so far that has not picked up the correct icon. The quick launch icon is correct, but not the task manager icon. It seems to be picking it up from some other location before using the one in the theme file.

    Under root/usr/lib/firefox there are some default icons. Also under root/usr/share/pixmaps there are a couple icons for firefox. All these match the one pictured. The icon under root/usr/share/apps is the correct one for the theme. These are the only locations that I am aware of with exception of the theme file.

    Would renaming the icons under lib/firefox and share/pixmaps force it to use the themed icon?

    It seems that this firefox icon is a problem with any icon theme that I use.
    Thanks for your time.


  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: firefox icon not matching theme icons

    If you go to the menu editor and then to firefox and then click the ff icon there, do you see your alternative in the system list it brings up?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: firefox icon not matching theme icons

    The icon there in the menu editor is correctly themed. I just noticed that the icon in the left side titlebar is the wrong icon. Shows same as the task manager. I seem to remember something about firefow being a gnome app and not a kde app. Is this correct? Could that have something to do with it? Just guessing here.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: firefox icon not matching theme icons

    FFox is basically GTK
    I have settings in the System Settings > Application Appearance > GTK Styles and Fonts
    In the Use Styles > GTK Styles - try selecting Clearlooks or Oxygen Molecule

    But I'm not sure this will change the icon, but it will give a better appearance of the browser
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: firefox icon not matching theme icons

    Quote Originally Posted by southernyankee View Post
    Would renaming the icons under lib/firefox and share/pixmaps force it to use the themed icon?
    no.

    It seems that this firefox icon is a problem with any icon theme that I use.
    Thanks for your time.
    Each application (under KDE, Gnome and other FreeDesktop compliants WMs) has a file with the extension '.desktop'. The command to start the program and the icon which represents it - among other things - are written in that file. The default location for these files - at system level - is /usr/share/applications. However it can be changed by setting the variable XDG_DATA_DIRS. If you want to change the default application icon, you could copy its desktop file to /usr/local/share/applications (so it won't be overwritten by updates), set the XDG_DATA_DIRS accordingly and edit the file - in case of Firefox - MozillaFirefox.desktop.

    Code:
     cat /usr/share/applications/MozillaFirefox.desktop 
    [Desktop Entry]
    X-SuSE-translate=true
    Categories=Network;WebBrowser;X-Ximian-Main;X-Ximian-Toplevel;GTK;
    Encoding=UTF-8
    Name=Firefox
    GenericName=Web Browser
    Comment=Web Browser
    TryExec=firefox
    Exec=firefox %u
    Icon=firefox
    Terminal=false
    StartupNotify=true
    MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;application/x-xpinstall;
    Type=Application
    I'm not sure that KDE uses that file to start Firefox... but it should appear in menu under 'NetWork' or 'WebBrowser' if you happen to have such categories. (except that category names and menu names don't have to match ... but that would be beyond the scope ...)

    Of course ... There must be an easier way to just change icons at user level under KDE. But at least, it gives you an idea where FreeDesktop (the standard used by KDE) is looking for icons.

  6. #6

    Default Re: firefox icon not matching theme icons

    Yes, Firefox is based on GTK - like Gnome - but it doesn't mean that Firefox is a Gnome application. The problem is in the way KDE handles GTK. Normally, GTK applications take their theme and icon settings from the file ~/.gtkrc-2.0. Kde writes the file ~/.gtkrc-2.0-kde4 and reads the settings from there. Explicitely setting pixmap_path and gtk-icon-theme-name in that file might produce some results.

    Code:
    pixmap_path "/usr/local/share/themes/niglo-common/gtk-2.0"
    gtk-icon-theme-name     = "Human"
    It's just an example, as you don't have those pixmaps.

  7. #7

    Default Re: firefox icon not matching theme icons

    Thanks for all the help. Had to do some reading on the XDG_DATA_DIRS variable as I didn't quite know what you were talking about. I copied the desktop file over to usr/local/share/applications, but still had the same icon effect. I very well could have done it wrong, but I could not get it to change the icon.

    I went ahead and renamed the default icons in the usr/lib/firefox just for the heck of it and know the icon in the task manager changes with the theme. I tried different themes and it works with each theme. I don't know what effect it will have when it gets updated. Hopefully I didn't jack things up to bad.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •