Results 1 to 8 of 8

Thread: Lokale Einstellungen

  1. #1

    Default Lokale Einstellungen

    Meine lokalen Einstellungen sind "deutsch - Schweiz". Nun finde ich in OpenOffice aber so seltsame Dinge wie Dezimaltrennzeichen "Komma" (statt "Punkt"), Listentrenner "Semikolon" (statt "Komma"), usw., und finde keine Möglichkeit, das umzustellen ohne gleich die ganze Sprache mit umzustellen.

    Es gibt da aber auch einen Hinweis auf "System-Einstellungen verwenden"...

    Nur: Gibt es tatsächlich in Opensuse 11.3 irgendwo eine Möglichkeit, solche Dinge systemweit auszuwählen und anzupassen? Hab so weit keine gefunden, aber unter Linux gibt es doch für alles auch irgendwo noch Settings-Dateien usw.; könnte doch immerhin sein!??

  2. #2
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Default Re: Lokale Einstellungen

    Am 03/10/10 01:06, schrieb cbockem:
    >
    > Meine lokalen Einstellungen sind "deutsch - Schweiz". Nun finde ich in
    > OpenOffice aber so seltsame Dinge wie Dezimaltrennzeichen "Komma" (statt
    > "Punkt"), Listentrenner "Semikolon" (statt "Komma"), usw., und finde
    > keine Möglichkeit, das umzustellen ohne gleich die ganze Sprache mit
    > umzustellen.
    >
    > Es gibt da aber auch einen Hinweis auf "System-Einstellungen
    > verwenden"...
    >
    > Nur: Gibt es tatsächlich in Opensuse 11.3 irgendwo eine Möglichkeit,
    > solche Dinge systemweit auszuwählen und anzupassen? Hab so weit keine
    > gefunden, aber unter Linux gibt es doch für alles auch irgendwo noch
    > Settings-Dateien usw.; könnte doch immerhin sein!??
    >
    >

    Habe leider bislang nur openSUSE 11.2 und so schnell habe ich die
    Systemeinstellungen nicht gefunden
    (so weit ich mich an ein früheres Problem mit en-US und dem Wunsch nach
    Wochenbeginn am Montag erinnern kann, dürfte das auch nicht ganz trivial
    sein).

    Aber zu OpenOffice.org:
    Versuch es mal unter
    OpenOffice(z. B.
    Writer)>Extras>Optionen>Spracheinstellungen>Sprachen>Gebietsschema>Deutsch_(Schweiz)

    Zumindest der Dezimalpunkt müsste dann da sein (siehe Zeile darunter).
    Probier bitte mal aus, ob und was dann noch hakt - und melde Dich bitte
    noch einmal.

    Ich werde ggf. erst wieder am Montag vorbeischauen, aber hier gibt es
    sicherlich viele andere Helferchen/Gesprächspartner.

    Viel Erfolg!
    pistazienfresser

    --
    - per NNTP (Thunderbird)
    - openSUSE 11.2 with GNOME 2.28.2 (or KDE 4.3.5) and Kernel Linux
    2.6.31.14-0.1-desktop (or ~pae ~default, Ubuntu 10.4 LTS 'lucid'
    2.6.33-24-genetic, MS Win XP) on Samsung X20 Pentium M 740 (1730 MHz)
    Intel 915GM 1400x1050
    - openSUSE profile: https://users.opensuse.org/show/pistazienfresser

  3. #3
    Join Date
    Sep 2008
    Location
    /heimat/deutschland/daimler-city
    Posts
    239

    Default Re: Lokale Einstellungen

    cbockem wrote:

    >
    > Es gibt da aber auch einen Hinweis auf "System-Einstellungen
    > verwenden"...
    >
    > Nur: Gibt es tatsächlich in Opensuse 11.3 irgendwo eine Möglichkeit,
    > solche Dinge systemweit auszuwählen und anzupassen? Hab so weit keine
    > gefunden, aber unter Linux gibt es doch für alles auch irgendwo noch
    > Settings-Dateien usw.; könnte doch immerhin sein!??
    >
    >


    Hallo,

    wenn es System weit wirken soll, kann das über YaST erledigt werden, schau
    dazu einfach dort:

    http://de.opensuse.org/YaST_old_style

    bzw dort:

    http://de.opensuse.org/YaST_old_style/System

    und für Schriften, Sprache etc dort:

    http://de.opensuse.org/YaST_old_styl...Sprache_wählen

    --
    Die "SuS(i)E" sei mit euch, wo immer ihr seid ..... ;-)

  4. #4

    Default Re: Lokale Einstellungen

    Danke für die Tipps, aber mir scheint dass das noch nicht reicht!

    Die Sprache bekomme ich ja leicht umgestellt, auch den "Dialekt" (d.h. de_CH), samt unserer Tastatur und Zeitzone.

    Das Problem sind eigentlich nur die folgenden Dinge die dann in Openoffice auftauchen:

    • Zahlen mit Komma statt Punkt als Dezimaltrennzeichen
    • Semikolon statt Komma als Listentrennzeichen
    • Formeln auf deutsch statt "normal" (z.B. "WENN(...)" statt "IF(...)" usw.)


    Da ich in Openoffice selber bisher nicht viel gefunden habe (ausser auch wiederum Umstellung der Sprache, ohne die anderen damit offenbar verknüpften Features) dachte ich dass es auch in der Linux-Welt wie bei den Windosen sein könnte: Dass solche Sachen nämlich Sache des Systems sind und nicht der einzelnen Anwendungen!

    In den Systemeinstellungen via Yast bin ich allerdings bisher nicht fündig geworden, wobei bei Linux die meiste "Magie" ja "hinter den Kulissen", in allen möglichen Setting-Dateien, spielt!

  5. #5
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Lokale Einstellungen

    Es gibt zwar globale Einstellungen bezüglich der Sprache und Tastatur, en detail sieht die Sache aber etwas komplexer aus, denn diese Einstellungen können von mehreren Seiten aus überschrieben werden - insbesondere die verwendete Desktop-Umgebung setzt da meist eigene Standards. Das wiederum ist aber u.U. wirkungslos, wenn eine bestimmte Anwendung anderen Umgebungsvariablen unterliegt (Beispiel: gtk+-Anwendungen unter KDE). Oft funktioniert das trotzdem, manchmal aber eben auch nicht. Insofern wäre es für eine Annäherung an das Problem schon mal wichtig zu wissen, welche Umgebung Du nutzt bzw. wie Du dort die Sprach- und Tastatureinstellungen gesetzt hast.

  6. #6
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Question Re: Lokale Einstellungen

    Quote Originally Posted by pistazienfresser View Post
    Aber zu OpenOffice.org:
    Versuch es mal unter
    OpenOffice(z. B.
    Writer)>Extras>Optionen>Spracheinstellungen>Sprachen>Gebietsschema>Deutsch_(Schweiz)

    Zumindest der Dezimalpunkt müsste dann da sein (siehe Zeile darunter).
    Probier bitte mal aus, ob und was dann noch hakt - und melde Dich bitte
    noch einmal.
    Eine kleine Zwischenfrage zur Klarstellung: Das oben Genannte
    (1) funktioniert nicht (wird unter 11.3 ignoriert o.ä.)
    (2) reicht nicht (betrifft nur das Dezimalzeichen, nicht ....)
    (3) ?,

    LG
    pistazienfresser

  7. #7

    Default Re: Lokale Einstellungen

    Also Sprache und Tastatur sind deutsch/Schweiz. Als GUI verwende ich Gnome, und das Ganze ist OpenSuse 11.3.

    Inzwischen habe ich auch bei Openoffice nochmals auf deutsch zurück geschalten, weil auch das Englische wieder sehr viele "eigenartige" Eigenschaften hat die ich eigentlich auch nicht mag, z.B. Datumsformate als Monat/Tag/Jahr usw.

    Komischerweise werden jetzt Zahlen mit Dezimalpunkt anstatt Komma anstandslos verdaut - schon mal gut so!

    Am meisten stört mich allerdings die Tatsache, dass man Formeln auf deutsch statt auf englisch schreiben muss. Als Programmierer wüsste ich die meisten Namen "intuitiv" solange sie englisch sind; auf deutsch muss ich immer nachschlagen. Und selbstverständlich ist auch jede deutsche Formel bei mir erst mal "falsch", weil ich die Parameter mit Kommas abtrenne; erwartet werden auf deutsch aber Semikolons!

    Ich vermute ja mal, dass dies letztlich kaum noch eine Opensuse-Frage ist, sondern nur noch innerhalb von Openoffice gelöst werden kann! Dort bin ich inzwischen auch schon auf Foren gestossen wo andere das gleiche oder ähnliche Probleme hatten. Allerdings scheint so weit keiner eine Lösung gefunden zu haben: Vielleicht existiert die schlicht und einfach nicht??

  8. #8

    Lightbulb Lösung selber gefunden! (Re: Lokale Einstellungen)

    Komisch dass das sonst keinen stört!?? Aber zum Glück habe ich die Lösung schliesslich selber gefunden - und entgegen meinen Befürchtungen existiert sie sogar! ;-)

    1. Man kann das Ganze auf deutsch lassen. (Englisch hätte den lästigen Nebeneffekt dass dann auch Datum und vieles mehr gemäss Ami-Geschmack eingestellt würde...)

    2. Spracheinstellungen: "Dezimaltrennzeichen gemäss Gebietsschema" scheint der "Feind" von Punkten zu sein - also weg mit der Option!

    3. Die Sprache der Funktionsnamen kann tatsächlich auch umgeschalten werden, nur nicht unter "Spracheinstellungen"! (Dies der Grund warum ich das nicht gleich gefunden habe...). Man findet es unter "Calc" - "Formeln"

    4. Wenn man dort auch noch Funktions-Trennzeichen "Komma" (,) eingibt sehen sogar die Parameterlisten vernünftig aus (kein Semikolon mehr)

    5. Je nachdem muss man dann noch die Listen (Monatsnamen, Wochentage...) dem eigenen Geschmack anpassen

    Uff - da bin ich wirklich froh!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •