Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: hello and custom Font DPI

  1. #1

    Default hello and custom Font DPI

    Hi guys I've actually only been using openSuse for a few days now and I chose to install KDE as it is openSuse's default DE (although in the installer it assured me that all it's DE's were equally supported) to give it a whirl. I've already had Ubuntu (with Gnome) established as my system of choice for about a year maybe and am running it on another machine.

    I've already found openSuse's KDE to be a lot less glitchy than Ubuntu's implementation of it. In fact the only two glitches I've had yet were with the Network Manager. All in all I'm enjoying my openSuse experience so far.

    My question is this: How can I set a custom font DPI setting in KDE? I know where to force it to 96 or 120 but those are the only options given to me. I was looking for 72. I've done this in Gnome and was hoping I could do it in KDE as well.

    Thanks!

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: hello and custom Font DPI

    Hello and welcome to the forum

    For my desktop I had to manually force the DPI because otherwise the font is too small (nvidia driver). To change my DPI I edited /etc/X11/xorg.conf (the one that nvidia-xconfig created) and added under the Monitor section:
    Code:
    Option "DPI" "96 x 96"
    Simply change 96 to whatever DPI you want. I think you can use

    Code:
    Xorg -configure
    To generate an xorg.conf
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3

    Default Re: hello and custom Font DPI

    I ran

    sudo Xorg -configure

    and got this


    Fatal server error:
    Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.


    Please consult the The X.Org Foundation support
    at X.Org Wiki - Home
    for help.

  4. #4
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: hello and custom Font DPI

    OK log out and press control+alt+f1 to get to tty and log in as root. Then run:

    Code:
    /etc/init.d/xdm stop
    Xorg -configure
    Then edit xorg.conf and add DPI to monitor section from my post above

    Code:
    vi /etc/X11/xorg.conf
    Then start X again
    Code:
    /etc/init.d/xdm start
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  5. #5

    Default Re: hello and custom Font DPI

    Which section of the file am I supposed to add the Option line?

  6. #6

    Default Re: hello and custom Font DPI

    Oh oops nvmd I re-read your first post.

  7. #7

    Default Re: hello and custom Font DPI

    Ok plus it made my conf file as "/root/xorg.conf.new".

    I saved the "Option" line in that file but I don't see the option in the fonts thing yet

  8. #8

    Default Re: hello and custom Font DPI

    I went back and copied "/root/xorg.conf.new" to "/etc/X11/xorg.conf" and now xorg.conf actually exists in there but I still don't see the option in the font forcing menu

  9. #9
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: hello and custom Font DPI

    You are meant to modify the DPI line in xorg.conf to what you want your font DPI to be.
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  10. #10

    Default Re: hello and custom Font DPI

    So it's supposed to be an immediate change? Well nothing's happened yet. Was it supposed to be "72 x 72" or "72 * 72"? Cause I did the former

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •