Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Open Office maybe I have a Solution

  1. #1
    Join Date
    May 2009
    Location
    Australia
    Posts
    332

    Red face Open Office maybe I have a Solution

    Ever since 11.3 Open Office was performing "badly" to say the least. It loaded slow, with a few documents open "save-as" and selecting a different folder took up to a minute...and so on....

    Anyway I had the suspicion that there maybe not enough memory allocated. Nothing within the OO settings worked.

    Then I looked into yast=>/etc/sysconfig=>System=>Limits...
    found "HARDLOCKLIMIT" set to "@256"
    changed to "@512"......OK finished.

    Ran a test with 10 documents open

    a) startup was much faster
    b) saveas instantly
    c) pdf instantly
    d) selecting new folder instantly

    Preliminary conclusion : Java(sun) and OO needs more memory

    Please comment.

    Cheers Otto
    Desktop: CPU: AMD Ryzan 4 core, RAM: 32 GB, SSD 120 GB OS, SSD 480 GB Raid, HD 500 GB , OS: 15.1
    Laptop: Toshiba, AMD 4 core, 8 GB RAM, SSD 500 GB, OS 15.1
    Printer: Brother Color laser , Scanner Epson V370. Main application: Ardour, Jack

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Open Office maybe I have a Solution

    Is there any downside of doing this?

    Thanks
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3
    Join Date
    May 2009
    Location
    Australia
    Posts
    332

    Default Re: Open Office maybe I have a Solution

    Sofar no downside, early days.
    I increased the value to"@1024
    Upside everything else loads much faster. Did just another test with "Gimp" open, opened 12 documents in OO ...the speed increase is phenominal.

    Maybe the default limitation also explained a number of "screen freezes" which I attributed to running KDE 4.5.1 RC. I was always wondering that with 8GB Ram the system should run faster.

    I'll keep you posted
    Desktop: CPU: AMD Ryzan 4 core, RAM: 32 GB, SSD 120 GB OS, SSD 480 GB Raid, HD 500 GB , OS: 15.1
    Laptop: Toshiba, AMD 4 core, 8 GB RAM, SSD 500 GB, OS 15.1
    Printer: Brother Color laser , Scanner Epson V370. Main application: Ardour, Jack

  4. #4
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Open Office maybe I have a Solution

    I also have 8gb ram so maybe I should try this.

    Thanks for posting this how to
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,454

    Default Re: Open Office maybe I have a Solution

    I achieved a comparable result by getting rid of the KDE dialogues - so the hypothesis of a memory problem sounds reasonable.

  6. #6
    Will Honea NNTP User

    Default Re: Open Office maybe I have a Solution

    john hudson wrote:

    >
    > I achieved a comparable result by getting rid of the KDE dialogues - so
    > the hypothesis of a memory problem sounds reasonable.


    I switched to the oo native file dialog (in oo setup) and saw a substantial
    improvement in response time as well.

    --
    Will Honea

  7. #7
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Open Office maybe I have a Solution

    Something is odd here. The default value for HARDLOCKLIMIT in /etc/sysconfig/ulimit is 5% of the total memory. This would translate to @197000 as an absolute value for my system, starting with the total available memory as reported by top for my system (4GB RAM).

    Code:
    top - 12:40:18 up 14 min,  5 users,  load average: 0.00, 0.04, 0.07
    Tasks: 183 total,   2 running, 181 sleeping,   0 stopped,   0 zombie
    Cpu(s):  0.3%us,  0.6%sy,  0.0%ni, 99.0%id,  0.0%wa,  0.1%hi,  0.0%si,  0.0%st
    Mem:   3940008k total,   901400k used,  3038608k free,    47332k buffers
    Swap:  5141196k total,        0k used,  5141196k free,   597336k cached
    Is there someone having some insight how it works and what would be the optimum value?
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  8. #8

    Default Re: Open Office maybe I have a Solution

    Adjusting the HARDLOCKLIMIT did not improve the situation in my 1G memory system, but clearing the clipboard (Klipper) works untill the clipboard fills up again.

  9. #9
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,506

    Default Re: Open Office maybe I have a Solution

    Thanks for sharing.

    I have a 2MB & 4MB machines. Setting HARDLOCKLIMIT to 25 (%) has improved times when saving into different directories.

    Boxes seen more responsive and no negative effects noticed.

    Since updating to openSUSE11.3, memory usage does not exceed ~450KB unless a crash is imminent.

    Thanks again.

  10. #10
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: Open Office maybe I have a Solution

    Quote Originally Posted by otto_oz View Post
    Ever since 11.3 Open Office was performing "badly" to say the least. It loaded slow, with a few documents open "save-as" and selecting a different folder took up to a minute...and so on....

    Anyway I had the suspicion that there maybe not enough memory allocated. Nothing within the OO settings worked.

    Then I looked into yast=>/etc/sysconfig=>System=>Limits...
    found "HARDLOCKLIMIT" set to "@256"
    changed to "@512"......OK finished.
    Great! Thanks. I was looking for something like this.
    In my case, startup was fine, quite fast. But I experienced the terrible slowness in saveas dialogs you say. I've done what you did (in my case HARDLOCKLIMIT was set to @256 too). I have to test it more, but for now I'm not experiencing that boring slowness and also startup seems quite faster.
    Thanks again for posting this how to.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •