Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: I have video, but no audo.

  1. #1

    Unhappy I have video, but no audo.

    I have video, but no audio.

    git.alsa-project.org Git - alsa-driver.git/history - utils/alsa-info.sh

    nat@linux-w8b1:~> cd /tmp/alsa-info.txt.DDmWnhwn8M
    bash: cd: /tmp/alsa-info.txt.DDmWnhwn8M: Not a directory
    nat@linux-w8b1:~> rpm -qa '*alsa*'
    alsa-tools-gui-1.0.23-1.8.i586
    alsa-plugins-1.0.23-1.9.i586
    alsa-oss-1.0.17-29.2.i586
    alsa-1.0.23-2.12.i586
    pyalsa-1.0.22-1.8.i586
    alsa-tools-1.0.23-1.8.i586
    gmerlin-alsamixer-0.4.3-0.pm.4.1.i586
    gmerlin-alsa-0.4.3-0.pm.4.1.i586
    alsa-utils-1.0.23-1.8.i586
    alsa-plugins-pulse-1.0.23-1.9.i586
    alsa-firmware-1.0.23-1.2.noarch
    alsamixergui-0.9.0rc1-746.1.i586
    nat@linux-w8b1:~> rpm -qa '*pulse*'
    libpulse-browse0-0.9.21-10.1.1.i586
    pulseaudio-utils-0.9.21-10.1.1.i586
    pulseaudio-module-zeroconf-0.9.21-10.1.1.i586
    pulseaudio-0.9.21-10.1.1.i586
    pulseaudio-module-bluetooth-0.9.21-10.1.1.i586
    pulseaudio-module-x11-0.9.21-10.1.1.i586
    gmerlin-pulseaudio-0.4.3-0.pm.4.1.i586
    pulseaudio-esound-compat-0.9.21-10.1.1.i586
    libpulse0-0.9.21-10.1.1.i586
    pulseaudio-module-gconf-0.9.21-10.1.1.i586
    alsa-plugins-pulse-1.0.23-1.9.i586
    cmus-plugin-pulse-2.3.3-1.pm.2.1.i586
    pulseaudio-module-lirc-0.9.21-10.1.1.i586
    vlc-aout-pulse-1.1.4-4.12.i586
    libpulse-mainloop-glib0-0.9.21-10.1.1.i586
    nat@linux-w8b1:~> rpm -q libasound2
    libasound2-1.0.23-2.12.i586
    nat@linux-w8b1:~> uname -a
    Linux linux-w8b1 2.6.34.7-0.3-default #1 SMP 2010-09-20 15:27:38 +0200 i686 i686 i386 GNU/Linux
    nat@linux-w8b1:~> cat /etc/modprobe.d/50-sound.conf

    options snd slots=snd-emu10k1
    # 08OF.zmyCPdHleeA:SB Audigy
    alias snd-card-0 snd-emu10k1
    nat@linux-w8b1:~>


    Any suggestions/advice will be greatly appreciated!!!
    Last edited by nbahn; 30-Sep-2010 at 18:52. Reason: typo in title

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: I have video, but no audo.

    SDB:Audio troubleshooting - openSUSE

    Usually it's down to settings in the audio mixer found in your panel system tray. Not having the Master channel selected and or having it muted....
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    26,443
    Blog Entries
    34

    Default Re: I have video, but no audo.

    Quote Originally Posted by nbahn View Post
    Please try running the script again:
    Code:
    /usr/sbin/alsa-info.sh
    again! You posted the wrong URL. There are examples here with screen shots: Welcome to multimedia sub-area

  4. #4

    Unhappy Re: I have video, but no audo.

    I managed to generate this URL:

    http://www.alsa-project.org/db/?f=6c...3b01468bf057cf

    But I don't understand the output.

  5. #5
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    26,443
    Blog Entries
    34

    Default Re: I have video, but no audo.

    Quote Originally Posted by nbahn View Post
    I managed to generate this URL:

    http://www.alsa-project.org/db/?f=6c...3b01468bf057cf

    But I don't understand the output.
    It may not be useful for you, but for someone who is possibly thousands of miles away trying to understand why your sound is not working, its incredibly useful. It tells me you are running a 32-bit openSUSE-11.3 with the 2.6.34.7-0.3-default kernel on a Gateway E-6100 and it confirms that that the installed rpms that you noted were indeed installed. It tells me your PC has only the one sound card, an SB Audigy 2 with a SigmaTel STAC9721,23 hardware codec. And it tells me this about your mixer settings (plus lots of other information):

    Simple mixer control 'Audigy Analog/Digital Output Jack',0
    Capabilities: pswitch pswitch-joined penum
    Playback channels: Mono
    Mono: Playback [off]
    Simple mixer control 'External Amplifier',0
    Capabilities: pswitch pswitch-joined penum
    Playback channels: Mono
    Mono: Playback [on]
    Simple mixer control 'Sigmatel 4-Speaker Stereo',0
    Capabilities: pswitch pswitch-joined penum
    Playback channels: Mono
    Mono: Playback [off]
    For openSUSE-11.0, user Chrysantine provided this guide: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA and to a certain extent it is applicable to 11.3. In particular note your audigy is very sensitive to the Simple mixer control 'Audigy Analog/Digital Output Jack control.

    Also, when testing your audio, test it with only one multimedia application running at a time.

    When testing, do you get sound from any applications ?

    Try each of the following in a terminal, first as a regular user and then with root permissions:
    • first:
      Code:
       speaker-test -Dplug:front -c2 -l5 -twav
    • second, try again:
      Code:
      speaker-test -c2 -l5 -twav
    • third:
      Code:
      speaker-test -c2 -D hw:0,0 -t wav -l3
    • fourth, this next command has a volume meter at the bottom of its output with a changing number of #'s and %'s to show volume levels so run this command and tell me if the number of #'s and %'s are changing:
      Code:
      aplay -vv /usr/share/sounds/alsa/Front_*
    • fifth: and also:
      Code:
      aplay -vv /usr/share/sounds/alsa/test.wav
    Do any of those give an indication of sound ?

    Also try those with and without headphones.

    Note that typically only 1/2 of those will work with a functioning system. Whats important here is to find out if ANY of those yield sound.

  6. #6

    Default Re: I have video, but no audo.

    The aplay commands did show changing hash marks and percentage numbers; unfortunately, there was no sound from any of the commands (and the headphones plug into a jack in one of the speakers, so I saw no point in trying that).

  7. #7
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    26,443
    Blog Entries
    34

    Default Re: I have video, but no audo.

    Quote Originally Posted by nbahn View Post
    The aplay commands did show changing hash marks and percentage numbers; unfortunately, there was no sound from any of the commands (and the headphones plug into a jack in one of the speakers, so I saw no point in trying that).
    You did not advise if you tuned your mixer like I suggested. I can only assume you did not, and that could explain why sound is not working for you.

  8. #8
    Join Date
    May 2009
    Location
    Australia
    Posts
    310

    Default Re: I have video, but no audo.

    I had similar problems when trying to channel the audio to my TV for watching DVDs.
    Solved it via the "KDE" Personal Settings (configure desktop).
    Under "Multimedia" select "phonon" and see what channels are set, you can test the outputs . (this is NOT in yast).
    If you have a separate video card , as in my case, you most likely find the solution here. Also as mentioned above, ensure in your mixer that the video-card outputs are enabled.


    cheers
    Desktop: CPU: AMD Ryzan 4 core, RAM: 16 GB, SSD 250 GB , OS. openSuseLeap 15.0
    Printer: Brother Color laser , Scanner Epson V370. Main application: Ardour, Jack

  9. #9

    Default Re: I have video, but no audo.

    Quote Originally Posted by oldcpu View Post
    You did not advise if you tuned your mixer like I suggested. I can only assume you did not, and that could explain why sound is not working for you.
    I have gone to both:
    *Computer->YaST2 Control Center -> Sound &
    *Computer->Control Center -> Sound

    I have been unable to locate "Simple mixer control 'Audigy Analog/Digital Output Jack control"

  10. #10
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    26,443
    Blog Entries
    34

    Default Re: I have video, but no audo.

    Quote Originally Posted by nbahn View Post
    I have gone to both:
    *Computer->YaST2 Control Center -> Sound &
    *Computer->Control Center -> Sound

    I have been unable to locate "Simple mixer control 'Audigy Analog/Digital Output Jack control"
    That control is in your mixer. Take a look at your mixer.

    If you are using KDE you can add extra controls to the mixer via the mixer's menu.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •