Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: OpenSuse 11.2: Unable to upgrade to digikam 1.4

  1. #1

    Default OpenSuse 11.2: Unable to upgrade to digikam 1.4

    Here's the history of the problem:

    Nov 2009
    - installed OpenSuse 11.2/64bit /w digikam 0.10.x

    Feb 2010
    - found out that digikam 0.10.x can't display RAW files from my Canon EOS 7D
    - upgraded to 1.0.0 from some community repo -> problem solved

    Sep 2010
    - errors in thumbnail generation: newly generated thumbnail occasionally "spreads" to other images in the same folder
    - attempt to upgrade to digikam 1.4.x fails
    - going back to 1.0.0 turns out to be impossible because it's not offered in any repo anymore
    - now stuck with 0.10.x again (see above)

    Some background concerning the upgrade failure:

    1.4.x is offered in repo KDE:Backports. It installs without complaining but crashes upon start (crash always occurs when "read database" is displayed).

    It's also offered in several other repos, but trying to install it from there triggers a lot of dependency conflicts in yast. These conflicts seem to hint at KDE needing to be upgraded. So, I went to kde.org and found that they even offer a *.ymp package for OpenSuse 11.2 to upgrade KDE to the latest version. But, trying to apply this again triggers tons of dependency conflicts and I have a feeling that I'm in danger of messing up my hole system if I proceed any further from there.

    So, what's going on here?
    - Am I missing something easy?
    - Could it be that it's *impossible* to upgrade to digikam 1.4 in OpenSuse 11.2?
    - Did I do something harmful by upgrading from 0.10.x to 1.0.0 in February?

    Thanks a lot!
    Frank

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: OpenSuse 11.2: Unable to upgrade to digikam 1.4

    Maybe try from a different repo. What about KDE:UpdatedApps?

    Here is one click
    http://software.opensuse.org/ymp/KDE...&query=digikam
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3

    Default Re: OpenSuse 11.2: Unable to upgrade to digikam 1.4

    @ah7013: Thanks, but it doesn't work. Same behaviour as when using KDE:Backports (smooth install, but crash upon start)

  4. #4
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: OpenSuse 11.2: Unable to upgrade to digikam 1.4

    Maybe the 0.10 database is not compatible with digikam 1.4?
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  5. #5
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: OpenSuse 11.2: Unable to upgrade to digikam 1.4

    Also maybe you could try digikam 1.2:

    http://software.opensuse.org/ymp/KDE...&query=digikam
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  6. #6

    Default Re: OpenSuse 11.2: Unable to upgrade to digikam 1.4

    @ah7013: negative again: I opened digikam 0.10 to see what the path to the database files would be, then renamed that directory, then installed 1.4 and launched it. It askes me for my collections (no database file to be found, obviously). I click "Cancel", program crashes like before.

    Now I'll try your 1.2 suggestion...

  7. #7
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: OpenSuse 11.2: Unable to upgrade to digikam 1.4

    I'll create an openSUSE 11.2 Virtual Machine and install digikam 1.4 and see if I get the same problem. Just going to download 11.2 now
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  8. #8

    Default Re: OpenSuse 11.2: Unable to upgrade to digikam 1.4

    @ah7013: the 1.2 rpm gets me dependency conflicts again, although considerably fewer than 1.4 (7 as opposed to 50+). However, these conflicts grow in number, once you follow the suggestions offered (most of which require a provider change (??, "Anbieterwechsel" in German)).

  9. #9

    Default Re: OpenSuse 11.2: Unable to upgrade to digikam 1.4

    Quote Originally Posted by ah7013 View Post
    I'll create an openSUSE 11.2 Virtual Machine and install digikam 1.4 and see if I get the same problem. Just going to download 11.2 now
    are you serious? oh, now i get it, you're a digikam sales person!

    But seriously, if your attempt turns out to be successful, that would add a lot of weight to my last question in my original post, no?

  10. #10
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: OpenSuse 11.2: Unable to upgrade to digikam 1.4

    Quote Originally Posted by FrankHere View Post
    are you serious? oh, now i get it, you're a digikam sales person!

    But seriously, if your attempt turns out to be successful, that would add a lot of weight to my last question in my original post, no?
    Yes I'm the digikam sales person lol

    Just finished install of 11.2 going to download digikam 1.4 now. Welcome to the forums BTW.
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •