Results 1 to 8 of 8

Thread: Unable to launch Xfce

  1. #1
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Unable to launch Xfce

    Normally I install Xfce during installation time, but
    I deceided to try and add it to a machine 'after the fact.'
    This is on an OS11.2 machine with KDE as the primary DE.

    When I select Xfce as the session I am receiving an error about:
    'Unable to load failsafe session.'

    xconfd is not running (D-Bus problem) or environment variable
    $XDG_CONFIG_DIRS is missing /etc or xcfe-session is not installed.

    Before I go investing time to sort this out, is there a simple
    fix that people have used to correct the problem.



  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Unable to launch Xfce

    Normally I install Xfce during installation time, but
    I deceided to try and add it to a machine 'after the fact.'
    This is on an OS11.2 machine with KDE as the primary DE.
    So just how did you install XFCE GofBorg? Normally I install from the openSUSE DVD, which gives me lots of choices. If I wanted to install after the fact, I would open up YaST / Software Management. I would select the View Button on the top left and pick Patterns. Next, I would select XFCE Desktop Environment. This is how I loaded it the very first time and it work just fine. So, how did you do it?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: Unable to launch Xfce

    >> Normally I install Xfce during installation time, but
    >> I deceided to try and add it to a machine 'after the fact.'
    >> This is on an OS11.2 machine with KDE as the primary DE.So just how did
    >> you install XFCE GofBorg? Normally I install from the

    > openSUSE DVD, which gives me lots of choices. If I wanted to install
    > after the fact, I would open up YaST / Software Management. I would
    > select the View Button on the top left and pick Patterns. Next, I would
    > select XFCE Desktop Environment. This is how I loaded it the very first
    > time and it work just fine. So, how did you do it?


    Same.



  4. #4
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: Unable to launch Xfce

    > Same.

    Actually I take that back. I did a search on Xfce and checked xfce desktop
    environment or something like that. Apparently that method doesn't get you
    everything because I tried your method and it is installing more stuff.
    Will let you know if it fixes it up. Thx.



  5. #5
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,442

    Default Re: Unable to launch Xfce

    > Actually I take that back. I did a search on Xfce and checked xfce
    > desktop
    > environment or something like that. Apparently that method doesn't get
    > you everything because I tried your method and it is installing more
    > stuff.
    > Will let you know if it fixes it up. Thx.


    Yep. That fixed it. Thx!

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Unable to launch Xfce

    GofBorg > Actually I take that back. I did a search on Xfce and checked xfce
    > desktop
    > environment or something like that. Apparently that method doesn't get
    > you everything because I tried your method and it is installing more
    > stuff.
    > Will let you know if it fixes it up. Thx.


    Yep. That fixed it. Thx!
    Happy to help GofBorg. The Patterns installation option is not the same and manually selecting packages to be installed and must be used for desktops. In general, if you did not load a set of programs, and a pattern exists for this as a group, you will be well served by installing it based on its pattern. Trust me on this as I have wasted much time trying to do this the hard way which almost never works right, as shown by your example here.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7

    Default Re: Unable to launch Xfce

    I had a similar problem, and this solution worked for me too.

    My problem:

    1. Install OpenSuse 11.3 (KDE) from Live disk
    2. Running XMing to connect to OpenSuse from Windows 7
    3. Create KDE session in XMing. It worked, but was just *hopelessly* slow over a wireless network.
    4. Create xfce session in XMing, with command "xfce4-session".
    5. Didn't work because xfce not installed
    6. Install xfce4-session package, etc, from YaST (packages, not patterns).
    7. Xming still didn't work,with the error in the OP ("Unable to load failsafe session.'
    xconfd is not running (D-Bus problem)...")
    8. Installed xfce pattern as described in the solution (and didn't need to remove anything first)
    9. XMing XFCE worked!!!
    10.. And, it works really nicely. I've got a smooth X Session running in Win7 over a wireless net

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to launch Xfce

    On 2012-06-19 10:16, javaman59 wrote:
    > 1. Install OpenSuse 11.3 (KDE) from Live disk


    11.3 is obsolete and has no updates.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •