Results 1 to 10 of 10

Thread: Undesired window maximize on move (KDE 4.4.4)

  1. #1

    Default Undesired window maximize on move (KDE 4.4.4)

    After installing SuSE 11.3 with KDE 4.4.4 "release 2", if find the following
    rather annoying behavior:

    After dragging a window by its titlebar along the top edge of the screen
    and releasing it, in invariably maximizes. Dragging the same window below
    the edge and then moving it vertically up, it stays as is (and as desired).

    Found no related settings in "system setup - window behavior".

    Any help?

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Undesired window maximize on move (KDE 4.4.4)

    Its under Settings->Window Behavior->Screen Edges for KDE 4.5 and uncheck the two checkboxes under Window Management. Not sure if its the same in KDE 4.4. If its not in 4.4 i'll create a openSUSE virtual machine with KDE 4.4 and figure it out on there
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3

    Default Re: Undesired window maximize on move (KDE 4.4.4)

    Quote Originally Posted by ah7013 View Post
    Its under Settings->Window Behavior->Screen Edges for KDE 4.5 and uncheck the two checkboxes under Window Management. Not sure if its the same in KDE 4.4. If its not in 4.4 i'll create a openSUSE virtual machine with KDE 4.4 and figure it out on there
    Thanks, in the system settings window I find

    Window Behavior -> Focu, TitlebarActions, WindowAction, Moving,Advanced

    but no Screen Edges and seemingly no useful settings in the other tabs.

  4. #4
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Undesired window maximize on move (KDE 4.4.4)

    Ok just give me about 15 minutes to install a openSUSE 11.3 VM with KDE 4.4 and i'll come back to you
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  5. #5
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Undesired window maximize on move (KDE 4.4.4)

    OK I found it! On my 11.3 VM with KDE 4.4 Its under Settings->Desktop->Screen Edges. Then untick the box which says "Maximize windows by dragging them to the top of the screen". you may be also interested in unticking "Tile windows by dragging them to the side of the screen". Then click apply
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  6. #6

    Default Re: Undesired window maximize on move (KDE 4.4.4)

    Thanks, worked.

    Sorry for not hunting through the settings myself - thought it's a bug, didn't think its a feature ;-)

  7. #7
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Undesired window maximize on move (KDE 4.4.4)

    Glad to hear it worked.
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  8. #8
    Join Date
    Dec 2008
    Location
    Montana, USA
    Posts
    550

    Default Re: Undesired window maximize on move (KDE 4.4.4)

    Ha ha ha ha! I also thought it was just a nuisance thing, one of those things that just happened once in a while.

    Thanks ah7013! One more minor annoyance eliminated! I wish I had the time to just go through all the settings but there are just so many of them! And. I'd miss the opportunity to pass along a pat on the back!

    Bart

  9. #9

    Default Re: Undesired window maximize on move (KDE 4.4.4)

    I see how this behavior could be useful, but how incredibly non-intuitive as a default... to have windows magically behave differently because you happen to set them down on a part of the screen which isn't visually differentiated in any way from the rest of the screen (i.e. not a separate panel or anything).

    Thanks so much for the tips for how to disable, and even more so, to preserve my sanity by confirming that this isn't caused by some bug or misconfiguration.

  10. #10

    Default Re: Undesired window maximize on move (KDE 4.4.4)

    They Moved it Again: Now Menu -> DesktopSettings -> Workspace Behavior -> Screen-Edges

    Untick both the boxes under "Window Management" to stop this nonsense.

    One can always double-click a titlebar to maximize a window, so this is nothing but a pointless "look what I can do" (think "Stuart" on MadTV) "feature" by those who might work on bugs and optimizing code to take less CPU and RAM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •