Results 1 to 7 of 7

Thread: Lost fonts after installing NVIDIA driver

  1. #1

    Default Lost fonts after installing NVIDIA driver

    I have installed SUSE 11.3 and I am using KDE4. I also installed the font "misc-console".

    After installing the NVIDIA driver 256.53 the font misc-console becomes useless because it is displayed so much slanted that it is imposible to read. However, if I disable the NVIDIA driver (by replacing "nvidia" with "nv" in xorg.conf), then it works fine. It also works fine in KDE3 and the NVIDIA driver. So, it seems to be a combination between NVIDIA and KDE4. A lot other fonts are also overly slanted and unreadable (like "Sony fixed", "misc fixed", etc.).

    If I launch konsole from a terminal, I receive the following warning:

    konsole(6928) Konsole::TerminalDisplay::setVTFont: Using an unsupported variable-width font in the terminal. This may produce display errors.

    Is there a way that I can use "misc-console" without having to uninstall the NVIDIA driver? I'm just used to this font for my terminal.

    The same happens whether I install the driver manually or through YAST, 32 or 64 bit.
    The video card is NVIDIA 8400GS, the system Athlon 64 4400+

    Thanks a lot!

  2. #2
    Join Date
    Nov 2009
    Location
    Mnchen
    Posts
    295

    Default AW: Lost fonts after installing NVIDIA driver

    Did you tried to change DPI?

  3. #3

    Default Re: Lost fonts after installing NVIDIA driver

    Yes, but it doesn't help.

  4. #4

    Default Re: Lost fonts after installing NVIDIA driver

    Has nobody else had the same problem? I doubt I'm the only SUSE KDE4 user with an NVIDIA videocard. It seems that with the NVIDIA driver installed less fonts are available in KDE4.

    I would appreciate any input or sharing experiences in this topic.

    Thanks!

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Lost fonts after installing NVIDIA driver

    But maybe you are the only one using misc-console. Maybe try another font?

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Lost fonts after installing NVIDIA driver

    So far, I have not had a font change due to loading a new version of the nVidia driver or because I updated my kernel, which also requires reloading my nVidia driver. I use the KDE desktop and I do change my default font as well, but to the Segoe UI font, taken straight from my old Windows Vista load. I run it at 120 DPI as I like living and looking large as they say (on my monitor, not me ). In any event I would agree with gogalthorp and his suggestion that the fault might be with the misc-console font. It would sure be worth a try to switch to something else just to see if that is the problem.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7

    Default Re: Lost fonts after installing NVIDIA driver

    The problem occurs alxo with other fonts, like misc-fixed. Monospace and nimbus mono L work. The problem does not occur if I use the konsole from KDE3. So, it's related to KDE4-Konsole. So, for the first few days I used KDE3-konsole in KDE4 and now I have started using KDE3, which works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •