Results 1 to 5 of 5

Thread: 11.3 & OpenOffice

  1. #1
    Join Date
    Jul 2010
    Location
    Cape Town
    Posts
    67

    Default 11.3 & OpenOffice

    I have just installed 11.3, 3.2.1.4-1.2-i586 rpm openSUSE-11.3-1.82. OpenOffice, which I use a frequently came up with an error message - "JRE is Defective".

    "OpenOffice.org requires a Java routine environment (JRE) to perform this task.The selected JRE is defective. Please select another version or install another JRE and select it under Tools-Open Office.org-JRE". Clicking the "OK" on the third or fourth try brought up a spreadsheet.

    I checked the installed version and found it identical to OpenOffice.org latest version: 3.2.1.4. I then reinstalled and now it goes through the loading process and flashes a blank page, presumably the function selection screen without any prior warning.

    I use a 32 bit PC with 512k RAM. When I loaded 11.2 I received a warning message that some applications might not work, but I went ahead and found no problems with any of the applications that I use. Installing 11.3, no warning was given.

    I have gone through the posts and found only one similar where it would not load on a system with Gnome.

  2. #2
    Join Date
    Jul 2010
    Location
    Cape Town
    Posts
    67

    Default Re: 11.3 & OpenOffice

    Have just found error log in Documents. Note the query re swap space - I have 776GB allocated. Here are the comments without the complete dump:

    # A fatal error has been detected by the Java Runtime Environment:
    #
    # java.lang.OutOfMemoryError: requested 32756 bytes for ChunkPool::allocate. Out of swap space?
    #
    # Internal Error (allocation.cpp:117), pid=10430, tid=3031410384
    # Error: ChunkPool::allocate
    #
    # JRE version: 6.0_17-b17
    # Java VM: OpenJDK Client VM (14.0-b16 mixed mode linux-x86 )
    # Derivative: IcedTea6 1.7.3
    # Distribution: Custom build (Mon Jul 5 23:35:28 UTC 2010)
    # If you would like to submit a bug report, please include
    # instructions how to reproduce the bug and visit:
    # Bugzilla Main Page
    #

    --------------- T H R E A D ---------------

    Current thread (0x086f3400): JavaThread "Unknown thread" [_thread_in_vm, id=10430, stack(0xbfb41000,0xbfb91000)]

    Stack: [0xbfb41000,0xbfb91000]

    --------------- S Y S T E M ---------------

    OSpenSUSE 11.3 (i586)
    VERSION = 11.3

    uname:Linux 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 i686
    libc:glibc 2.11.2 NPTL 2.11.2
    rlimit: STACK 8192k, CORE 0k, NPROC 1874, NOFILE 8192, AS 836960k
    load average:1.45 1.04 0.55

    CPU:total 1 (1 cores per cpu, 1 threads per core) family 15 model 1 stepping 2, cmov, cx8, fxsr, mmx, sse, sse2

    Memory: 4k page, physical 251508k(4096k free), swap 794620k(718472k free)

    vm_info: OpenJDK Client VM (14.0-b16) for linux-x86 JRE (1.6.0_17-b17), built on Jul 5 2010 23:53:02 by "abuild" with gcc 4.5.0 20100604 [gcc-4_5-branch revision 160292]

    time: Thu Sep 23 11:16:26 2010

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,788
    Blog Entries
    14

    Default Re: 11.3 & OpenOffice

    If you take a look at the system requirements for 11.3, you'll see that 512K is below limits. What you see now IME is a memory problem.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: 11.3 & OpenOffice

    Knurpht wrote:

    >
    > If you take a look at the system requirements for 11.3, you'll see that
    > 512K is below limits. What you see now IME is a memory problem.
    >
    >

    I guess this should read 512M and it is enough fotr opensuse 11.3 with
    kde/gnome, I tested both on an old machine and it works well including
    office software, burning, multimedia ...
    So this is most likely not the real problem.

    The exception from java I can see is
    # java.lang.OutOfMemoryError: requested 32756 bytes for

    But java does not use the available physical ram/swap but is limited to what
    is defined in the -Xmx parameter with which the jvm is started.

    Either this is set too low or more likely this is set to such a high value
    that the start of the jvm notices that the given amount of requested memory
    can never be allocated.


    --
    openSUSE 11.2 64 bit | Intel Core2 Quad Q8300@2.50GHz | Gnome 2.28 | GeForce
    9600 GT | 4GB Ram
    openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | Gnome 2.30 | Quadro
    FX 3600M | 4GB Ram


  5. #5
    Carlos E. R. NNTP User

    Default Re: 11.3 & OpenOffice

    On 09/23/2010 03:36 PM, johnmidl wrote:
    >
    > Have just found error log in Documents. Note the query re swap space - I
    > have 776GB allocated. Here are the comments without the complete dump:


    776 GB? No way.


    > Memory: 4k page, physical 251508k(4096k free), swap 794620k(718472k
    > free)


    That is about 250 MB ram and about 800MB swap. Both values are very low. Add more ram if you can, or
    at least, add more swap, to about 2 GB at least.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •