Results 1 to 6 of 6

Thread: Can't change default GUI (rather don't know how)

  1. #1

    Unhappy Can't change default GUI (rather don't know how)

    Hey all,

    So I just switched from KDE to Gnome and after a successful install upon logout I went to the panel that allows one to choose an application (KDE, Gnome, Windowmaker etc).

    Gnome worked like a dream.

    "I don't remember installing any other applications," I says to myself "Why would they be listed there? I'll try booting into one of them."

    At random I chose a new xWindow and hit enter... blackness.

    So like any linux user I created /etc/sysconfig/desktop with DESKTOP="GNOME" and DISPLAYMANAGER="GNOME" parameters to force my hand back into Gnome.

    No dice. Where to next?
    -Wiggy
    Last edited by wigs; 22-Sep-2010 at 12:34. Reason: adding tags

  2. #2

    Default Re: Can't change default GUI (rather don't know how)

    Ctrl + Shift + F* commands allow me to switch freely to command line and back. So if anyone could tell me the command to specify gnome on startx I think this would be an easy fix.

    Thanks

  3. #3
    Join Date
    Jan 2009
    Location
    43.009 N, 73.172 W
    Posts
    189

    Default Re: Can't change default GUI (rather don't know how)

    Reboot, and at the login screen, before logging in, choose the desktop you want from the menu at the bottom of the screen.

  4. #4

    Default Re: Can't change default GUI (rather don't know how)

    udaman if only it were that simple!!

    Well actually it was, but just in a different direction.
    The problem with your suggestion is it never gave me that login screen: just blackness.

    Solution: login via failsafe then use xinit gnome to specify x as gnome. Now, I have the option of retracing my steps to the login screen and adjusting the applications to my hearts content.

    Thanks for your response.

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,472
    Blog Entries
    14

    Default Re: Can't change default GUI (rather don't know how)

    In fact, there is no "default" GUI. X will start the last used desktop environment, unless told otherwise by user's choice in the login screen.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Jan 2009
    Location
    43.009 N, 73.172 W
    Posts
    189

    Default Re: Can't change default GUI (rather don't know how)

    Check that the file /etc/inittab has
    Code:
    # The default runlevel is defined here
    id:5:initdefault:
    You might be booting to run level 3, which is the command line, run level 5 is the GUI login.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •