Results 1 to 5 of 5

Thread: Can't install Matlab

  1. #1

    Default Can't install Matlab

    Hi, I'm trying to install Matlab r2010b, this is what I typed and this is the error I get:

    andres@linux-58ak:~> /home/andres/matu20Xb_iso/install &
    [1] 4833
    andres@linux-58ak:~> Preparing installation files ...
    Installing ...
    /home/andres/matu20Xb_iso/install: line 562: /tmp/mathworks_4833/java/jre/glnx86/jre/bin/java: cannot execute binary file
    Finished

    [1]+ Done /home/andres/matu20Xb_iso/install
    andres@linux-58ak:~>

    In the past I could install r2010a and made it this way, now, I don't know what it is.
    Please, need some help!!!

  2. #2

    Default Re: Can't install Matlab

    Hmm.. Are you sure Java is installed? I'm running MATLAB 2010a without problem.

  3. #3

    Default Re: Can't install Matlab

    Quote Originally Posted by Spyhawk View Post
    Hmm.. Are you sure Java is installed? I'm running MATLAB 2010a without problem.
    How do I check that?

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,107
    Blog Entries
    2

    Default Re: Can't install Matlab

    Howdy,
    You can use YAST to install an approved JRE (Java Runtime Environment), do not select any of the "dev" versions and depending on the requirements of your application should either be v1.5 or v1.6.

    It looks like the install script first copied its own version of Java but didn't modify the permissions properly to make it executable.

    HTH...

  5. #5

    Default Re: Can't install Matlab

    Hi I'm running opensuse 11.4 and I'm trying to install matlab r2010b but I'm taking the same error as aussa:

    kostis@linux-3pn0:~/virtual-drives/1> ./install &
    [1] 10076
    kostis@linux-3pn0:~/virtual-drives/1> Preparing installation files ...
    Installing ...
    ./install: line 562: /tmp/mathworks_10076/java/jre/glnx86/jre/bin/java: cannot execute binary file
    Finished


    I have java environment installed

    kostis@linux-3pn0:~/virtual-drives/1> java -version
    java version "1.6.0_20"
    OpenJDK Runtime Environment (IcedTea6 1.9.7) (suse-1.2.1-i386)
    OpenJDK Server VM (build 19.0-b09, mixed mode)


    Can you please give me any info on how to solve it?
    Thanks in advance

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •